1. Tarka L's Avatar
    I have a problem with my Nexus 7 (self inflicted) and the bottom line is that I need to retrieve some files (.txt) that are on the device but I can't get it to boot. I basically rooted the device and everything was running perfectly until I accidentally clicked to update the OS. Now when I try to switch the device on it just goes to the new 4 coloured globes loading screen and stays there indefinitely. Unfortunately when I plug the device into my computer it isn't recognised so I can't access the files on the device. I am able to get the device into recovery mode so I can perform a factory reset but before I do that I really need to get some files off the device that I was working on. Is there ANY way that I am able to access the files on the device to retrieve them in its current state? I don't seem to be having any luck in getting the device to show up on the computer even in recovery mode. If you need any additional info don't hesitate to ask.
    02-15-2014 03:31 PM
  2. zkSharks's Avatar
    If you use fastboot to flash a custom recovery (if you don't currently have one flashed or something isn't working right), you can then pull data from it using ADB commands. You'll likely only be able to do this if USB debugging has already been enabled. The ADB command would be something like this:

    adb pull / c:\Android\
    That will pull the contents of your device, sans 'special files', and place them in the c:\Android\ directory. Be aware it may take some time if there is much data to be transferred. Now, as far as getting your tablet running again, it sounds like it's stuck in a fairly standard bootloop. See the following:

    02-15-2014 04:42 PM
  3. Tarka L's Avatar
    USB debugging was already setup and when I put the device into recovery mode and run:
    adb devices
    I get the following response:
    List of devices attached
    015d4a824467fc16         recovery
    When I run the adb pull command I get three directories; cache, sys and tmp. Each has a bunch of subdirectories but the sdcard directory that holds all my work files seems not to exist. I have tried a few options like mounting the /sdcard but as yet with no success. When I run the pull command I seem to get a large number of 'Skipping special file' messages. not sure if my files are being included in these special files and whether its possible to force pull all files?
    02-16-2014 01:42 PM

Similar Threads

  1. Replies: 2
    Last Post: 05-21-2014, 10:09 PM
  2. iTunes playlist not showing up in Kies 3?
    By Tom Metcalf in forum General Help and How To
    Replies: 1
    Last Post: 03-24-2014, 09:10 PM
  3. Note 2 can't delete file from myfiles
    By Salah Eddine Khadroub in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 02-19-2014, 11:06 AM
  4. [APP][2.2+] SMS Todo: build todo lists from sms
    By smstodoapp smstodoapp in forum Android Apps
    Replies: 0
    Last Post: 02-15-2014, 03:10 PM
  5. altered setting in contacts list please help
    By yakfire in forum Samsung Galaxy S4 Mini
    Replies: 0
    Last Post: 02-15-2014, 01:42 PM