1. Michael Riely's Avatar
    Hello. After buying two Nexus 7s already from Argos's ebay site which had bad faults, i decided to buy one brand new and had to travel quite far to pick the LAST one in store up. When i got home and tried to boot it. I got nothing, so i plugged it in a seen what looked like a faint flash of glitchy lines appear very fast, followed by the screen appearing to have a dim glow. No battery Icon. Assuming it was a very low charge. I waited an hour - same results. Hooked to USB via PC - same result . So i kept it on charge a while and notice it gets warm at the rear as it would only when fired up. It is clearly firing up but not showing anything on screen.

    Any ideas or am i now to forget Nexus and forget tablets all together because i have had 3 months of nothing but problems with them. I have tried all combined button modes. All they do is make the screen switch from a dim glow to plain off and back on again. Is this a Dead Nexus or what?

    Thank's.
    09-17-2014 03:49 PM
  2. Michael Riely's Avatar
    Quick Update:

    After almost 4 hours trying every type of online fix with no results. I unplugged the micro USB via the nexus itself, then blew hard into the socket of the nexus and the socket on the cable and plugged back in and the battery logo appeared as normal and started to charge. I have NOT as yet booted it up as i want the battery to gain far more life before i stride any further.

    WHAT a bug!!

    I will Update this post with the results shortly. Any tips or advice will still be appreciated

    Thank's..
    09-17-2014 04:25 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! That was a good idea--debris in the charging port can certainly interfere with normal charging or data connection. Are you sure the device is brand new and not refurbished?
    09-17-2014 08:52 PM
  4. Michael Riely's Avatar
    Thank you

    Brand spanking new! I had two refurbished devices that was fine except in one the speaker blew after one hour using it. The other executed commends without touching it. Thus i bought one brand new sealed, never touched. The battery was totally dead. I can only assume these people simply do not test these devices before packaging them for sale. I could not even update Android until it was fully charged. Now i find out that it can not let me hook a USB stick to it without it being hacked or some other crap! I am thinking of sending this back, too. Maybe an ipad?

    Thank's for the reply
    09-19-2014 01:02 AM
  5. B. Diddy's Avatar
    The 2012 Nexus 7 is pretty old, so if you truly got a brand new unit in a sealed box, it's possible that it's been sitting around for a long time. Most batteries are charged up a decent amount before the device is boxed, so that the consumer can start using it striaght out of the box--but this assumes that it was purchased within maybe a month or so of its packaging. Yours may have been lying around for many months to over a year. The other thing is that it can be very easy to seal a package, so a used device could be made to look brand new and untouched.

    The 2012 Nexus 7 can connect to a USB drive, but as you alluded to, it requires rooting and Stickmount: How to Use a USB Drive with the Nexus 7
    09-19-2014 02:30 AM

Similar Threads

  1. Replies: 4
    Last Post: 09-24-2014, 12:52 PM
  2. Replies: 1
    Last Post: 09-17-2014, 01:47 PM
  3. My Google account disappered from Nexus 4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 12:25 PM
  4. nexus s4 problems
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 12:19 PM
  5. nexus s4 problems
    By Teclar Masimba in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 05:41 AM
LINK TO POST COPIED TO CLIPBOARD