1. AC Question's Avatar
    I have tried holding the power button for 30 + seconds. Iv'e tried plugging it in and holding the power and volume down button at the same time. I have taken the back off and made sure the battery connector was all the way in, and even unplugged the battery and let it sit for a couple of minutes and plugged it back in and still nothing. I even made sure I was using the factory tablet charger and not just any cell phone charger. These steps worked before but not this time. Is there anything else that I can try to get it to charge and power on? I would really appreciate any help you could give me.
    09-01-2015 06:43 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! It could be a dead battery, or possibly a dead motherboard. You could try replacing the battery on your own, but you'd probably need a technician to check on the motherboard.
    09-02-2015 02:25 AM
  3. ohmslaw's Avatar
    Have you tried a different cable ?
    09-02-2015 12:09 PM
  4. tcat57's Avatar
    Have had to replace the charger/usb port on my 7. If contact is lost in that port due to wear it won't charge and if no charge, it will run down dead and won't respond to the on/off switch - your symptoms.
    09-05-2015 09:49 PM

Similar Threads

  1. Replies: 2
    Last Post: 05-22-2016, 11:57 PM
  2. S5 Reset on its own
    By aros1701 in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 09-04-2015, 12:12 PM
  3. Why is old mail remaining on my phone when deleted from server?
    By Jim Peyton in forum Android 5.0 Lollipop
    Replies: 3
    Last Post: 09-01-2015, 08:31 PM
  4. Replies: 0
    Last Post: 09-01-2015, 06:23 PM
  5. external sd card read/write functions on Kit Kat
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-01-2015, 06:21 PM
LINK TO POST COPIED TO CLIPBOARD