1. bushybr0ws's Avatar
    Hey, so I'm really panicking right now.

    I tried to follow the tutorial on New Nexus 7: How to Root, Unlock Bootloader and Install Recovery - International Business Times this page to root my new nexus 7 that I purchased like a week ago. Everything was going fine. I unlocked the bootloader according to the tutorial. I installed the TWRP version, and that seemed to be going fine. I tried rebooting the device into normal mode through TWRP so I could put the Update SuperSU 1.43 onto the device storage, and this is where I started having issues. When rebooting through TWRP the device said "Hey wait we noticed you aren't rooted. Would you like to install supersu?" I said sure, thinking it could download it for me. I think it tried to "flash" (not sure what that means) supersu onto the device even though it isn't on its storage. Now I'm stuck in a booting loop (the rainbow x of death). I can go into the fastboot menu and access TWRP fine (recovery option) but it keeps asking me for a password that I didn't create. I can get to the bootloader.

    From my computer I can use the fastboot command and it sees my device, but not adb. I can't access the internal storage of the device using file explorer. I open up devices and printers (I'm on a windows) and it shows my nexus, and I troubleshoot, it says there's a driver issue, and I can't do the fix because I don't have USB 2.0 or something. I set up the same thing on my roomate's computer but I can't get to the filesystem through his windows machine either.

    I don't know what to do. I don't even really care if it's rooted at this point, but I want the device to work. I used "fix permissions" successfully from TWRP, and I don't know if that did anything.

    What do I need to do to get this device working again? I will be active in this post. Please help me. I'm really stressed out. I can't afford a new one of these...
    09-08-2013 08:21 PM
  2. bushybr0ws's Avatar
    Oh, I should mention that in my Android SDK thing that the tutorial had me set up I did install the google driver as well as the platform tools that it asked me to. I checked several sites to see if they were saying the same instructions. I thought I was being pretty careful.
    09-08-2013 08:22 PM
  3. josiahlikesminecraft's Avatar
    You r going to have to do a factory reset. You will lose everything though.

    Posted via Samsung S3
    09-08-2013 08:24 PM
  4. bushybr0ws's Avatar
    How do I do a factory reset? There's the factory reset option from TWRP, and it fails.
    09-08-2013 08:27 PM
  5. josiahlikesminecraft's Avatar
    U will have to do it with your computer. Just Google it.

    Posted via Samsung S3
    09-08-2013 08:28 PM
  6. bushybr0ws's Avatar
    Somehow I can see my device using the adb command in the command prompt window. Can/should I "push" the supersu zip to the device? Would that help?
    09-08-2013 08:32 PM
  7. josiahlikesminecraft's Avatar
    No it wouldn't help.

    Posted via Samsung S3
    09-08-2013 08:33 PM
  8. josiahlikesminecraft's Avatar

    Follow this guide.

    Posted via Samsung S3
    09-08-2013 08:34 PM
  9. josiahlikesminecraft's Avatar
    09-08-2013 08:44 PM
  10. bushybr0ws's Avatar
    I've started using this guide The Definitive Guide on How to Restore Your Nexus 7 Tablet (Even if You've Bricked It) Nexus 7 softModder from my google results. Does this method work? It's taken a while so far so that's why I'm slow in responses.
    09-08-2013 09:20 PM
  11. bushybr0ws's Avatar
    UPDATE: Using the guide I mentioned above, I finally fixed this issue. I have to re-set it up, but it works. DDDD

    Thanks for your help.
    09-08-2013 10:10 PM
  12. josiahlikesminecraft's Avatar
    Yay good to know. Just let me know if you have anymore questions. I would also reroot it and see if it works because rooting is amazing.

    Posted via Samsung S3
    09-08-2013 10:12 PM
  13. bushybr0ws's Avatar
    The only weird thing now is I don't see my nexus in the windows explorer program under "computer" like it used to be. That's how I would access the filesystem. Is there any other way to fix this? My device manager says "android device" using a driver from that guide I posted. I think it's called "Google nexus adb interface." I have a backup of one of my important apps that I need to copy over. I guess there's the adb push. lol idk what I'm doing.

    UPDATE: fixed the file transfer issue by uninstalling temp drivers that I used for recovery and using the stock ones.
    09-08-2013 10:26 PM
  14. josiahlikesminecraft's Avatar
    I'm really not sure I'm not experienced with nexus devices.

    Posted via Samsung S3
    09-08-2013 10:34 PM
  15. bushybr0ws's Avatar
    Got it anyway. Just had to remove and reinstall a driver.

    I'm getting experience the hard way haha.
    09-08-2013 10:35 PM
  16. josiahlikesminecraft's Avatar
    Well good to hear. Windows is kind of weird when it comes to drivers.

    Posted via Samsung S3
    09-08-2013 10:36 PM
  17. Golfdriver97's Avatar
    You may have to reflash the system images. Which is basically like reflashing the stock OS.
    09-08-2013 10:38 PM
  18. josiahlikesminecraft's Avatar
    That's another option that u can try.

    Posted via Samsung S3 Running Slimrom
    09-08-2013 10:39 PM
  19. anon(847090)'s Avatar
    Got it anyway. Just had to remove and reinstall a driver.

    I'm getting experience the hard way haha.
    Well good to hear. Windows is kind of weird when it comes to drivers.

    Posted via Samsung S3
    Windows have 2 drivers for all nexus devices.

    1. ADB drivers for using fastboot and doing all the flashing stuff.
    2. MTP drivers for making the SD card show up on My Computer.

    when you rooted it switched to ADB drivers and when you uninstalled the drivers it switched(installed) back to MTP drivers.

    here is how to switch back and forth

    Open Device Manager
    Right Click "Android device" and click "Update device Software"
    Click "Browse your Computer for driver Software"
    Click "Let me Pick from a list of device drivers on my Computer"
    Click Next, for the device list shown.
    Select "Android ADB Interface" or "MTP [something something]" and click Next. It will give you a warning. click OK and Install.
    09-09-2013 12:07 PM

Similar Threads

  1. Replies: 7
    Last Post: 07-28-2014, 03:40 PM
  2. Help I Formatted my Tablet completely!!!
    By georgiaboi22 in forum Samsung Galaxy Tab
    Replies: 7
    Last Post: 04-29-2014, 11:48 AM
  3. HELP! ActiveSync Not Working Properly HTC One.
    By chriskir in forum HTC One M7
    Replies: 3
    Last Post: 10-01-2013, 06:40 PM
  4. Email Syncing Problem
    By underdog1924 in forum Legacy Android & Other OS's
    Replies: 8
    Last Post: 09-17-2013, 02:58 AM
  5. HTC Thunderbolt Won't Factory Reset. Help Please!!
    By MasonM77 in forum General Help and How To
    Replies: 4
    Last Post: 09-08-2013, 10:46 PM