1. pheatton's Avatar
    Like some I was frustrated with not getting the 4.4 update on my new 2013 Nexus 7. I did some searching and it looked like the manual ADB method was the only one I could find that was tried and true. I did come across a method that walked through updating with the OTA file but I ran into a problem with the recovery not having the apply from SD card option. It then hit me to try the good ole Wugs Nexus Toolkit that I have used with very good results on my Galaxy Nexus. So I downloaded the OTA file from here and renamed it update.zp. I then got my Wugs Toolkit updated and the correct drivers installed. I then launched the Advanced Utilities and selected the Sideload Update option, couple minutes later I had 4.4 on the tablet.

    Im not sure if this will help but since I did not see anything like this online I figured I would post it.
    11-17-2013 12:31 AM
  2. Haalcyon's Avatar
    Good 'ole Wugs Nexus Toolkit. Forever useful.
    11-17-2013 06:49 AM
  3. dacunto's Avatar
    How did you get it to recognize the ADB device?
    11-17-2013 08:21 PM
  4. dacunto's Avatar
    nevermind...figured it out
    11-17-2013 09:15 PM
  5. callanish's Avatar
    Please tell. I've hit a brick wall at that part.
    11-17-2013 09:26 PM
  6. Mark McKeown's Avatar
    Novice question here and I apologize. Have a 2012 Nexus 7. Downloaded the new 4.4 image file. It is a .tar file and I don't have anything to open it with and nothing to execute it with. What am I missing?
    11-18-2013 04:07 PM
  7. pheatton's Avatar
    For the ADB issue I would suggest going through the steps in the program to install the correct drivers and make sure they are working. Also make sure you have USB debugging enabled and are using the OEM cable.

    As for the 2012 version make sure you get the correct first. There is a guide by the same site on updating the 2012 version and a download link is there for the OTA file. Then it should be just the same procedure I did. Since I don't have a 2012 model I cant say for sure.

    As always this is a proceed at your own risk.
    11-19-2013 06:36 PM
  8. CKwik240's Avatar
    Novice question here and I apologize. Have a 2012 Nexus 7. Downloaded the new 4.4 image file. It is a .tar file and I don't have anything to open it with and nothing to execute it with. What am I missing?
    If you have a Wifi version, download a copy of the OTA instead and follow the instructions here to sideload it:

    How to manually update your Nexus tablet to KitKat [updated] | Android Central

    If you have an LTE version, you can download the Nexus Root Toolkit here:

    Nexus Root Toolkit v1.7.8 | WugFresh

    There are some basic instructions on that site. The software will guide you through some of it. I would use the driver installation guide in the program if you haven't set up your drivers already or are not sure. Unlock the device in the program (back up anything you need first as it will delete everything at this point). Once unlocked, you can "Flash Stock + unroot" function. Choose the tgz file. It will require the MD5 checksum so uless you have it for the tar file, you will need to use the original tgz file. It will install the factory image at this point. Disclaimer, I did this successfully and found it easy to do, but use this method at your own risk. I don't know what kind of problems, if any, others may have run into using this method. I just learned of it last week while figuring out how to update with the factory image for my LTE Nexus 2013. I just did it again with the KRT16S update tonight. Personally, I would find the OTA version if you have the wifi version and go that route. There's a lot less uncertainty. Unfortunately, the LTE version of the OTA isn't out yet and I am just way impatient. Good luck.
    11-19-2013 11:12 PM
  9. tonyr6's Avatar
    I tried the sideloading thing and just holding down buttons I could not get my Nexus 7 to even turn on. Then when I got it on it was stuck on no command. I was able to fix it by holding down the volume up and power buttons. Did not even load anything on there and I nearly bricked it. Sorry coming from using Apple products this is my first Android device so I am new here.
    11-20-2013 03:44 PM

Similar Threads

  1. Thinking about going to g2 from note 3.
    By GTvert90 in forum Verizon LG G2
    Replies: 5
    Last Post: 11-21-2013, 11:00 AM
  2. Anyone Successfully Logged In to T-Mobile Lately?
    By larrygeary in forum Google Nexus 7 Tablet (2013)
    Replies: 19
    Last Post: 11-19-2013, 12:16 PM
  3. How To Limit Apps
    By Don164 in forum HTC One M7
    Replies: 2
    Last Post: 11-17-2013, 06:15 PM
  4. Is there a ONE STOP SHOP iPhone to Android Music App?
    By Michael_CS in forum Android Apps
    Replies: 2
    Last Post: 11-17-2013, 02:33 PM
  5. Google now no longer interactive after update
    By Christopher Gilliam in forum LG G2
    Replies: 1
    Last Post: 11-16-2013, 08:58 PM