1. BeeBiteBoy's Avatar
    Bought a Nexus 7, it will not turn on and when I plug it in it no battery indicator or anything appears. I have held power button down for over a minute, tried holding volume down and power, tried holding both volumes down and power, nothing happens. It's like a $250 paperweight. Any ideas?
    12-09-2013 09:03 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try the procedure described in this support page: https://support.google.com/googlepla...561?hl=en&rd=2. If that doesn't work, see if you can return it for a replacement.
    12-09-2013 10:36 PM

Similar Threads

  1. fastboot error: could not get pipe properties
    By mchockeyvette27 in forum General Help and How To
    Replies: 7
    Last Post: 08-25-2015, 04:12 PM
  2. Virgin Mobile Canada folks getting their 4.4.1 or 4.4.2 yet?
    By Michael_CS in forum Google Nexus 5
    Replies: 4
    Last Post: 12-12-2013, 09:37 AM
  3. Should any of us be worried?
    By rawrblaah in forum Samsung Galaxy S4
    Replies: 16
    Last Post: 12-12-2013, 07:59 AM
  4. Phone not working - should I root?
    By Mari Pereira in forum General Help and How To
    Replies: 5
    Last Post: 12-11-2013, 01:39 AM
  5. Galxy s3 not working???
    By Briana Villa in forum AT&T Galaxy S III
    Replies: 14
    Last Post: 12-10-2013, 01:49 PM
LINK TO POST COPIED TO CLIPBOARD