1. Bednarz's Avatar
    So I had my Nexus a few days and noticed something strange when checking the battery usage graph, the wifi showed as a solid blue line indicating it was never switching off, restarting made no difference, it was always a solid single line.

    My settings were:

    Network notification: OFF
    Keep wifi on during sleep: NEVER
    Scanning always available: OFF

    I tried going through running apps and killing them off one by one to see if that would allow the Nexus to switch wifi off during sleep, but nothing seemed to make a difference.


    The strange thing is I did a factory reset, and then changed the wifi settings to the same as above and this is the result:

    Wifi never turning off in sleep mode on Nexus 7 (2013)-screenshot_2014-03-04-10-34-07.jpg

    Now that is obviously better than before the factory reset when the wifi would never turn off at all, however is it normal that it is now periodically switching itself on and off during sleep?

    Is there a bug in the 'keep wifi on during sleep' options or could something else strange be going on here?

    I'm assuming my initial problem (before the factory reset) with wifi always being on during sleep was caused by an app, but which one I have no idea...
    03-04-2014 05:44 AM
  2. patruns's Avatar
    Not sure you understand what wifi off during sleep really means. It means it is not constantly on while sleeping. Running apps can still turn it on and off to sync.
    03-04-2014 02:51 PM
  3. B. Diddy's Avatar
    I don't think the Nexus 7 allows apps to turn on wi-fi if you have the wi-fi turned off and Scanning off. Other devices do allow that, but there is no option for that with the N7, and I've never seen it happen on my 2012 nor 2013 versions. It's an odd bug. Although you already did a factory reset, it might still be worth doing a cache partition wipe.

    Posted via Android Central App
    03-04-2014 03:26 PM
  4. Sassi666's Avatar
    My wifi has always shown as a solid blue line with wifi set to go off with sleep. I even know that it goes off as when I reconnect it shows wifi as off for a few seconds. I just assumed it was a bug in the android battery app

    Sent from my Nexus 7 using AC Forums mobile app
    03-04-2014 05:22 PM
  5. gerryp123's Avatar
    It was my impression that certain apps could turn on wifi for synch info updates even when N7 was in sleep state. (Isn't this what wake-locks are all about?). For example, I have a weather app that correctly reports latest air temp when I wake up N7 -- even with wifi off. How does it know this???
    03-05-2014 04:17 PM
  6. B. Diddy's Avatar
    I could be wrong, but my N7 never turns wifi on by itself. I would think that the app wakelock partially awakens the device in order to refresh data, but can only do so if wi-fi was already turned on. When you turn your N7 on and the temp is correct, is it possible that the wi-fi is coming on right when you awaken it, thereby allowing the app to refresh immediately?
    Ntchwaidumela likes this.
    03-05-2014 04:24 PM
  7. Relgoshan's Avatar
    Evidence points to either broken power reporting or more likely broken control of the wifi radio. If you run Wireshark on a PC on your home wifi and set it to log only packets from your tablet's MAC address I expect you will see regular activity even with controls set to keep the wifi off.
    B. Diddy and GSDer like this.
    03-05-2014 06:58 PM
  8. gerryp123's Avatar
    I could be wrong, but my N7 never turns wifi on by itself. I would think that the app wakelock partially awakens the device in order to refresh data, but can only do so if wi-fi was already turned on. When you turn your N7 on and the temp is correct, is it possible that the wi-fi is coming on right when you awaken it, thereby allowing the app to refresh immediately?
    When I wake N7, wifi is always OFF until I turn it ON. Are you saying that waking N7 momentarily turns on wifi to refresh apps and then turns it off again ???
    03-05-2014 08:37 PM
  9. B. Diddy's Avatar
    No, what I was wondering was if wifi might have been left on, but the "Wifi on during sleep" setting was set to "Never." In that situation, wifi is supposed to remain off while asleep, but then once you wake the tablet up, wifi would turn on as well. I know, a relatively unlikely scenario, but just wondering.

    Posted via Android Central App
    03-05-2014 09:05 PM
  10. Gauhar Mahmood Azeem's Avatar
    Cache partition wipe solved it for me

    Sent from my Nexus 7 using Tapatalk
    brosko likes this.
    03-06-2014 11:32 AM
  11. rejgr's Avatar
    I'm having the exact same issue. Got my new N7 yesterday & I've been trying to figure out why it keeps WiFi ON even while sleeping even thought I set it to never keep it on. I even booted in safe mode, wiped the cache partition and it's still doing it.

    My last hope is a factory setting reset and I'll see what happens from there. edit:Not working either.. just did a factory reset and it just won't turn off the WiFi. Guess I'll have to use the "Wifi:auto off" app from now on (it does work - tested). I find it a bit ridiculous to have to use a third party app to have something that's part of android actually work but hey ...

    BTW, can you tell me how to get to the screen you showed on your first post? (The history details for the connections) ... Can't seem to find it on mine... I'm using 4.4.2 on my N7. Thanks

    /cheers

    R

    Update: Found out how to get the history details screen.

    Update 2: It worked for less than a day... then it won't turn off midi anymore (again!) when it goes to sleep. I guess I'll have to find an app that'll allow me to see which app stops midi from turning off. Note that WiFi auto-off stopped working as well. I found another one called "Screen off WiFi off" that seems to work great at the moment.
    04-02-2014 06:38 AM
  12. skyrockett's Avatar
    Some applications can override the system policy. Viber can keep wifi ON during sleep. You might wanna check your application for those options.
    04-04-2014 10:37 PM
  13. gkendall43's Avatar
    Make sure you have Scanning always available turned off in WiFi advanced settings. That did it for me.

    Posted via Android Central App
    04-05-2014 11:26 AM

Similar Threads

  1. HTC One S : Mobile data won't turn on
    By Giannis9700 in forum HTC One S
    Replies: 2
    Last Post: 03-06-2016, 04:52 PM
  2. S Health isn't the same on Sprint Galaxy Note 3 with KitKat 4.4.2
    By cib227 in forum Sprint Samsung Galaxy Note 3
    Replies: 2
    Last Post: 04-10-2014, 12:15 AM
  3. set up mail filters with multiple contacts on G Tab 2 10.1
    By papafrankm in forum Samsung Galaxy Tab 2 10.1
    Replies: 1
    Last Post: 03-23-2014, 02:25 PM
  4. problems with the keyboard after the kitkat update on s4
    By aaron vaz in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 03-06-2014, 01:32 PM
  5. X on Screen
    By frjeff in forum General Help and How To
    Replies: 5
    Last Post: 03-04-2014, 11:48 AM
LINK TO POST COPIED TO CLIPBOARD