1. RapGod34's Avatar

    I received a Google Nexus 7 for last Christmas. I didn't have any issues up until today. The screen just froze and the screen turned all pixely that was rainbow. I was able to turn it off, and tried doing a repair, but it just froze and went back to that screen. Sometimes I can hold the power button and touch the screen and the normal screen pops up. I'm not able to do anything though because the screen is frozen. I recognized that it was in airplane mode. Any help would be appreciated. Thank you. This is what the screen looks like. Frozen with Rainbow Pixels-115165d1398663219t-nexus-7-frozen-cannot-power-off-stuck-colorful-pixel-screen-nexus.jpg
    08-15-2014 08:17 PM
  2. B. Diddy's Avatar
    Yikes! Try powering off by pressing and holding the Power button until it turns off. Then see if you can boot into Recovery Mode and wipe the cache partition: http://forums.androidcentral.com/goo...tion-wipe.html
    08-15-2014 08:41 PM
  3. RapGod34's Avatar
    I'm able to power it down, but once I try to turn it on, it freezes and then eventually I have press the power button to turn the screen on and it's that rainbow pixles.
    08-15-2014 08:47 PM
  4. GSDer's Avatar
    Does the screen look normal up until the point when it freezes (I mean, during boot you see the four balls and the Google text)?

    Are you saying that the screen freezes and then times out and goes dark, and when you short-press the Power button to turn the screen on it looks all garbled?

    Have you tried connecting it to your computer to see if it's behaving normally (despite the weird screen pattern)? If so, you may be able to reload the firmware.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-15-2014 09:38 PM
  5. RapGod34's Avatar
    When I turn it on, the screen times out and goes dark, then when I short-press the Power button, the screen looks like that. I've connected to my computer and it seems to behave normally besides the screen.
    08-15-2014 09:44 PM
  6. RapGod34's Avatar
    I've been trying to fix it, and I found that if I hold my finger down on the screen while I short-press the Power button it goes to the lock screen. I'm able to unlock it sometimes, but it freezes a little afterwards.
    08-15-2014 10:36 PM
  7. GSDer's Avatar
    Since the computer recognises it you should try reloading the stock firmware. You can try Nexus Root Toolkit (not just for rooting) or do it yourself:
    Factory Images
    here - just
    - boot into Fastboot mode (with the device completely off, press-and-hold Volume Down + Power)
    - connect it to your computer
    - download Fastboot.exe from XDA
    - run "fastboot oem unlock" from a Command prompt (elevated to Administrator privilege) (this WILL wipe your device)
    - then extract the contents of the firmware download and run the "flash-all.bat" file

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-16-2014 11:53 AM

Similar Threads

  1. root for Droid Mini with 4.4.4
    By jevbrowser in forum Droid Mini Rooting, ROMs, & Hacks
    Replies: 7
    Last Post: 04-10-2016, 03:58 PM
  2. My S5 will not work with Sprint Airave while in LTE/CDMA mode
    By Jason MacArthur in forum Ask a Question
    Replies: 7
    Last Post: 08-21-2014, 10:41 AM
  3. Issues with connectivity after software update
    By Jean-Baptiste Ronfard in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 08-15-2014, 09:18 PM
  4. LG G2 sync Outlook contacts with phone
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-15-2014, 02:19 PM
  5. Bose Bluetooth headset noisy with Galaxy s5
    By birdnerd258211 in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 08-15-2014, 07:14 AM