1. Danney Webb's Avatar
    My wife's Nexus 7, 2012 I believe, hangs on the wifi setup screen after I did a factory reset on it. I have the same tablet that is working and we have two android phones that are working with the wifi. This unit however after choosing English as the language just stays set on "searching for wifi networks ...". If I choose "other network" and enter in the SSID and password I always get the message, "failed to save network". Any help to get past this?
    05-06-2015 04:17 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Even though other devices are connecting fine, try rebooting the router (by unplugging its power, waiting 10 seconds, and plugging back in again).
    05-06-2015 05:26 PM
  3. Danney Webb's Avatar
    Thanks for the suggestion. It did not change anything however.
    05-06-2015 08:35 PM
  4. B. Diddy's Avatar
    How about temporarily turning off the router's encryption?
    05-07-2015 02:38 AM
  5. Danney Webb's Avatar
    I don't know how to do that. I have Linksys Smart Wi-Fi. I went through all the settings but couldn't find anything about encryption.
    05-07-2015 11:40 PM
  6. B. Diddy's Avatar
    By encryption, I mean the router's security (i.e., WEP, WPA, WPA2, etc.). There should be a way to turn off the security in the router's settings.
    05-08-2015 12:08 AM
  7. Danney Webb's Avatar
    Okay I tried again after turning off security from WPA/WPA2 PSK to NONE but it still would not connect. I think something is wrong inside the tablet. Would it change anything if I did the "three finger" factory reset again?
    05-08-2015 11:08 PM
  8. B. Diddy's Avatar
    Frustrating. Can you try it on some other wi-fi network, like your local Starbucks?
    05-09-2015 12:15 AM
  9. Danney Webb's Avatar
    Okay, I tried it at work and also on the church's wifi but with no luck.
    05-10-2015 04:02 PM
  10. B. Diddy's Avatar
    It might be time to try reflashing the factory image. See the instructions here: How to manually update your Nexus | Android Central. Find the factory image here: https://developers.google.com/android/nexus/images
    05-10-2015 06:33 PM
  11. Danney Webb's Avatar
    Thank you B. Diddy, after some trial and error, I was able to flash Android 4.3 onto the tablet today. Everything seems to be working now. This is a great resource. Danney
    B. Diddy and Ntchwaidumela like this.
    05-11-2015 04:53 PM
  12. Ntchwaidumela's Avatar
    Great job, B. Diddy!
    B. Diddy likes this.
    05-12-2015 11:35 AM
  13. 1eggebek's Avatar
    Hi Danney,

    I'm having this same problem now. How did you manage to get access to the Nexus' settings if you weren't able to get past the wifi login page? Thanks for your help.

    John
    08-27-2016 05:33 AM
  14. GSDer's Avatar
    John,

    If you look at post #10 you'll see the link for flashing the firmware - that apparently solved the OPs problem.

    Be sure you know which device you have (2012 vs. 2013) so that you get the correct firmware.

    You could also try wiping the system cache in Recovery mode prior to flashing the firmware.
    08-27-2016 11:43 AM

Similar Threads

  1. Note 4: No phone book transfer to automobile after android 5.0 install
    By Loveable John in forum Samsung Galaxy Note 4
    Replies: 11
    Last Post: 05-08-2015, 02:25 PM
  2. Replies: 1
    Last Post: 05-06-2015, 07:26 PM
  3. Why isn't my S5 accepting encryption passcode after Lollipop update?
    By mvietori in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 05-06-2015, 04:54 PM
  4. Why won't my Samsung Note 4 stay on?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-06-2015, 04:38 PM
  5. Replies: 0
    Last Post: 05-06-2015, 03:52 PM
LINK TO POST COPIED TO CLIPBOARD