1. Rick Dangerous's Avatar
    So i have had my beautiful 128GB Pixel 2XL Panda Bear for nearly five years now, and it still works great. One thing has been happening lately and intermittently that I can't explain: It will connect to my home wifi network, but say "no internet". Here is the troubleshooting i've done so far:

    -Restarted phone
    -Forgot network, re-connected
    -Ensured wifi toggled "on", not on airplane mode
    -Reset home wifi by unplugging routers
    -Reset home wifi network through the EERO app
    -Reset all wireless/bt settings in system settings
    -Tested by connecting to work iphone hotspot (works, will get internet)
    -Gone into MAC privacy settings and selected use phone MAC instead of randomized mac.

    I have dual EERO wireless routers running a 5ghz network and for 98% of the time i've been in my new home it's worked just fine (have been here 2 months now). For random half days or full days (this is the second time now) the phone will connect to my home wifi network, but say "No Internet" when i know there is internet, because my work computer is connected and my work Iphone XR is connected. But then I can get wifi through my work phones hot-spot, so i know my phone wifi works. What is going on here? Any thoughts to point me in the right direction would be much appreciated.
    08-04-2022 10:03 AM
  2. J Dubbs's Avatar
    I would make sure your home wi-fi is set to broadcast at 2.4 AND 5ghz.. older devices can be picky about 5ghz. I have some older devices including an original pixel, and I found with our Google mesh system that broadcasts at both frequencies all the devices work best.

    Are the early pixels even 5ghz compatible? I don't remember anymore lol.
    BerryBubbles likes this.
    08-05-2022 02:29 AM
  3. Rick Dangerous's Avatar
    I disconnected and re-connected last night and voila, signal! I'm not sure why it has conked out a few times now; but will just stick with it unless it goes out for 2-4 weeks and then begrudgingly look into a new phone. Luckily so far it has worked 99% of the time. I'm not sure what it's being picky about, perhaps the 5ghz as you say, I might try setting up a 2.4ghz network through my EERO app and see if it likes that any better. Thanks for the tip!
    J Dubbs likes this.
    08-05-2022 08:22 AM
  4. Rick Dangerous's Avatar
    I noticed today when charging my XL directly from my macs USB-C port that it was glitching and freaking out and shut itself off. It then knocked the wifi out when i restarted it. I wonder if "overcharging" it is causing this problem; frying the wifi antenna, etc. Are you not supposed to charge phones directly from computers?
    08-05-2022 03:46 PM
  5. B. Diddy's Avatar
    Any firmware updates available for the router?
    08-07-2022 01:27 AM
  6. Mr Bojangles1's Avatar
    Try going to settings on your phone and search for private dns. Change it to google and see if that helps. Google's hostname is dns.google.

    Or you could use cloudflare too.
    Laura Knotek and B. Diddy like this.
    08-07-2022 10:03 AM
  7. Rick Dangerous's Avatar
    Thanks guys; seems to be working fine now that i am not charging the phone to 100%+ off my macbook pro's USB-C port. Seemed to be overloading the phone for some reason. Gets 5ghz network just fine.
    J Dubbs likes this.
    08-08-2022 09:08 AM
  8. Rick Dangerous's Avatar
    Charging/overcharging is the culprit. It shuts down and there is a glitch near the top of the screen.

    Seems like the hardware may be getting a bit tired but i seem to be able to manage it; i just have to be careful not to overcharge. Thanks all!
    J Dubbs likes this.
    08-12-2022 09:36 AM

Similar Threads

  1. 4a 5G - no update yet, not posted to Google even
    By hallux in forum Google Pixel 4a & Pixel 4a 5G
    Replies: 7
    Last Post: 08-15-2022, 10:05 PM
  2. Why is Acer Spin 513 with Mediatek processor no longer available
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-08-2022, 01:19 AM
  3. How to lock my home screen
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 08-08-2022, 01:07 AM
  4. My Galaxy A32 burns through data
    By Joshua Duplechin in forum Samsung Galaxy A Series
    Replies: 5
    Last Post: 08-07-2022, 10:01 AM
  5. no software update option in my tablet
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-04-2022, 09:51 AM