1. Rick Dangerous's Avatar
    So i have had my beautiful 128GB Pixel 2XL Panda Bear for nearly five years now, and it still works great. One thing has been happening lately and intermittently that I can't explain: It will connect to my home wifi network, but say "no internet". Here is the troubleshooting i've done so far:

    -Restarted phone
    -Forgot network, re-connected
    -Ensured wifi toggled "on", not on airplane mode
    -Reset home wifi by unplugging routers
    -Reset home wifi network through the EERO app
    -Reset all wireless/bt settings in system settings
    -Tested by connecting to work iphone hotspot (works, will get internet)
    -Gone into MAC privacy settings and selected use phone MAC instead of randomized mac.

    I have dual EERO wireless routers running a 5ghz network and for 98% of the time i've been in my new home it's worked just fine (have been here 2 months now). For random half days or full days (this is the second time now) the phone will connect to my home wifi network, but say "No Internet" when i know there is internet, because my work computer is connected and my work Iphone XR is connected. But then I can get wifi through my work phones hot-spot, so i know my phone wifi works. What is going on here? Any thoughts to point me in the right direction would be much appreciated.
    08-04-2022 11:03 AM
  2. J Dubbs's Avatar
    I would make sure your home wi-fi is set to broadcast at 2.4 AND 5ghz.. older devices can be picky about 5ghz. I have some older devices including an original pixel, and I found with our Google mesh system that broadcasts at both frequencies all the devices work best.

    Are the early pixels even 5ghz compatible? I don't remember anymore lol.
    BerryBubbles likes this.
    08-05-2022 03:29 AM
  3. Rick Dangerous's Avatar
    I disconnected and re-connected last night and voila, signal! I'm not sure why it has conked out a few times now; but will just stick with it unless it goes out for 2-4 weeks and then begrudgingly look into a new phone. Luckily so far it has worked 99% of the time. I'm not sure what it's being picky about, perhaps the 5ghz as you say, I might try setting up a 2.4ghz network through my EERO app and see if it likes that any better. Thanks for the tip!
    J Dubbs likes this.
    08-05-2022 09:22 AM
  4. Rick Dangerous's Avatar
    I noticed today when charging my XL directly from my macs USB-C port that it was glitching and freaking out and shut itself off. It then knocked the wifi out when i restarted it. I wonder if "overcharging" it is causing this problem; frying the wifi antenna, etc. Are you not supposed to charge phones directly from computers?
    08-05-2022 04:46 PM
  5. B. Diddy's Avatar
    Any firmware updates available for the router?
    08-07-2022 02:27 AM
  6. Mr Bojangles1's Avatar
    Try going to settings on your phone and search for private dns. Change it to google and see if that helps. Google's hostname is dns.google.

    Or you could use cloudflare too.
    1dot1dot1dot1.cloudflare-dns.com
    Laura Knotek and B. Diddy like this.
    08-07-2022 11:03 AM
  7. Rick Dangerous's Avatar
    Thanks guys; seems to be working fine now that i am not charging the phone to 100%+ off my macbook pro's USB-C port. Seemed to be overloading the phone for some reason. Gets 5ghz network just fine.
    J Dubbs likes this.
    08-08-2022 10:08 AM
  8. Rick Dangerous's Avatar
    Charging/overcharging is the culprit. It shuts down and there is a glitch near the top of the screen.

    Seems like the hardware may be getting a bit tired but i seem to be able to manage it; i just have to be careful not to overcharge. Thanks all!
    J Dubbs likes this.
    08-12-2022 10:36 AM
  9. Rick Dangerous's Avatar
    When i plug my phone in to charge, it shuts down EVERY time. It will only charge when off. Hasn't bothered me so far yet

    Have tried multiple cables/chargers, I think it's either a glitch or a hardware flaw. Debating doing a full reset on the phone to see if it will fix it.
    J Dubbs likes this.
    08-18-2022 03:51 PM
  10. B. Diddy's Avatar
    I would lean more towards a hardware problem with the USB port. Maybe it's causing a short that forces the phone to power down.
    Laura Knotek likes this.
    08-18-2022 05:00 PM
  11. J Dubbs's Avatar
    When i plug my phone in to charge, it shuts down EVERY time. It will only charge when off. Hasn't bothered me so far yet

    Have tried multiple cables/chargers, I think it's either a glitch or a hardware flaw. Debating doing a full reset on the phone to see if it will fix it.
    You've got nothing to lose with the reset... although you've gotten an incredible amount of life out of your panda It might be time to treat yourself to a new pixel
    08-19-2022 06:56 AM
  12. Rick Dangerous's Avatar
    Oh man i have all my files, my emulators, my apps, my photos, etc. It would be a pain, but I probably should try it.

    Going to give it a whirl and then yeah, maybe if it doesn't fix it limp it along for a few months and spring for a new Pixel 7 since those are coming out in October. If the hardware wasn't acting up; i'd be fine with it for another few years, it's plenty powerful and the battery is still at 84%, lasts all day.
    J Dubbs likes this.
    08-19-2022 11:58 AM
  13. J Dubbs's Avatar
    Oh man i have all my files, my emulators, my apps, my photos, etc. It would be a pain, but I probably should try it.

    Going to give it a whirl and then yeah, maybe if it doesn't fix it limp it along for a few months and spring for a new Pixel 7 since those are coming out in October. If the hardware wasn't acting up; i'd be fine with it for another few years, it's plenty powerful and the battery is still at 84%, lasts all day.
    The Panda Pixel is legendary... I think it's one of the most well known pixels. Pixel fans either owned one or wanted to lol. I would want to keep using it as long as possible too Hopefully it's just a software issue... I personally fixed a similar issue with a factory reset once, so there's a chance
    Laura Knotek likes this.
    08-20-2022 03:40 AM
  14. Rick Dangerous's Avatar
    I figured out how to fix this; I just have to forget the network and reconnect near one of my wifi routers. Has become a non-issue.

    The Panda is alive and well and i think will be around for a few more months at the least!
    B. Diddy and J Dubbs like this.
    10-11-2022 09:48 AM
  15. Rick Dangerous's Avatar
    Well unfortunately my Panda started shutting off again every time I plug it in to charge. I tried vigorously cleaning the charging port a few times, and also doing the full system erase and reset, and it's still doing it. I think this is the end of the line as I need it for navigation and can't have it running out of batteries while I'm on the road.

    It's been a good 5 year run for sure, would happily have the phone another 2-3 years if it was still working properly. Oh well.... off to the Google store I go to order a Pixel 7 with 256GB.

    Cheers all, see you over in that area of the site!
    Laura Knotek, B. Diddy and J Dubbs like this.
    11-15-2022 10:44 AM

Similar Threads

  1. 4a 5G - no update yet, not posted to Google even
    By hallux in forum Google Pixel 4a & Pixel 4a 5G
    Replies: 7
    Last Post: 08-15-2022, 11:05 PM
  2. Why is Acer Spin 513 with Mediatek processor no longer available
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-08-2022, 02:19 AM
  3. How to lock my home screen
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 08-08-2022, 02:07 AM
  4. My Galaxy A32 burns through data
    By Joshua Duplechin in forum Samsung Galaxy A Series
    Replies: 5
    Last Post: 08-07-2022, 11:01 AM
  5. no software update option in my tablet
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-04-2022, 10:51 AM
LINK TO POST COPIED TO CLIPBOARD