1. pstellato73's Avatar
    I set my do not disturb for weekdays from 11pm to 7:30am. After 7:30am it still shows do not disturb is on. I have to manually turn it off. Is this normal? Does anyone use this and have the same issue? It's not a huge deal but kind of annoying.
    11-09-2017 07:56 AM
  2. N4Newbie's Avatar
    What do your settings look like? And, where did you set it up?

    In Settings -> Sound -> Do Not Disturb preferences, I have configured "Quiet Nights" which looks like this:

    Question about do not disturb schedule-screenshot_20171109-080335.jpg

    It turns itself off at 5:30 AM, as expected. Pixel 2 XL.
    11-09-2017 08:07 AM
  3. pstellato73's Avatar
    What do your settings look like? And, where did you set it up?

    In Settings -> Sound -> Do Not Disturb preferences, I have configured "Quiet Nights" which looks like this:

    Click image for larger version. 

Name:	Screenshot_20171109-080335.jpg 
Views:	53 
Size:	65.6 KB 
ID:	273415

    It turns itself off at 5:30 AM, as expected. Pixel 2 XL.
    Here is my setup. But at 7:30am, it does not turn off. I have to manually turn it off. I do not have the alarm setting turned on because sometimes, I snooze and don't want to be bothered. Question about do not disturb schedule-screenshot_20171109-124606.jpgQuestion about do not disturb schedule-screenshot_20171109-124559.jpg
    11-09-2017 12:49 PM
  4. N4Newbie's Avatar
    Can you check the settings of your Event rule?

    Maybe there is something there that would explain the problem.
    11-09-2017 12:52 PM
  5. 18t's Avatar
    Should automatically turn off. Could always use an app like Tasker to toggle DND.
    11-09-2017 08:14 PM
  6. nelamvr6's Avatar
    I'm with N4Newbie, what is that event rule?
    11-09-2017 08:30 PM
  7. pstellato73's Avatar
    Event this is for meetings, but it was happening before I added that. Doesn't work for event rule at all.
    11-10-2017 12:06 AM
  8. pstellato73's Avatar
    I used tasker as well, still wouldn't turn off. Never had this issue before the pixel 2 xl
    11-10-2017 12:07 AM
  9. N4Newbie's Avatar
    Event this is for meetings, but it was happening before I added that. Doesn't work for event rule at all.
    Okay, I want you to think really, really, hard - is it possible that you have some other app/utility that is trying to manage your DND configuration? There are tons of such apps - maybe take a look at https://play.google.com/store/apps/c...1ljJDQ6c&hl=en and see if anything catches your eye.

    I don't normally use the Events option, however I just enabled it and then - on my work computer - I scheduled a five minute meeting to start 5 minutes hence. Sure enough, at the appointed time, my Pixel 2 XL went into DND mode and then turned itself back off 5 minutes later when my "meeting" ended. (Yes, my Exchange account is fully synced on my phone using the Nine email app).

    You've got something going on , that's for sure.
    11-10-2017 08:47 AM
  10. nelamvr6's Avatar
    Event this is for meetings, but it was happening before I added that. Doesn't work for event rule at all.
    You realize that Event rule is turned on in that screen cap, right?

    I'm not sure what your issue is, the scheduled DND works fine on my phone. Maybe a troubleshooting step you could try is to delete all rules and start from scratch. See what happens...
    11-10-2017 08:50 AM
  11. N4Newbie's Avatar
    You realize that Event rule is turned on in that screen cap, right?
    I think what he meant is that even though the Event rule is enabled, his phone is not automatically going into DND during scheduled meetings.
    11-10-2017 09:05 AM
  12. theragtopman's Avatar
    I had the same problem with my 2 day old Pixel 2 XL. The default weeknight and weekend rules did not work, even though I configured them to right out of the box. I noticed the problem yesterday midday when do not disturb was still on. Then last night, I just assumed Do not disturb would toggle on at the set time, but being awakened by a notification at 1:45 proved otherwise (grrr!). I deleted the built in weeknight and weekend rules and created two new rules with the same names and settings and do not disturb works fine now on my Pixel 2 XL. I vaguely remember having this same problem when I first got my original Pixel XL last year. Maybe try deleting your built-in rules and recreating new ones and see if that works for you too. Good luck.
    11-10-2017 03:26 PM
  13. pstellato73's Avatar
    I think what he meant is that even though the Event rule is enabled, his phone is not automatically going into DND during scheduled meetings.
    Correct. But I do think something is going on. I even removed my night task on tasker. Just to see if that was my issue.
    11-11-2017 12:09 AM
  14. pstellato73's Avatar
    I had the same problem with my 2 day old Pixel 2 XL. The default weeknight and weekend rules did not work, even though I configured them to right out of the box. I noticed the problem yesterday midday when do not disturb was still on. Then last night, I just assumed Do not disturb would toggle on at the set time, but being awakened by a notification at 1:45 proved otherwise (grrr!). I deleted the built in weeknight and weekend rules and created two new rules with the same names and settings and do not disturb works fine now on my Pixel 2 XL. I vaguely remember having this same problem when I first got my original Pixel XL last year. Maybe try deleting your built-in rules and recreating new ones and see if that works for you too. Good luck.
    I will do this tonight to see if that is my issue. Thanks for the input
    11-11-2017 12:09 AM
  15. scgf's Avatar
    I use MacroDroid to achieve silent mode. MacroDroid is a free app which allows you to build macros. When my phone is charging AND on my home wifi AND it's between 9pm and 7am it is silent. When taken off charge it goes into normal mode. I found this better because some nights I'm out and about so a schedule just based on the time of day and day of the week just wouldn't work.

    Question about do not disturb schedule-screenshot_20171111-113403.jpg

    Normal mode is achieved with another macro:

    Triggers: Power Disconnected
    Actions: Volume Change
    Constraints: None
    paulbadassbriant and GSDer like this.
    11-11-2017 06:36 AM
  16. pstellato73's Avatar
    That's cool. I've been using tasker for stuff like that. But I'll check it out.

    BTW: deleting the pre configured rules worked. I added a new night rule and the DND turned off this morning. Wooohooo! So even if you change the pre configured DND rules it will not work. You HAVE to delete all pre configure rules. Damn shame. Thanks for helping out
    nelamvr6 and AnnDroid like this.
    11-11-2017 09:35 AM
  17. scgf's Avatar
    That's cool. I've been using tasker for stuff like that. But I'll check it out.
    I prefer MacroDroid because for me, as a non-programmer, it is easier to understand. Prior to the Google fix for the ticking sound I had MacroDroid turn off NFC during a call and turn it back on afterwards. I was very pleased with myself, lol!
    11-11-2017 12:25 PM
  18. DesertTwang's Avatar
    Thank you for sharing your experience. The pre-set rules on my Pixel 2 don't work right, either. Some days DND does turn off at the specified time, but others it doesn't, causing me to miss important calls. Super annoying. I'm going to try your approach and see if that helps.
    01-22-2018 03:41 PM
  19. K3y804rD's Avatar
    I think I also know of another solution. One that does not require a third party app. It's actually fairly simple, so simple I feel like a real tard after finding out what it was. So if your on the main screen of your phone and you swipe down and on the quick settings you see DND if you click on the drop down arrow it should say do not disturb until you turn off manually. It's annoying that it tldoes that but that's what the issue was with my phone. Just make sure you have a schedule already set up and if you turn off DND at main screen that should fix it. Good luck!
    05-15-2018 08:05 AM
  20. PowrDroid's Avatar
    For the people that had trouble with your DND rules with your Pixel 2 right out of the box, is it possible some rule got imported from your previous device? I had this happen when I went from my Droid Turbo to my 2 XL. If so, you must delete the rule and build a new one.
    05-15-2018 08:33 AM

Similar Threads

  1. Hi my S7 is start on Odin mode. What shall I do now?
    By Android Central Question in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 11-12-2017, 01:16 AM
  2. whatapp is not working without out wifi
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-12-2017, 01:08 AM
  3. Nest Location Not Working
    By comptech520 in forum Samsung Galaxy S8 & S8+
    Replies: 1
    Last Post: 11-09-2017, 04:53 PM
  4. Why do have keep syncing my email every time i use it.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-09-2017, 04:27 PM
  5. sd card not inserted after phone drop in water
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-09-2017, 07:23 AM
LINK TO POST COPIED TO CLIPBOARD