Save big + get 3 months free! Sign up for ExpressVPN today

  1. Android Central Question's Avatar
    Hey all,

    Sorry for the noob question however my new Pixel 2 XL cant seem to play my motion pictures.

    Example: I have my motion on "ON" and when i snap a picture the motion icon turns RED like its saving something.

    Than when I go back to my photos the motion is on "OFF". Regardless of that, when I turn motion "ON" it does not show any MOTION....just a still photo.

    I have tried multiple times and different techniques....but motion photos are not working for me.

    Please help.
    02-04-2018 09:43 AM
  2. trooba's Avatar
    Hey all,

    Sorry for the noob question however my new Pixel 2 XL cant seem to play my motion pictures.

    Example: I have my motion on "ON" and when i snap a picture the motion icon turns RED like its saving something.

    Than when I go back to my photos the motion is on "OFF". Regardless of that, when I turn motion "ON" it does not show any MOTION....just a still photo.

    The motion icon keeps spinning when it's on "on"......

    I have tried multiple times and different techniques....but motion photos are not working for me.

    Please help.
    02-04-2018 08:05 PM
  3. radioactive70's Avatar
    Hey all,

    Sorry for the noob question however my new Pixel 2 XL cant seem to play my motion pictures.

    Example: I have my motion on "ON" and when i snap a picture the motion icon turns RED like its saving something.

    Than when I go back to my photos the motion is on "OFF". Regardless of that, when I turn motion "ON" it does not show any MOTION....just a still photo.

    The motion icon keeps spinning when it's on "on"......

    I have tried multiple times and different techniques....but motion photos are not working for me.

    Please help.
    Strange..
    02-04-2018 08:29 PM
  4. trooba's Avatar
    How is it supposed to work anyway? I can't actually find a youtube video on it either...

    But i assume that you take a picture with motion on (or automatic) and when you click on the picture at the bottom right corner it should play the pic for you....
    02-04-2018 08:38 PM
  5. GSDer's Avatar
    How is it supposed to work anyway?
    When you have motion enabled and you view a picture (either in the Photos app or directly in the Camera app from that preview) it shows a short clip (3 seconds?) of movement captured with the picture.
    I normally have that turned off but I enabled it just to be sure that it worked as expected and it did.
    radioactive70 likes this.
    02-04-2018 09:58 PM
  6. radioactive70's Avatar
    Fwiw I just checked mine and its working fine.
    02-04-2018 10:08 PM
  7. B. Diddy's Avatar
    Welcome to Android Central! Open your Google Photos app, tap Menu>Settings, is the Remove Video From Motion Photos switch turned off?
    02-06-2018 01:26 AM
  8. B. Diddy's Avatar
    I merged the duplicate threads (thanks for the heads up, @GSDer).
    02-06-2018 09:57 PM
  9. Pixel2Motion's Avatar
    I'm also having this problem. Worked fine previously, now new photos say that there is motion to turn on, but nothing moves. Older motion captures still work fine.
    04-19-2018 06:49 PM
  10. sethacker10's Avatar
    My Motion Photo button is disabled all the time. Can't get it enabled. Any suggestions?
    06-03-2018 10:14 AM
  11. GSDer's Avatar
    My Motion Photo button is disabled all the time. Can't get it enabled. Any suggestions?
    You're saying that in the Camera app you don't see the options to change the setting, or that when you pick a different option it doesn't stick?
    What OS?
    06-03-2018 12:11 PM
  12. mariastamps's Avatar
    This is my problem. I have the Android Pie (9) OS.
    I tap the icon and the menu does not pop up.
    Thanks for any help you can provide. Much appreciated!

    Camera Motion - Pixel 2 XL-pixel-2-camera.png
    08-18-2018 01:03 PM
  13. GSDer's Avatar
    I tap the icon and the menu does not pop up.
    That's because you have the Flash set to ON - if you set the Flash to OFF or AUTO then the Motion control will work properly.
    08-19-2018 12:51 PM
  14. Richliu's Avatar
    Same problem here! I can't find the solution anywhere.
    Attached Thumbnails Camera Motion - Pixel 2 XL-screenshot_20190309-094533.jpg  
    03-08-2019 08:32 PM
  15. GSDer's Avatar
    Same problem here!
    Which 'same' problem?
    1. When you view the picture while still in the Camera application do you see the motion?
    2. When you view the picture in the Photos application you don't see the motion?
    03-08-2019 10:36 PM
  16. Richliu's Avatar
    I can't view the motion photo in the Camera, it disappear after processing by camera app. Then it disappeared on my phone, just like I never took this photo.
    Or it should be said that I can’t take a motion picture at all.
    03-10-2019 08:03 PM
  17. GSDer's Avatar
    I can't view the motion photo in the Camera, it disappear after processing by camera app.
    Then it disappeared on my phone, just like I never took this photo.
    I did see some squirrely behavior on the part of the Photos app: even though I could see the motion photo from within the Camera application it wouldn't show up in the Photos app. I took a few of them (I usually have that option turned off but I enabled it to check this out) but they just wouldn't show up, even after 15 minutes. Yet they looked just fine inside the Camera.
    I finally turned off the motion option in the Camera application and lo-and-behold the pictures suddenly showed up in the Photos app. Go figure.
    Regarding the pictures not even showing up in the Camera application - not sure what to tell you there. Try the usual suspects: Force stop; Clear cache and data; Uninstall updates.
    Richliu likes this.
    03-11-2019 01:21 AM
  18. mustang7757's Avatar
    I can't view the motion photo in the Camera, it disappear after processing by camera app. Then it disappeared on my phone, just like I never took this photo.
    Or it should be said that I can’t take a motion picture at all.
    How did you make out? , Did you try any of the steps mentioned?
    03-11-2019 11:32 AM
  19. Richliu's Avatar
    Thank you for your advises. I've tried all but it didn't work for me. Finally I flash full factory image provided by Google, then after reboot everything is okay now.
    mustang7757 likes this.
    03-12-2019 12:07 AM

Similar Threads

  1. My Pixel 2 does not want to cast with any TV, any ideas why?
    By Android Central Question in forum Google Pixel 2 & Pixel 2 XL
    Replies: 13
    Last Post: 06-15-2020, 01:19 AM
  2. Google Pixel XL 2
    By detfan in forum Marketplace Archive
    Replies: 6
    Last Post: 03-14-2018, 08:24 AM
  3. Best alternate camera app
    By NealJ777 in forum Google Pixel 2 & Pixel 2 XL
    Replies: 6
    Last Post: 02-05-2018, 02:36 PM
  4. Active Edge and google pixel buds
    By Lefank in forum Google Pixel 2 & Pixel 2 XL
    Replies: 2
    Last Post: 02-04-2018, 02:00 PM
  5. Replies: 0
    Last Post: 02-03-2018, 04:57 PM
LINK TO POST COPIED TO CLIPBOARD