1. The Lip's Avatar
    My P2XL is on Verizon. I have WiFi calling enabled in the phone's settings. For some reason, the setting occasionally reverts back to disabled. Has anybody else experienced that and if so, is there a fix? Since there is no icon in the window shade, the only way I know that the setting has changed is that I don't get WiFi calling in places that I know I should.

    My second question is, is there a way to force WiFi calling? When I get or make a call, my phone starts off on the network, and, when it switches to WiFi calling (which can be a few seconds or up to a minute later), there is a momentary loss of mic and audio. I have had people hang up during the "dead period" thinking that I got disconnected. I would like to be able to make or receive a call in WiFi calling. Is that possible (apart from possibly disabling the network connection)?
    04-18-2018 01:57 AM
  2. Mike Dee's Avatar
    My P2XL is on Verizon. I have WiFi calling enabled in the phone's settings. For some reason, the setting occasionally reverts back to disabled. Has anybody else experienced that and if so, is there a fix? Since there is no icon in the window shade, the only way I know that the setting has changed is that I don't get WiFi calling in places that I know I should.

    My second question is, is there a way to force WiFi calling? When I get or make a call, my phone starts off on the network, and, when it switches to WiFi calling (which can be a few seconds or up to a minute later), there is a momentary loss of mic and audio. I have had people hang up during the "dead period" thinking that I got disconnected. I would like to be able to make or receive a call in WiFi calling. Is that possible (apart from possibly disabling the network connection)?
    I have had to enable it more than once but it may have been after a reset or update. The only thing you priotize is wifi or mobile during roaming.
    04-18-2018 05:06 AM
  3. toiday's Avatar
    I have T-Mobile so I've been using it way before other carriers and before Pixel. Under call setting, when you turn on WiFi calling, there is a preference setting: WiFi preferred or mobile preferred. I use mobile preferred because you don't know what quality of WiFi you're connecting to. Besides, I have unlimited minutes anyway. WiFi calling was great for our overseas trips. We still able to make calls from overseas. Also able to text from the airplane. It has improved a lot as well. I used to have my call cut off switching from WiFi calling to mobile. But now it stays on. A short disruption is still better than being dropped.
    04-18-2018 06:57 AM
  4. Mike Dee's Avatar
    I have T-Mobile so I've been using it way before other carriers and before Pixel. Under call setting, when you turn on WiFi calling, there is a preference setting: WiFi preferred or mobile preferred. I use mobile preferred because you don't know what quality of WiFi you're connecting to. Besides, I have unlimited minutes anyway. WiFi calling was great for our overseas trips. We still able to make calls from overseas. Also able to text from the airplane. It has improved a lot as well. I used to have my call cut off switching from WiFi calling to mobile. But now it stays on. A short disruption is still better than being dropped.
    If you dig deeper you will find that preference is when you are roaming
    04-18-2018 08:00 AM
  5. m1a1mg's Avatar
    My Verizon Pixel 2 XL does it constantly. There seems to be no rationale to it. Verizon says, just like Google, to boot to safe mode or reset. Tried both with no luck. I found a person on the Verizon forums with the same issue.
    04-19-2018 11:06 PM
  6. TraderGary's Avatar
    I use Google Fi which does WiFi calling automatically whenever WiFi is the best option. My home is surrounded by hills and has no cell tower signal. Whenever I'm home I'm totally dependent on WiFi calling. If I'm on a call and leave home, as I drive away, I get automatic switching to cell towers with no audible interruption whatsoever. When out driving and I'm on the phone and come home, my phone automatically switches to my home WiFi calling, and again there is no discernable interruption whatsoever during the transfer.

    Google Fi is doing everything flawlessly. My guess is that your problem is with your carrier.
    04-19-2018 11:56 PM
  7. Photo_Drew's Avatar
    I want to say there's a setting in the advanced wifi to keep wifi on all the time. I turned off WiFi calling because when the phone would wake up from sleep with a call or would drop the call when it connected to the WiFi.
    04-20-2018 09:00 PM
  8. Mike Dee's Avatar
    I want to say there's a setting in the advanced wifi to keep wifi on all the time. I turned off WiFi calling because when the phone would wake up from sleep with a call or would drop the call when it connected to the WiFi.
    Please post a screenshot because that's not the setting I see. I see a preference for roaming.
    04-20-2018 10:21 PM
  9. Photo_Drew's Avatar
    Please post a screenshot because that's not the setting I see. I see a preference for roaming.
    It was on my z Force. Not sure on pixel. Assumed it was similar. Menu is diff on Oreo I noticed
    04-20-2018 10:54 PM
  10. lmdroid's Avatar
    I use verizon and the only way I was able to use wifi calling reliably was to follow link listed below.

    https://www.xda-developers.com/enabl...ixel-pixel-xl/
    04-21-2018 08:07 AM
  11. m1a1mg's Avatar
    I have the "prefer wifi" option on my Pixel 2 XL. It would still drop. Another option, that has now worked for 48 hours, is to change Preferred Network Type to LTE/CDMA. It's default was Global. Not phone tech savvy, so I can't logic why this would work, but it seems to be thus far.
    04-22-2018 11:54 AM
  12. Mike Dee's Avatar
    I use verizon and the only way I was able to use wifi calling reliably was to follow link listed below.

    https://www.xda-developers.com/enabl...ixel-pixel-xl/
    That link applies to the original Pixel. They don't disable it on the current models and I'm not sure it's still disabled on the original
    04-22-2018 01:07 PM
  13. lmdroid's Avatar
    Verizon disables the wifi preferred setting on all Pixels. The link that I provided describes how to enable wifi preferred. Wifi calling works much better with this setting enabled.
    04-22-2018 02:58 PM
  14. Mike Dee's Avatar
    Verizon disables the wifi preferred setting on all Pixels. The link that I provided describes how to enable wifi preferred. Wifi calling works much better with this setting enabled.
    My wifi calling works fine.
    04-22-2018 05:43 PM
  15. m1a1mg's Avatar
    Verizon disables the wifi preferred setting on all Pixels. The link that I provided describes how to enable wifi preferred. Wifi calling works much better with this setting enabled.
    Not true. My Pixel 2 has wifi calling. It is enabled. My issue was totally different.
    04-23-2018 10:44 PM
  16. lmdroid's Avatar
    Not true. My Pixel 2 has wifi calling. It is enabled. My issue was totally different.
    WiFi calling is enabled with Verizon, but the "WiFi preferred" setting is not available until you apply the fix as described in the link that I posted. If you open your phone app and go to settings>calls. WiFi preferred is not listed under WiFi calling. That setting is available with T-Mobile. I have weak cell signal at home and want WiFi calling to be default. It won't attempt to use cell signal at home with WiFi preferred activated. I hope you can understand that.
    04-24-2018 11:06 AM
  17. m1a1mg's Avatar
    Once again, you are incorrect. I did not have to do any such thing with my stock VZW Pixel 2 XL. The Google store version does have an issue, but it doesn't take all that. Just turn on - connect data service when roaming.

    Jeez.
    05-04-2018 10:24 PM

Similar Threads

  1. Best File Format for External HDD Accessed via WiFI?
    By lifereinspired in forum General Help and How To
    Replies: 4
    Last Post: 04-18-2018, 03:43 PM
  2. Wifi connection problems lg g6 at public wifi sites
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-18-2018, 02:25 AM
  3. why cant i turn on my wifi calling?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-17-2018, 09:06 PM
  4. Disable voicemail or call forwarding
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-17-2018, 08:03 PM
  5. Can't set Google Phone as default call app
    By africsnail in forum Ask a Question
    Replies: 1
    Last Post: 04-17-2018, 05:48 PM
LINK TO POST COPIED TO CLIPBOARD