1. PaulQ's Avatar
    My house is covered in Google Homes. I can't seem to get my Pixel to permanently retain the setting to not respond to "OK Google" when locked. This is only an issue because I walk through my home on a daily basis saying the command to operate my home. The phone will not remain compliant. Am I doing something wrong?

    Luckily, my Google Homes win and the commands are executed by them and not the phone but it's just annoying that the phone comes to life.

    I won't even bring up how buried that setting is to not listen when locked.
    Kirstein Gourlay likes this.
    06-12-2018 12:54 AM
  2. Almeuit's Avatar
    Not sure TBH. I turned off "OK Google" except when using Android Auto / Google Maps. This is due to Google Homes all around my house as well.
    Kirstein Gourlay likes this.
    06-12-2018 01:40 AM
  3. Kirstein Gourlay's Avatar
    My house is covered in Google Homes. I can't seem to get my Pixel to permanently retain the setting to not respond to "OK Google" when locked. This is only an issue because I walk through my home on a daily basis saying the command to operate my home. The phone will not remain compliant. Am I doing something wrong?

    Luckily, my Google Homes win and the commands are executed by them and not the phone but it's just annoying that the phone comes to life.

    I won't even bring up how buried that setting is to not listen when locked.
    I have literally disabled ok google on my phone to stop that happening. I didn't even know there was a serting to not listen when locked. Can you point me to it please?
    06-12-2018 03:41 AM
  4. strikeIII's Avatar
    I use "Hey Google" for my Home devices and "Ok Google" for my phone.

    EDIT: sorry that's on my Galaxy S9+ where it doesn't respond to "Hey Google" only "Ok Google".
    06-14-2018 12:43 AM
  5. PaulQ's Avatar
    I have literally disabled ok google on my phone to stop that happening. I didn't even know there was a serting to not listen when locked. Can you point me to it please?
    I believe there are multiple routes to what I think is the setting. Here is one way....

    1. Open your Google Feed (or whatever they call it - swipe right)
    2. At the bottom-right, tap the hamburger menu
    3. Select SETTINGS
    4. At the top, under Google Assistant, select SETTINGS
    5. On the next screen, look down the list under "devices" and pick "PHONE"
    6. In the second section titled "Get hands free help with voice match," turn off the first option labeled "Access with voice match"


    In my case, it seems to magically re-enable itself. I wonder if it has something to do with Android Auto. OK Google continues working when this setting is off. In fact, it pops up a notification to that effect when you turn it off as described above.

    If you don't use Android Auto, let us know if it stays off for more than a couple days.
    Kirstein Gourlay likes this.
    06-14-2018 06:24 PM
  6. PaulQ's Avatar
    I use "Hey Google" for my Home devices and "Ok Google" for my phone.

    EDIT: sorry that's on my Galaxy S9+ where it doesn't respond to "Hey Google" only "Ok Google".
    Bingo.... this used to be my solution too. Now they both respond to both.

    This is just an annoyance right now. It hasn't actually interfered with my smart home functions (yet).
    06-14-2018 06:25 PM
  7. Kirstein Gourlay's Avatar
    I believe there are multiple routes to what I think is the setting. Here is one way....

    1. Open your Google Feed (or whatever they call it - swipe right)
    2. At the bottom-right, tap the hamburger menu
    3. Select SETTINGS
    4. At the top, under Google Assistant, select SETTINGS
    5. On the next screen, look down the list under "devices" and pick "PHONE"
    6. In the second section titled "Get hands free help with voice match," turn off the first option labeled "Access with voice match"


    In my case, it seems to magically re-enable itself. I wonder if it has something to do with Android Auto. OK Google continues working when this setting is off. In fact, it pops up a notification to that effect when you turn it off as described above.

    If you don't use Android Auto, let us know if it stays off for more than a couple days.
    Thank you
    06-15-2018 12:31 AM

Similar Threads

  1. My tab 4 is not getting recongized by my pc...
    By tamer442005 in forum Ask a Question
    Replies: 16
    Last Post: 06-14-2018, 01:01 PM
  2. how to fix android brightness?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-11-2018, 10:19 PM
  3. Replies: 1
    Last Post: 06-11-2018, 10:17 PM
  4. Volume randomly lowers and go back to normal
    By Trizorg in forum Verizon Galaxy Nexus
    Replies: 1
    Last Post: 06-11-2018, 09:59 PM
  5. Walmart Pay Not Working - Pixel2
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-11-2018, 07:32 PM
LINK TO POST COPIED TO CLIPBOARD