1. clohrey's Avatar
    The Pixel 2XL is driving me crazy! The android auto was working a few months ago fine and now it doesn't. It started with pandora not working, then it went to the whole system not showing up on the screen. I have tried everything. I tried new cords, updated the Ford system, did a factory reset on the phone. It is literally driving me crazy. Now the charger all of a sudden doesn't work.

    I hate this phone, looking at Note 9. I have had it.
    09-05-2018 11:37 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! If you connect the phone to your computer via USB, does the computer recognize it? If not, there's probably an issue with the USB-C port. Assuming you're the original owner of the phone, and there's been no damage from water or trauma, you should be able to request warranty repair or replacement from Google.
    09-05-2018 11:58 AM
  3. kmf1's Avatar
    @ B. Diddy...regarding USB connecting to computers: Should the Pixel 2 XL work with the Android File Transfer app and a Mac computer running 10.13 6? I tried to connect, with no success.
    09-05-2018 12:17 PM
  4. Veraton's Avatar
    Welcome to Android Central! If you connect the phone to your computer via USB, does the computer recognize it? If not, there's probably an issue with the USB-C port. Assuming you're the original owner of the phone, and there's been no damage from water or trauma, you should be able to request warranty repair or replacement from Google.
    I don't think it's a USB C Port. I have this exact issue, as do many others see the below google product forum thread.

    I also chatted with Pixel Support yesterday 9/4 and as soon as I mentioned Android Auto they said there is a known issue and to wait until the next update to see if it's resolved. Of course they could provide no details as to when that is.

    My Nexus 6P (latest updates) connects to my vehicle without issue with multiple cables but my Pixel XL 2 has stopped connecting completely, it has been iffy since the Android Pie update requiring me to unplug and replug multiple times to get it to trigger but charging works fine. (2017 Honda CRV)

    https://productforums.google.com/for...%7Cspell:false
    B. Diddy likes this.
    09-05-2018 01:00 PM
  5. B. Diddy's Avatar
    I don't think it's a USB C Port. I have this exact issue, as do many others see the below google product forum thread.
    The main reason I was suspecting the port was that the OP also mentioned that the charger no longer works either (unless they specifically meant charging from the car's USB port only). I have seen discussions about wonky Android Auto issues, so that thought did cross my mind.
    09-05-2018 01:20 PM
  6. B. Diddy's Avatar
    @ B. Diddy...regarding USB connecting to computers: Should the Pixel 2 XL work with the Android File Transfer app and a Mac computer running 10.13 6? I tried to connect, with no success.
    Sorry, I can't say for sure since I don't use Macs myself. I know that Android File Transfer has been buggy pretty much forever, so it'd be hard to say if it's an issue with the phone, the Mac, or AFT (or some combination).
    09-05-2018 01:21 PM
  7. kmf1's Avatar
    Sorry, I can't say for sure since I don't use Macs myself. I know that Android File Transfer has been buggy pretty much forever, so it'd be hard to say if it's an issue with the phone, the Mac, or AFT (or some combination).
    Just curious. Thanks!
    09-05-2018 01:27 PM
  8. jonratner999's Avatar
    I was having a problem with Android file transfer on my Mac as well. I resolved this by stopping sync of Google drive while you are using Android file transfer. It then works as it always had.
    09-05-2018 05:05 PM
  9. kmf1's Avatar
    I will give that a try. Thanks!
    I was having a problem with Android file transfer on my Mac as well. I resolved this by stopping sync of Google drive while you are using Android file transfer. It then works as it always had.
    09-05-2018 05:29 PM
  10. vansmack's Avatar
    Android Auto and the Pixel XL 2 are so strange. I'm sorry yours is still sucking....

    After countless reboots with Oreo and Pie (both pre and final release), multiple USB-C cables and many helpful though unproductive chats with Google, the Aug 9 update finally fixed my Android Auto problems with my wife's Chevy Bolt. It's been solid for three weeks now [knockonwood]

    I'm fairly convinced I'm one update away from going back to AAHell, but I'll take it for now.
    09-05-2018 06:40 PM
  11. TANDC's Avatar
    We had the same issue and for us it was the cord...the one we had been using charged and everything but for some reason didnt work with our new Kenwood.

    Able to try another phone?
    09-06-2018 02:32 PM

Similar Threads

  1. Hard reset doesn't work for samsung galaxy tab 2 10.1
    By Android Central Question in forum Ask a Question
    Replies: 28
    Last Post: 09-18-2018, 03:22 PM
  2. Google Pixel app notifications with no sound
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 09-09-2018, 03:36 AM
  3. samsung galaxy j3 2017 power button not working?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-05-2018, 12:13 PM
  4. My android 6.1 is not reading my sim card
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-05-2018, 12:10 PM
  5. why is my infinix X572 not rebooting and staying on the operating system level
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-05-2018, 12:00 PM
LINK TO POST COPIED TO CLIPBOARD