1. MJ Yoon's Avatar
    Hi I bought 2 google pixel2 for my wife and myself a year ago.
    We both were satisfied with the device.

    However, couple weeks ago, I smelled something burning and I saw that smoke was coming out from the charging port. It was just 10~15 mins after I had plugged the official charging cable. I plugged out the charging cable and checked everything. Phone was working fine except burnt smell and very hot at the bottom of the device. After a while I gave it a try to recharge it and realized that charging did not work, showed volt icon that usually appears when charging for a sec and disappeared. I did factory reset and after that volt icon showed up which means cable was detected but device didn't charge at all. Is there anyone who has the same issue with Pixel2?

    UPDATE: I requested call to Google Support Team and filed the issue. I submitted the form and sent photos of device in order to make sure whether it has any visible physical damage. They said the issue has been forwarded to the specialist and they will contact me in couple days.

    After few days, I haven't got any contact, so I called support team again and they asked me to follow up through the email that I submitted the form.

    I sent email couple more time to the email and still no answer.
    Now phone is a brick. It has been out of battery and no way to charge it.
    12-21-2018 03:20 PM
  2. Mooncatt's Avatar
    Did you try a new USB cable? I had one of those short out on me and caused a similar problem (bad USB cables are common, but rare to short out like that). You may get lucky and that's all it is. If not, then definitely a hardware fault inside the phone. Chances are it can be fixed but you may have to pay for it if you don't have warranty. Resetting the phone won't do anything for hardware faults.
    12-21-2018 03:42 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! That sounds frustrating. Were you using the original charging cable and plug, or a 3rd party one? Is it possible there was some moisture in the port when you plugged it in?
    12-22-2018 02:51 AM
  4. Rukbat's Avatar
    It can take a week for them to get back to you, but Google is one of the best companies for customer service.
    @Mooncatt - the Pixel 2 is still under warranty.
    12-22-2018 01:45 PM
  5. o4liberty's Avatar
    Never had that happen on any device was your wall outlet bad or loose this would cause this issue.
    12-24-2018 06:42 PM
  6. Mike Dee's Avatar
    Never had that happen on any device was your wall outlet bad or loose this would cause this issue.
    A loose wall outlet should not cause an issue at the USB C port
    01-01-2019 05:05 PM

Similar Threads

  1. How to remove Google search bar after Pie update
    By dangerousfen in forum Nokia 7.1
    Replies: 6
    Last Post: 12-28-2018, 04:53 PM
  2. Pixel 3 DxOMark 101 ..??
    By DMP89145 in forum Google Pixel 3 & Pixel 3 XL
    Replies: 57
    Last Post: 12-28-2018, 09:56 AM
  3. Is anyone having problems with their Smart Lock / google assistant on a pixel 3?
    By Stephlauren1991 in forum General Help and How To
    Replies: 0
    Last Post: 12-21-2018, 01:29 PM
  4. Can't login to my google account after factory reset.
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-21-2018, 12:41 PM
  5. Replies: 0
    Last Post: 12-21-2018, 10:43 AM
LINK TO POST COPIED TO CLIPBOARD