1. Android Central Question's Avatar
    It appears, I can't say conclusively, that around the time of the May security update on my Pixel 2, GPS and location services intermittently stop updating. For example, apps that use the phone's location (Google maps-- both on the handset and android auto, mapmyride, ingress) will not change my location as I move around. Sometimes, google maps on android auto will update, but only around every 10-20 seconds, and will place my blue dot someplace random in the vicinity, nowhere near me. Google Maps on Android Auto will say "Searching for GPS", Waze's location will just float around the map.

    A restart will fix the problem, every time. But usually about once a day it comes back, requiring another restart. Very annoying.

    I've done the following:
    1. Cleared storage and cache for apps that use locations.
    2. Cleared storage and cache for Google Maps.
    3. Turned location services on and off, and set to "high accuracy"
    4. Updated A-GPS data with GPS Status app.
    5. Complete factory reset.
    06-02-2019 08:11 AM
  2. Ken Burton's Avatar
    It appears, I can't say conclusively, that around the time of the May security update on my Pixel 2, GPS and location services intermittently stop updating. For example, apps that use the phone's location (Google maps-- both on the handset and android auto, mapmyride, ingress) will not change my location as I move around. Sometimes, google maps on android auto will update, but only around every 10-20 seconds, and will place my blue dot someplace random in the vicinity, nowhere near me. Google Maps on Android Auto will say "Searching for GPS", Waze's location will just float around the map.

    A restart will fix the problem, every time. But usually about once a day it comes back, requiring another restart. Very annoying.

    I've done the following:
    1. Cleared storage and cache for apps that use locations.
    2. Cleared storage and cache for Google Maps.
    3. Turned location services on and off, and set to "high accuracy"
    4. Updated A-GPS data with GPS Status app.
    5. Complete factory reset.
    Having similar random gps issues with my pixel 2xl running Android Q beta 3.
    06-02-2019 10:15 AM
  3. GSDer's Avatar
    A restart will fix the problem, every time. But usually about once a day it comes back, requiring another restart.
    The good news is that if a restart fixes the problem then it's probably not a hardware issue.
    Unfortunately that doesn't make the problem any less annoying. Since it's random it's difficult to recommend Safe mode (I assume that after the Factory Reset you reloaded your normal apps?) but if you can survive a day without other 3rd party applications you may want to consider that.
    Or if you suspect that it had something to do with the May Security update (I don't remember seeing anything about changes to GPS functionality in that update) you could flash the April build and see if the problem goes away.
    06-02-2019 02:34 PM
  4. GSDer's Avatar
    Having similar random gps issues with my pixel 2xl running Android Q beta 3.
    You could try unenrolling from the Beta, which will put you back on Pie, and see if that solves the problem.
    I haven't experienced that on my Pixel 2 XL running the Android Q Beta 3, although due to the new restrictions several 3rd party applications have to be granted the "Allow all the time" permission rather than the (more appropriate IMO) "Allow only while using the app" permission.
    06-02-2019 02:41 PM
  5. Rukbat's Avatar
    If it's only happening on the beta, report it.

    If it's happening on Pie, I can tell you that with a few long drives since the May update, mine has never lost a beat, so it's your phone, not the update. Maybe installing TWRP, for a full data (data only, nothing else) backup (then copy the whole emulated/0 to a PC), then flashing the full factory ROM (Google | Factory Images for Nexus and Pixel Devices), then installing TWRP and restoring from the backup, will fix it. (If not, you may have a hardware problem.)
    06-03-2019 04:17 PM
  6. Zedd's Avatar
    I got the June 5th update today, the 4th, thats strange. Perhaps if you install it that will fix your issue. Google is going to want you to do a factory reset, thatwill fix it too but sucks having to do it, very time consuming..
    good luck!
    06-04-2019 11:32 AM
  7. NewArtDroid's Avatar
    I'm having the same problem over the last few weeks. Today, I had it for my entire ride to work, and missed hearing about an accident that delayed me 30 minutes. It seems when I restart the phone as well, it goes away, only to come back later. I'm not doing beta anything. Just use of the phone. Any help would be appreciated.
    06-10-2019 07:45 AM
  8. Hyacin's Avatar
    Same here, still, in August. Oddly though it only started a couple weeks ago, I was running Dirty Unicorns at the time, and I hadn't flashed an image or changed anything major in at least a couple months. I wiped and went back to factory hoping that would fix it, but it continued ... and the same as everyone else here, a reboot fixes it, but only for a bit and then it comes right back ... it is driving me batty.
    08-19-2019 11:39 AM

Similar Threads

  1. What does it mean on my Google activity com.awti.slc
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 06-02-2019, 11:32 PM
  2. i need to format my phone
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-02-2019, 03:14 PM
  3. I have a samsung 10+ and the games in the kids home (preinstalled) app wont download
    By Android Central Question in forum Samsung Galaxy S10 & S10+
    Replies: 1
    Last Post: 06-02-2019, 10:38 AM
  4. Replies: 1
    Last Post: 06-02-2019, 05:07 AM
  5. What does com.awti.slc means in Google activity
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-02-2019, 02:16 AM
LINK TO POST COPIED TO CLIPBOARD