1. PhobicCarrot's Avatar
    I tried taking a photo this AM directly in Android messages on my 3XL, it did not work. The app kept telling me that it could not take the photo. I was able to take a photo from the camera app.

    Now (after a reboot), when I launch the Camera app, it either just gives a black screen, or quits. When I try to switch to the Front facing camera, the app quits.

    I am considering returning the device.

    EDIT: And the FLASHLIGHT is grey-ed out as well.

    EDIT: A subsequent reboot has enabled the camera again, but I can re-create the problem by trying to take a photo from w/in the Messages app.
    10-22-2018 11:23 AM
  2. puch96's Avatar
    I'm not having this issue. Maybe get an exchange?
    10-22-2018 12:22 PM
  3. mustang7757's Avatar
    Not having that issue just tried
    Go into settings then app find camera clear cache and storage then force close see what happens
    10-22-2018 12:28 PM
  4. PhobicCarrot's Avatar
    Nope. Tried clearing cache, force stopping, clearing all data.....nothing fixed it.
    10-22-2018 12:32 PM
  5. mustang7757's Avatar
    Nope. Tried clearing cache, force stopping, clearing all data.....nothing fixed it.
    Maybe try it for message app?
    10-22-2018 12:35 PM
  6. PhobicCarrot's Avatar
    Maybe try it for message app?
    ;( No change.
    10-22-2018 12:40 PM
  7. mustang7757's Avatar
    ;( No change.
    I'm sorry running out of options except factory reset if u want
    10-22-2018 12:41 PM
  8. PhobicCarrot's Avatar
    UPDATE: Twitter causes the same issue, so I believe it is a function of the CAMERA app.
    10-22-2018 12:48 PM
  9. PhobicCarrot's Avatar
    UPDATE: Factory Data Reset did not fix the problem.
    10-22-2018 01:38 PM
  10. Lobwedgephil's Avatar
    Sounds like you need to return or request a replacement. Sucks.
    10-22-2018 01:41 PM
  11. Mike Dee's Avatar
    10-22-2018 01:54 PM
  12. PhobicCarrot's Avatar
    Spent an hour on the phone w/ Google support. Ended up replacing the device.
    mustang7757 likes this.
    10-22-2018 03:30 PM
  13. mustang7757's Avatar
    Spent an hour on the phone w/ Google support. Ended up replacing the device.
    Good , you spend the money you should have it working
    10-22-2018 03:39 PM
  14. Mike Dee's Avatar
    Spent an hour on the phone w/ Google support. Ended up replacing the device.
    I know it's a hassle but in the end it'll be worth it.
    10-22-2018 05:05 PM
  15. EMGSM's Avatar
    Glad to hear you're getting a new phone. Hope the new one works the way it's supposed to.
    10-23-2018 01:19 AM
  16. PhobicCarrot's Avatar
    OP: So far so good. Its been 15 hrs with the replacement device.
    TrueBlueKew and puch96 like this.
    10-23-2018 07:49 AM
  17. Mike Dee's Avatar
    OP: So far so good. Its been 15 hrs with the replacement device.
    Great!
    10-24-2018 08:38 AM
  18. mustang7757's Avatar
    I just got update from play store , don't Kno if it fixes any problems anyone having.
    bhatech likes this.
    10-24-2018 08:42 AM
  19. gsainath4u's Avatar
    Most likely a Camera drivers(software) or the sensor(hardware) issue.
    When an app (like messages or twitter) requests to take a photo, the camera app has to take the photo and give the result back to the requesting app.
    In your case, looks like that communication between the Camera and the requesting app is getting corrupted somehow and is causing the camera (hardware) to be in a bad state.

    Glad that you could get a replacement for it.
    10-24-2018 10:32 AM
  20. GSDer's Avatar
    OP: So far so good. Its been 15 hrs with the replacement device.
    Would have been interesting to see if it worked properly in Safe mode (just with the stock Android Messages application of course; no Twitter test), just to see if some 3rd party application was involved in the problem.
    10-24-2018 01:17 PM
  21. PhobicCarrot's Avatar
    Would have been interesting to see if it worked properly in Safe mode
    Tried Safe Mode. No difference.

    I also tested it after FDR, but before adding any 3d party apps.
    10-24-2018 01:34 PM
  22. bhatech's Avatar
    I have been having issues with the camera app, opens up and then just shows a dark blank screen, can't click any button and force closing the app doesn't work, only restraining the phone fixes the issue. I have also seen the QR scanner doesn't work. For example if go messages app and in settings click messages for web to scan the QR code it doesn't work and just hangs. Same with trying to scan QR code for WhatsApp web. I don't know if the latest camera updates are causing the issues for me. I did even a complete factory reset and set up everything from scratch instead of restoring from back up to see if the issues goes away. But still same issues with the camera app and works fine after I restarted the phone.


    10-25-2018 03:04 PM
  23. mustang7757's Avatar
    I have been having issues with the camera app, opens up and then just shows a dark blank screen, can't click any button and force closing the app doesn't work, only restraining the phone fixes the issue. I have also seen the QR scanner doesn't work. For example if go messages app and in settings click messages for web to scan the QR code it doesn't work and just hangs. Same with trying to scan QR code for WhatsApp web. I don't know if the latest camera updates are causing the issues for me. I did even a complete factory reset and set up everything from scratch instead of restoring from back up to see if the issues goes away. But still same issues with the camera app and works fine after I restarted the phone.


    https://uploads.tapatalk-cdn.com/201...b6021495cb.jpg
    OP replaced the device to fix it
    10-25-2018 03:11 PM
  24. bhatech's Avatar
    Grr saw the edits...so time to ask for a replacement I guess.
    OP replaced the device to fix it
    10-25-2018 03:30 PM
  25. mustang7757's Avatar
    Grr saw the edits...so time to ask for a replacement I guess.
    You tried everything else so probably best bet.
    10-25-2018 03:36 PM
52 123

Similar Threads

  1. S5 camera failed
    By hochien in forum Software Development and Hacking
    Replies: 1
    Last Post: 10-25-2018, 04:46 PM
  2. My CPU is at 100% level, draining battery, but no app appears to be active
    By Android Central Question in forum Ask a Question
    Replies: 7
    Last Post: 10-25-2018, 04:16 AM
  3. I cant find an app.in the app manager .
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-22-2018, 02:28 PM
  4. My phone doesn't allow apps to access photos
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-22-2018, 03:18 AM
  5. Huawei P8 won't let apps access my photos
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-22-2018, 03:12 AM
LINK TO POST COPIED TO CLIPBOARD