1. pdarrah's Avatar
    Since updating to Android 10, my photos are only backing up/syncing with the cloud when I open the Photos app. If I don't remember to open the app to let it backup, then the only copy is on my phone.

    I had a similar problem when Pie was first installed and all I needed to do was change the App setting to NOT optimize the battery for the Photos App. I have checked (multiple times) and the Photos App is still set to NOT optimize, but the syncing will only happen when I open the app.

    Anyone else seeing this? Any ideas for a fix?
    10-08-2019 02:38 PM
  2. B. Diddy's Avatar
    Any power-saving modes turned on, or 3rd party battery-saver apps installed?
    10-08-2019 07:08 PM
  3. pdarrah's Avatar
    Any power-saving modes turned on, or 3rd party battery-saver apps installed?
    The only Battery App I use is GSam Battery Monitor and I don't think it does any "saving" - it just shows info about usage.

    If there are any other power-saving modes, I am not aware of them.

    Battery settings: Battery Saver -Off, Adaptive Battery - On

    Apps settings: Advanced - Battery Optimization - show list of "Not Optimized" and Photos is included on the list.

    I guess I am assuming that the "Not Optimized" for Photos means that Adaptive Battery does not mess with it.

    I could try turning off Adaptive Battery, but it seems to be an all or nothing type setting and I'm concerned it will really impact battery life if I get rid of it.
    10-09-2019 08:58 AM
  4. B. Diddy's Avatar
    You have it set to back up on wi-fi only, correct?
    10-09-2019 09:22 AM
  5. pdarrah's Avatar
    You have it set to back up on wi-fi only, correct?
    Yes - in the Photos app, under Backup&Sync I have Cellular Data turned off.

    The Backup/Sync works perfectly when I open the app - it immediately starts syncing whatever is queued up. This would make sense if I had just come back onto WiFi, but I have taken pictures while connected to Wifi and they still get queued up until the app opens.
    10-09-2019 11:42 AM
  6. B. Diddy's Avatar
    Does that happen in Safe Mode as well?
    10-09-2019 12:53 PM
  7. pdarrah's Avatar
    I've never used Safe Mode. Guess I should look it up and give it a try. I am just loading the October update right now, so I'll check when it is done and see if it is still doing it.

    Edit: Yes!!! Latest update has fixed it for me.

    Thank you B. Diddy for looking at it.
    B. Diddy likes this.
    10-09-2019 02:47 PM

Similar Threads

  1. Google drive not showing backup
    By Rohan Jangam in forum Ask a Question
    Replies: 6
    Last Post: 10-10-2019, 10:12 AM
  2. Any app that gives total vertical ascent and descent (in real time)?
    By 44Joan in forum Samsung Galaxy Watch Active 2
    Replies: 4
    Last Post: 10-10-2019, 08:42 AM
  3. Is there a way to skip the Android 10 Sept update and go to Oct directly
    By TechZOnline in forum Google Pixel 2 & Pixel 2 XL
    Replies: 4
    Last Post: 10-09-2019, 09:28 AM
  4. Replies: 2
    Last Post: 10-08-2019, 04:20 PM
  5. Screen Recording & other Feature Flags - Android 10
    By Pixelfan56 in forum Google Pixel 3 & Pixel 3 XL
    Replies: 1
    Last Post: 10-08-2019, 01:37 PM
LINK TO POST COPIED TO CLIPBOARD