1. Pete Acton's Avatar
    I have a pixel 3a and android auto has never worked properly when connected via usb to my Kenwood head unit.I have contacted google and done what they suggest but it still disconnects from a/a after 2-3 mins.Tried various usb cables and other android phones running android 9 works fine.Apple car play works ok...Pixel 3a runnning Android 10 doesnt work....Im about to give up and get an apple i phone !! Any one have any ideas...thanks
    01-24-2020 03:33 AM
  2. SpookDroid's Avatar
    Have you tried another Android 10 device? I have no issues on mine, but it's a Note 10 on a Hyundai unit. IF another Android 10 device works, however, then it's a phone compatibility issue (Google´s fault), but if another Android 10 device also fails, then it's a car unit problem (Kenwood's fault, Google MIGHT help but the issue is not on their end).

    Have you made sure that Android Auto is not set to battery saving and is allowed to always run in the background? Have you tried clearing AA's cache/data or uninstalling/rebooting/re-installing? What about unpairing your car unit from Bluetooth and re-pairing as well?
    Pete Acton likes this.
    01-24-2020 07:28 AM
  3. B. Diddy's Avatar
    Welcome to Android Central! I moved this from the Pixel 3 forum to the Pixel 3a forum.
    01-24-2020 11:46 AM
  4. Coop61's Avatar
    I have a pixel 3a and android auto has never worked properly when connected via usb to my Kenwood head unit.I have contacted google and done what they suggest but it still disconnects from a/a after 2-3 mins.Tried various usb cables and other android phones running android 9 works fine.Apple car play works ok...Pixel 3a runnning Android 10 doesnt work....Im about to give up and get an apple i phone !! Any one have any ideas...thanks
    Have you checked to see if there were any firmware updates for you Kenwood head unit? AA works great on my Kenwood with my Pixel3xl.
    01-24-2020 05:45 PM
  5. foxbat121's Avatar
    Same here. Both wireless AA and wired AA work fine on my Kenwood head unit.
    Coop61 likes this.
    01-25-2020 11:09 AM

Similar Threads

  1. Replies: 5
    Last Post: 01-24-2020, 06:01 PM
  2. wont turn on
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 01-24-2020, 03:59 PM
  3. Android app pictures
    By jeffwalkerlegal in forum General Help and How To
    Replies: 3
    Last Post: 01-24-2020, 06:20 AM
  4. Cannot print on WIFI Printer
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-2020, 01:45 AM
  5. galaxy j7 pro sm-j7 samsung android
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-2020, 01:37 AM
LINK TO POST COPIED TO CLIPBOARD