1. d4005's Avatar
    I'm finding that my P6P will attempt to connect to any wifi - even insecure ones. What I'd like is that it will only ever connect to the ones in my saved networks list. Looking at the screenshots below, I can't get things to work like that.

    If I disable "Find and connect to Wi-Fi networks" then it simply drops my current connection (which is on my saved list). So that should basically be called "Wi-Fi On/Off".

    Want to auto-connect only to known Wi-Fi...-2022-01-19-15.17.10.jpg

    You see on that screenshot above it says "Network preferences: Connect to public networks".

    If I go into those Network preferences hoping to disable that, by toggling off the two check-boxes and go back a level - it still says "Connect to public networks".

    Want to auto-connect only to known Wi-Fi...-2022-01-19-15.21.15.jpg

    The option in there "Turn on Wi-Fi automatically: Wi-Fi will turn on near high-quality saved networks, like your home network" - that sounds really promising but I don't think it is. Turning off the "Notify for public networks: When automatic connection isn't available" sounds like something that should be off - and it is - but it still says "Connect to public networks" in the settings screen above it.

    It's making me want to just turn Wi-Fi off completely every time I'm not in the vicinity of a Saved network. I could automate that with Tasker if I have to - although one of my key triggers for my "at home" state is when it connect to my home Wi-Fi - so maybe not. The GPS triggers I never find particularly reliable.

    Does anyone here (with or without Tasker) successfully get their P6P to only connect to one of their Saved Networks?
    01-19-2022 08:43 AM
  2. B. Diddy's Avatar
    Go to your list of saved wi-fi networks and look at any of the public networks that might be saved. Make sure the Auto-Connect toggle is turned off there.
    01-19-2022 11:07 AM
  3. d4005's Avatar
    Go to your list of saved wi-fi networks and look at any of the public networks that might be saved. Make sure the Auto-Connect toggle is turned off there.
    The only networks there were ones that it randomly connected to (without my knowledge) in the last couple of weeks. I deleted each of them and now I'm down to just a handful that are known to me. But I'm sure the next time I walk/drive past an open one it's going to auto-connect. Even trying to connect without knowing the password has its risks.
    01-19-2022 12:53 PM
  4. Ben_70's Avatar
    I keep Turn on WF Automatically off and Notify for Public Networks on and have never had an issue with the phone automatically connecting to public networks and the phone does auto switch onto my saved WF list.
    Blaize19 likes this.
    01-19-2022 01:04 PM
  5. d4005's Avatar
    I keep Turn on WF Automatically off and Notify for Public Networks on and have never had an issue with the phone automatically connecting to public networks and the phone does auto switch onto my saved WF list.
    Thanks - I'll give that configuration a try.

    The description "Notify for public networks: When automatic connection isn't available" does seem to imply that if automatic connection is possible (when there's no security/password) then it won't notify you because it didn't need to.
    01-19-2022 01:13 PM
  6. Blaize19's Avatar
    I keep Turn on WF Automatically off and Notify for Public Networks on and have never had an issue with the phone automatically connecting to public networks and the phone does auto switch onto my saved WF list.
    Same here. Never had an issue with it set this way.
    01-19-2022 02:28 PM
  7. StormnNJ's Avatar
    My OG and 3 used to connect to verified open networks but I haven't seen that on P5 or P6P. It would connect to hotspots without my knowledge and show a G with a key symbol in notifications. I thought they did away with it but still part of Google connectivity services according to Play store.
    01-19-2022 02:40 PM
  8. d4005's Avatar
    I think I might have jumped to conclusions earlier. I was seeing the notification for the connection being offered and assumed I'm only being offered it because it would need a password. My concern was that if it was an open network it would have auto-connected without asking me. I got offered this one today and went into the options and see that I can disable the notification.

    Want to auto-connect only to known Wi-Fi...-2022-01-21-09.14.03.jpg Want to auto-connect only to known Wi-Fi...-2022-01-21-10.10.18.jpg
    B. Diddy likes this.
    01-21-2022 07:27 AM
  9. spARTacus's Avatar
    Hmmm. Not sure I ever had these problems with my Android devices. For me, WiFi is always on and the devices will always "see" all/any SSIDs that it might detect, but it will never try to auto connect to any SSID unless I have previously connected and unless the toggle is set to "automatically re-connect". I never wondered much about the "Wi-Fi will turn on near high-quality saved networks, like your home network". For that to work, Wifi is probably actually on but just not being shown as on to the user (otherwise how would the device know that a high quality SSID is nearby), unless it is using saved geolocation information (which could also raise eyebrows to some people).
    01-21-2022 07:44 AM

Similar Threads

  1. my S21 slows down throughout the day until i have to restart it
    By walterkurtz in forum Samsung Galaxy S21 & S21+ & S21 Ultra
    Replies: 22
    Last Post: 02-15-2022, 02:36 PM
  2. galley app notification categories after update 11 to 12 how many
    By y2jman in forum Samsung Galaxy S20 & S20+ & S20 Ultra
    Replies: 0
    Last Post: 01-21-2022, 02:12 AM
  3. Can I cast from my Pixel 4 to a Samsung SmartTV?
    By Paul Mena in forum Google Pixel 4 & Pixel 4 XL
    Replies: 7
    Last Post: 01-20-2022, 11:18 PM
  4. Moto E7 power wont connect to home wifi
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-20-2022, 08:55 PM
  5. How high does the battery power need to be to update your tablet
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-20-2022, 05:22 PM
LINK TO POST COPIED TO CLIPBOARD