1. athompson99's Avatar
    I have a Pixel from Verizon. I have HD Voice Enabled on my account. I have wifi calling enabled on the device. I have worked with both Verizon and Google to troubleshoot. No one seems to have any real knowledge on this feature.

    I have poor cell signals in my house so I want to use wifi calling. Google Hangouts works fine. To test I put the phone in Airplane mode and then turn back on the wifi. (No Cell bars). Hangouts makes and receives calls, but the native Pixel dialer will not.

    It seems like some people here have it working. Could you please let me know how you know you are making a wifi call and what you did to get it to work. Thank you.
    10-28-2016 05:27 AM
  2. big_Drew's Avatar
    You'll know it's enabled if your lockscreen or notification shade says Wifi Calling. It works for me on T-Mobile but I had to re-register my e911 address with the carrier for some reason and reboot. The problem must be on Verizon's end.

    I can't get my Google Pixel to make a wifi call-screenshot_20161028-090841.jpg
    deesugar likes this.
    10-28-2016 08:18 AM
  3. deesugar's Avatar
    You'll know it's enabled if your lockscreen or notification shade says Wifi Calling. It works for me on T-Mobile but I had to re-register my e911 address with the carrier for some reason and reboot. The problem must be on Verizon's end.
    Verizon doesn't have a lockscreen notification for Wi-Fi calling. And therein lies the problem. Wi-Fi calling is poorly supported, and even worse in its clarity of use. I know I have activated Wi-Fi calling because I can make normal calls when in airplane mode and on Wi-Fi. You can see in the screen shot it says, "Wi-Fi Call" in the Phone App and that's the only way you would know. If you were in any other screen you wouldn't know because there is no icon in the notification area. There is no way to know if you've successfully enabled Wi-Fi Calling either.

    I can't get my Google Pixel to make a wifi call-verizon-wifi-calling.jpg


    Additional Things:

    • I had to go in my Settings-->More-->Network settings reset and reset my network connections while Verizon tech reset my network settings on his end in order to make WiFi Calling work.
    • You will get a notice to turn off Airplane mode when testing a WiFi call under Airplane mode which is understandable, just ignore it and try again which usually works.
    • I use Adguard (an ad blocker app) and it definitely interferes with WiFi calling. I suspect any VPN app that loop backs will have a problem but I did test it out on my work VPN and you'll be happy to know that I was able to make calls.
    • I have Google Voice forwarding to my phone.
    10-28-2016 12:31 PM

Similar Threads

  1. My sd card unmouting itself randomly
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-30-2016, 11:39 AM
  2. I need a pin code rent a center because lock my phone?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-28-2016, 12:57 PM
  3. My phone says there is data but doesnt work
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-28-2016, 06:39 AM
  4. can't play this video in samsung galaxy j5 prime
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-28-2016, 06:35 AM
  5. I can't download from the google play store app
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-28-2016, 06:33 AM
LINK TO POST COPIED TO CLIPBOARD