1. pab61's Avatar
    I got my Pixel back in January of this year. When I first got it I had no issues with connecting to any wi-fi. Now I can only connect to 5ghz wi-fi. Any time I tryto connect to a 2.4 network the connection just says saved and it jumps to the 5ghz. I am not sure when this started but it's been at least a few months. Has anyone else experienced this? Any suggestions on a solution?
    05-13-2017 09:25 AM
  2. Golfdriver97's Avatar
    Have you tried a reboot?
    05-13-2017 09:38 AM
  3. N4Newbie's Avatar
    Do you have any other devices connected to the 2.4 GHz band? If so, are they working?

    My Netgear WNDR3700V4 router's 2.4 GHz band has a habit of ceasing to function at random times and, to get it going again, I have to perform a reboot from the router's Advanced menu (or, simply pull the plug...). I know when it happens because my wife's HP laptop (which does not have 5.0 GHz Wi-Fi capability, only 2.4) loses internet connectivity and, when I look at the available Wi-Fi connections, my router doesn't show in the list.

    After a reboot all will be fine until the next time, which may be weeks or more away. I just had to boot it this morning, as a matter of fact.
    05-13-2017 09:43 AM
  4. pab61's Avatar
    Everything else, laptops, tablet, Iphones connects with no issues. It's only my Pixel and it is every 2.4g network. Not just at home.
    05-13-2017 10:05 AM
  5. N4Newbie's Avatar
    Everything else, laptops, tablet, Iphones connects with no issues. It's only my Pixel and it is every 2.4g network. Not just at home.
    Ah, okay.

    Two things to try:

    1. Go to Settings -> Wi-Fi and long-press the 2.4 network connection. From the pop-up context menu, tap Forget network. Next, go ahead and re-add the network and see if it will connect.

    2. If that doesn't work, try Settings -> Wireless & networks -> More... and try a Network settings reset. You will have to re-add all of your wireless networks (and re-pair your Bluetooth devices, if I recall correctly). PITA, but worth trying.

    If still no joy, then possibly a hardware failure?
    05-13-2017 10:11 AM
  6. pab61's Avatar
    Thanks, no joy.
    05-13-2017 10:31 AM
  7. N4Newbie's Avatar
    Thanks, no joy.
    If Network Settings Reset didn't fix it and yet other devices connect to the same network, it certainly sounds like a possible hardware issue.

    As a last resort, if it were my own device, I would probably try a full factory reset, or - wild & crazy time - I would use WugFresh's Nexus Root Toolkit (Nexus Root Toolkit v2.1.9) to wipe and reinstall the operating system.

    The more practical owner might choose to call Google Support instead.

    But, before we move on, one more question: have you tried "Forgetting" the 5G connection and then see if it will connect to the 2.4G one? It is at least possible that the phone has an internal preference for 5G or that it sees the 5G network as being the better (faster, more reliable, stronger signal) of the two options at any given moment.
    05-13-2017 10:56 AM
  8. 4Boots4u's Avatar
    Same exact problem. All other devices connecting without problem. Pixel with either not even show WiFi, or goes through a cycle of showing WiFi network as "saved" then "connecting" and ultimately "disabled"
    05-13-2017 09:38 PM
  9. 4Boots4u's Avatar
    I tried both of these without success
    05-13-2017 09:38 PM
  10. pab61's Avatar
    Thanks for all of your help. Verizon is sending me a new phone.
    05-14-2017 08:55 AM

Similar Threads

  1. What is the difference between the large and small gear fit2's?
    By AC Question in forum Samsung Gear Fit 1 & 2
    Replies: 1
    Last Post: 05-14-2017, 01:21 PM
  2. Video and spotify not working
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-13-2017, 08:26 AM
  3. Wifi and hotspot SIMULTANEOUSLY PLEASE :D same device
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-13-2017, 06:20 AM
  4. My android turns on and off, stuck on Samsung logo!
    By charlyyx in forum Samsung Galaxy A5
    Replies: 0
    Last Post: 05-13-2017, 05:17 AM
  5. Replies: 0
    Last Post: 05-13-2017, 04:22 AM