1. JasW's Avatar
    Since updating, I get at least one unexpected restart a day it seems. Sometimes a freeze and then a restart as well.

    I'd already done a factory reset after updating, so I'm not quite sure what to look for.

    Also the fact that no one else has apparently reported it here has me wondering whether it may be something peculiar to me, i.e., certain app or apps running in the background and not playing well with others.

    So: Has anyone else been experiencing this?
    09-13-2017 07:45 AM
  2. jleakey's Avatar
    Since updating, I get at least one unexpected restart a day it seems. Sometimes a freeze and then a restart as well.

    I'd already done a factory reset after updating, so I'm not quite sure what to look for.

    Also the fact that no one else has apparently reported it here has me wondering whether it may be something peculiar to me, i.e., certain app or apps running in the background and not playing well with others.

    So: Has anyone else been experiencing this?
    I haven't experienced any issues. Did you possibly tell Android to restore apps and wifi from backup?

    Other then that it could be a misbehaving application. This can be a real headache because you would have to install all your apps one by one and wait a day or so before installing the next.
    09-13-2017 07:58 AM
  3. JasW's Avatar
    I haven't experienced any issues. Did you possibly tell Android to restore apps and wifi from backup?

    Other then that it could be a misbehaving application. This can be a real headache because you would have to install all your apps one by one and wait a day or so before installing the next.
    Yes, I restored the way I usually do after a factory wipe -- app data, device settings, contacts, etc. from my Google backup account. I'm not sure why that would introduce a problem with Oreo that hadn't been there on Nougat.

    Definitely the last thing I want to do is add apps back one by one. And I'm not rooted so logcat apps are out.
    09-13-2017 08:51 AM
  4. jleakey's Avatar
    Yes, I restored the way I usually do after a factory wipe -- app data, device settings, contacts, etc. from my Google backup account. I'm not sure why that would introduce a problem with Oreo that hadn't been there on Nougat.

    Definitely the last thing I want to do is add apps back one by one. And I'm not rooted so logcat apps are out.
    Usually when I wipe and reinstall I do not restore anything. I set it up as a new device. My contacts will automatically appear when signing into my Gmail account. As for applications I just download the applications manually.
    09-13-2017 11:36 AM
  5. atakin77's Avatar
    I just had this happen to me earlier today. Curious to hear if the wipe helps out.
    09-13-2017 04:09 PM
  6. 65fastback's Avatar
    Same here. My phone never restarted or froze up. Its done it about 30 times since oreo. I'm in the beta program so I complained about it but never heard anything back.
    09-14-2017 12:14 PM
  7. NightOrchid's Avatar
    Which Region and Network are you with?..

    Alot of Play Store apps might still be on 712 compatibility,, You could try removing all except the pure google apps, which means you wont lose any contacts / emails or texts and you could just use Google Music for 2 or 3 days.,.. and see how you get on.

    Also, Try clearing the App Cache:


    https://recomhub.com/blog/how-to-cle...-and-pixel-xl/


    Lets know how it goes..
    09-14-2017 12:29 PM
  8. JasW's Avatar
    Oops. I believe I found the problem.

    After the traditional post-upgrade factory wipe, I indiscriminately dumped the entire music folder from my PC onto the phone. (Though I have an 128GB Pixel XL, I usually edit it down somewhat.) That resulted in my using 91% of the internal storage. Leaving less than 10% free internal storage on one's phone is not a good idea.

    I've freed up space, rebooted, and have not yet had any random restart (knock on wood).
    NightOrchid and DMP89145 like this.
    09-14-2017 12:46 PM
  9. NightOrchid's Avatar
    Glad you found the solution and sorted it out.

    Thanks for sharing it your solution. I could only manage to get hold of a 32GB model, so ill bear this in mind.

    Also, dont forget, using the adaptor in the box, the Pixel & XL supports USB OTG and it still has a headphone jack.. .

    Im picking myself up a mini 64GB pen drive so i can have loads of storage.

    Enjoy
    09-14-2017 01:12 PM
  10. JasW's Avatar
    Actually, the problem returned at the end of the day again, so using less than 90% of storage space is definitely not the solution to this problem, which I now see has been noted and discussed on other forums. Some people have RMA'd their Pixel because of this. If you don't have the problem, you're lucky -- you're like those people who didn't lose power after going through Irma.
    09-17-2017 06:13 AM
  11. Christopher Gilliam's Avatar
    I've been getting them pretty regular too I already did it what you did and factory reset my phone that didn't help so I factory reset it as a new phone slowly reinstall apps still kept randomly restarting not sure what's causing it
    09-17-2017 08:40 AM
  12. DJM626's Avatar
    Alot more freezing and app crashes then I've ever experienced on this phone! Have not installed any new apps. Already did factory reset. Not impressed with this oreo so far. Crappy signals again all over too
    09-17-2017 01:16 PM
  13. JasW's Avatar
    A dev on Reddit says they found a bug in Oreo's new notification channels that causes the phone to reboot, that Google has fixed it, and that the fix will be in a system update.
    09-18-2017 02:03 PM
  14. Slow_S10's Avatar
    I have had a couple of random reboots. But for me they both happened under the exact same circumstances. Which was when I would have YouTube playing in the small PiP window while doing something else. So far that has been the only times I have experienced reboots.
    Yesterday 07:34 AM
  15. Blaize19's Avatar
    Thus far no reboots for me, even with YouTube PiP.
    Yesterday 07:52 AM
  16. JasW's Avatar
    Ha, I haven't been able to try PIP because I don't have YouTube Red. Since they have a 3-month free trial, I decided I'd give it a whirl. When I received the confirmation email from Google, I clicked on the "Get Started" button in the email (this was in AquaMail) and -- the phone froze and rebooted. Yay.

    No crash when I finally did try it, though.
    Yesterday 09:27 AM

Similar Threads

  1. OREO and 6P - Questions after the update
    By Buddy1969 in forum Nexus 6P
    Replies: 11
    Last Post: Yesterday, 01:12 AM
  2. Replies: 2
    Last Post: 09-17-2017, 12:50 PM
  3. Apps on Samsung TabA crashing
    By Jolenemo in forum Samsung Galaxy Tab A (8 & 9.7)
    Replies: 5
    Last Post: 09-14-2017, 09:05 PM
  4. Replies: 2
    Last Post: 09-14-2017, 11:56 AM
  5. My google searches appear on my Wife's Facebook page
    By Martin Day1 in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2017, 12:52 PM
LINK TO POST COPIED TO CLIPBOARD