1. dlalonde's Avatar
    I bought my Pixel XL (2016) used last week. Everything was perfect. Tried Android P Beta and then went back to official Oreo. The phone worked perfectly all week.

    Then yesterday evening, I'm watching a YouTube video and the thing shuts off to never turn back on. I can't access recovery but the bootloader is there. The thing is it's locked and I can't allow OEM unlock cause I can't boot into Android.

    When I try to boot normally or go into recovery mode there's a white flicker on top. Like it's trying to load it but can't.

    It's possible that it's no longer under warranty...

    Can anyone help?

    Strangely enough, on Reddit, 3 other users say they had the exact same problem yesterday too. Anyone else here?

    Thanks
    06-01-2018 11:36 AM
  2. Gdraft#WN's Avatar
    Does the screen lite up at all?

    If not, plug it and charge it all day.

    I have had it go completely dead while playing a game or other intensive app.

    Once it dies completely, you can't just plug it on and it will turn on.

    Let it sit all day or over night on the charger.

    Should come up after that
    06-01-2018 01:07 PM
  3. dlalonde's Avatar
    Does the screen lite up at all?

    If not, plug it and charge it all day.

    I have had it go completely dead while playing a game or other intensive app.

    Once it dies completely, you can't just plug it on and it will turn on.

    Let it sit all day or over night on the charger.

    Should come up after that
    The only screen that comes up is the bootloader. Nothing else.

    So I just have to leave it plugged in for maybe 12 hours and check again if it comes back?
    06-01-2018 01:56 PM
  4. Golfdriver97's Avatar
    I'd say it's worth a shot. Reflashing the ROM will wipe the device
    06-01-2018 02:03 PM
  5. dlalonde's Avatar
    I'd say it's worth a shot. Reflashing the ROM will wipe the device
    Normally I'd agree but right now given I have a backup of everything and how afraid I am of just losing my money I don't mind wiping anything. I just want it to boot! :P

    I just plugged it in. I hope it works.

    When @Gdraft#WN says "I have had it go completely dead while playing a game or other intensive app" it reminds me that, strangely enough, it happened just after I set the video I was watching on YouTube to 720p and there was about 20% left of battery life. Maybe that's just it but then again that wouldn't be normal behavior would it?
    06-01-2018 02:30 PM
  6. dlalonde's Avatar
    Well that didn't help at all! Now I can even get into the bootloader anymore. I tried turning it on to see if it was filled up and it does nothing. Before there was still a little vibration when I pressed the power button, now nothing
    06-01-2018 05:27 PM
  7. Lilybell2's Avatar
    I suggest you try the troubleshooting steps in this Google Support article:

    https://support.google.com/pixelphon.../7167687?hl=en
    06-01-2018 06:55 PM
  8. Golfdriver97's Avatar
    Did the device get really warm?
    06-01-2018 07:26 PM
  9. dlalonde's Avatar
    Did the device get really warm?
    No it didn't. It's really weird because there's no physical symptoms except not turning on of course.

    I suggest you try the troubleshooting steps in this Google Support article:

    https://support.google.com/pixelphon.../7167687?hl=en
    I did already unfortunaly to no avail.
    06-02-2018 09:44 AM
  10. Golfdriver97's Avatar
    No it didn't. It's really weird because there's no physical symptoms except not turning on of course.
    I think the next step is contacting Google. https://support.google.com/pixelphone/answer/7109524 There should be a link to contact Google at least on your PC.
    06-02-2018 10:10 AM
  11. Lilybell2's Avatar
    Contacting Google Support as suggested by Golfdriver97 is a logical next step. If it turns out your phone is out of warranty, then see here for the list of authorized repairers: https://support.google.com/store/answer/7182296?hl=en

    Also, you should be able to get a free diagnostic exam for your Pixel XL phone at uBreakiFix.
    06-02-2018 11:52 AM
  12. dlalonde's Avatar
    That's where I am now. But they're asking for the original purchase ID which I don't have as I bought it from someone who bought it from Google. So I'm waiting for that person to give me the ID but no luck for now.

    What's strange is that with the IMEI they were able to track down the purchase so I don't understand why they're asking for that.
    06-02-2018 02:59 PM
  13. Lilybell2's Avatar
    That's where I am now. But they're asking for the original purchase ID which I don't have as I bought it from someone who bought it from Google. So I'm waiting for that person to give me the ID but no luck for now.

    What's strange is that with the IMEI they were able to track down the purchase so I don't understand why they're asking for that.
    Hopefully, you will be able to get the original purchase ID from the previous owner.
    dlalonde likes this.
    06-02-2018 04:33 PM
  14. dlalonde's Avatar
    Good news! I got an RMA!!

    Thanks for your help everyone!
    06-03-2018 10:21 AM
  15. Lilybell2's Avatar
    Congratulations! That was fortunate.
    dlalonde likes this.
    06-03-2018 03:18 PM
  16. dlalonde's Avatar
    Congratulations! That was fortunate.
    Thanks! Yeah I am really happy!!
    06-03-2018 06:59 PM
  17. Golfdriver97's Avatar
    That's good news!
    dlalonde likes this.
    06-04-2018 02:18 PM
  18. LeoRex's Avatar
    Good news! I got an RMA!!

    Thanks for your help everyone!
    Google's pretty good about that, for units with locked bootloaders, there's not much you can do to be honest.
    06-14-2018 06:55 AM
  19. dlalonde's Avatar
    Google's pretty good about that, for units with locked bootloaders, there's not much you can do to be honest.
    They are. The return was quick, easy and I was very very happy....

    ...but...

    The replacement device I got was also defective (it didn't charge). I went to get a new RMA and they offered me an "advanced" return which I chose. Then I learned that I had to secure the amount for a new device on my credit card so I chaged my mind. The agent started a regular return but I never got my RMA or shipping labels.

    It's been a week now of them saying "We'll get back to you in 24-48 hours" every 24 to 48 and I never get anything. I'm really really irate and running out of patience. This is a ridiculous situation for a company the size of Google. Everytime I go back to speak to them they tell me they'll get back to me in 24 to 48 hours and to just wait. I don't know what to do.
    06-14-2018 06:47 PM

Similar Threads

  1. New, here for help
    By googlealchemist in forum New to the Forums? Introduce Yourself Here!
    Replies: 8
    Last Post: 06-09-2018, 10:20 AM
  2. HTC ONE M7 802D bricked!!.
    By Android Central Question in forum HTC One Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 06-04-2018, 12:17 AM
  3. System update bricked my phone
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 06-02-2018, 06:06 PM
  4. Need Help
    By Akhil Sharma4 in forum Ask a Question
    Replies: 4
    Last Post: 05-31-2018, 08:33 PM
  5. Replies: 2
    Last Post: 05-31-2018, 03:09 PM
LINK TO POST COPIED TO CLIPBOARD