1. rolefourlife's Avatar
    Hello all,

    I just got my Nexus 4 today, have it up and running with Straight Talk (AT&T), still totally stock on 4.2.2.
    Play Store app is on version 3.10.14

    Trying to open up the Play Store but I'm getting this error...
    "Error retrieving information from server. [DF-PFA-02]"

    Any clues on why this might be happening or how I might solve it and get back to the normal Play Store home screen?
    Haven't found anything on the forums or much anywhere else online.

    Other notes:
    I've tried clearing the data, clearing the cache, uninstalling updates, rebooting the phone. Nothing seems to work so far.
    Tried connecting on WiFi and on AT&T data.
    I'm still able to do searches for apps and download them, as well as updating apps by clicking "my apps". If I'm looking at "Installed" and I click <My Apps, it also takes me back to the error message instead of the regular Play Store home.
    Other Google apps seem to work just fine.

    Much thanks guys.
    05-02-2013 12:58 AM
  2. S-Doo-1965's Avatar
    I have the same error on my nexus 7.
    05-02-2013 06:48 AM
  3. mikefly562's Avatar
    I have the same issue on my Galaxy Note 2...just started yesterday night. I've tried data clearing, cache clearing, etc. I am still able to update my apps though and I can still search too. Hopefully it's an issue with Google and not my phone.
    05-02-2013 08:47 AM
  4. rolefourlife's Avatar
    Checked again this morning... still getting the error.
    S-Doo-1965 likes this.
    05-02-2013 09:07 AM
  5. S-Doo-1965's Avatar
    I can click my favorites, search, ect. Looks like only the front page is hosed. The other Nexus 7 in the house rcved the new play store update last night. So I cleared the data and uninstalled the update, rebooted. And then.........still had the error. A small pox on you Google.
    05-02-2013 09:27 AM
  6. kcraiderz's Avatar
    Having the same issue on my galaxy s4 so cleared cache /reset no luck same issue it on 3.0....so I I have a solution for now download new Google play store 4.0.25 apk.file from droid life and it works now make sure in settings /security/unknown sources/ is check.good luck here's the link Download: Latest Google Play Store 4.0.27
    05-02-2013 10:07 AM
  7. lstice's Avatar
    Thank you for the solution!
    I found and downloaded the latest Google Play Store. v4.0.27 and now the Play Store is working again!
    05-02-2013 10:41 AM
  8. int_architect's Avatar
    Having the same problem on my EVO 3D. But only when trying to access Play Music.

    3VO via ACF
    05-02-2013 05:47 PM
  9. S-Doo-1965's Avatar
    I took the nuclear option with a factory rest. Fixed it and got the new play store too.
    05-03-2013 12:32 AM
  10. Steven Comeau's Avatar
    I have same issue on my nexus 7 except I can open all of the play store sections except for the play music section.
    05-03-2013 02:20 PM
  11. rolefourlife's Avatar
    I didn't get around to sideloading the most up to date version of the Play Store, but it must have updated on its own. The error is now gone and I have the normal homescreen of the app now.

    So if you get this problem, maybe just wait a couple days and it will fix itself?
    S-Doo-1965 likes this.
    05-06-2013 02:27 PM

Similar Threads

  1. Error [DF-BPA-13}
    By ponkin3456 in forum New to the Forums? Introduce Yourself Here!
    Replies: 1
    Last Post: 12-14-2012, 11:37 PM
  2. Error Code DF-BPA-09
    By jeffjeter in forum Google Nexus 7 Tablet (2012)
    Replies: 4
    Last Post: 08-29-2012, 09:34 AM
  3. Replies: 35
    Last Post: 11-18-2009, 09:13 PM
  4. error force close
    By JE5TERHEAD in forum Motorola Droid
    Replies: 1
    Last Post: 11-12-2009, 10:41 PM
  5. Call Settings Error
    By kobalt9 in forum General Help and How To
    Replies: 1
    Last Post: 08-09-2009, 06:31 AM