1. bgoman9's Avatar
    I'm getting this error "-24" when downloading a certain app from the Play Store. Specifically Amazon's store app.

    From what I've read, you have to root the phone, download a ROM manager and then delete the data/data file with the com.amazon name. I'm looking for a way to do this without rooting. I'm not very technically inclined and have no idea how to read code or what exactly rooting a phone does.

    I've also heard that you can solve this issue by doing a factory reset, but I don't want to have to re-customize my phone (I'm using Nova Launcher and a bunch of other apps). Any other solutions to this problem??

    BTW I have a Galaxy S4 and have tried finding the data/data folder in the My Files application but can't seem to locate it. I've found just about everything else though. Could anyone walk me through this?
    02-24-2014 10:16 AM
  2. mahiyakanamansana's Avatar
    I just thought about this awhile ago and this solution worked out for me. You should try it yourself.

    I'm using Samsung Galaxy S4

    Go to Application Manager>All>Contacts Storage. Press clear data.

    Hope it works for you.
    04-13-2014 05:42 AM

Similar Threads

  1. Replies: 25
    Last Post: 08-03-2014, 08:30 AM
  2. Rooting Nexus 4 4.4.2 without wiping data?
    By nscombatant in forum Nexus 4 Rooting, ROMs, & Hacks
    Replies: 4
    Last Post: 04-19-2014, 12:55 PM
  3. Replies: 14
    Last Post: 03-07-2014, 03:08 PM
  4. Just got a Virgin Mobile HTC EVO 4G and its already been rooted....
    By Jcarlton74 in forum HTC V 4G Rooting, Rom's, and Hacks
    Replies: 3
    Last Post: 02-26-2014, 01:16 AM
  5. [ROOT] (Unofficial) Defy XT555C
    By Nick_73 in forum Motorola Defy
    Replies: 0
    Last Post: 02-23-2014, 06:41 PM