1. tgp's Avatar
    OK, here is my setup: I have a Nexus 6 on Verizon. I used Google Voice for my voicemail (I disabled my Verizon voicemail), and I also use Hangouts for SMS. Along with that, I would get messages and calls that came in on Google Voice. Let's say the Google account is 12345@gmail.com, and the GV number is 123-456-7890.

    I used that Google account to request Project Fi, and I received the invition not long after they started rolling out. I bought another Nexus 6 (used) to use on Project Fi, and I ordered the SIM only kit. After I received it, I turned my Google Voice account into Project Fi, transferring the number. So now, my 12345@gmail.com account is Project Fi, and my Fi number is 123-4560-7890. That part works fine.

    I'm running into issues on my Verizon phone. First of all, transferring my GV account to Fi killed the voicemail for my Verizon line. What I ended up doing was to forward my Verizon number to my Fi number if it's busy or no answer. That works perfectly. It forwards after a few rings, and it goes right to voicemail. To the caller it is completely normal.

    A bigger issue is that I cannot call my Fi number from my Verizon phone. It goes directly to voicemail. I place a call to 123-456-7890 from my Verizon phone, and the first thing I hear is "You have no new messages...". This means that I cannot call my Fi phone from my Verizon phone. I have the Project Fi app installed on my Verizon phone. I tried removing it, but it didn't make any difference. It still calls voicemail. I also tried canceling the call forwarding, but that didn't do anything either.

    At this point, my Verizon line should not be connected to Google voicemail in any way. The calls I don't answer go to Google voicemail, but it is via call forwarding. Is this happening because of Hangouts? I can receive Project Fi calls on my Verizon phone via Hangouts, but for regular calling I use the built in phone dialer, not the Hangouts dialer. When I call the Fi number, I also use the built in phone dialer, not the Hangouts dialer.

    Is the phone somehow automatically calling from my Fi number when I call the Fi number? I called my wife's phone to make sure all calls do not come from Fi, and they don't. Her Caller ID shows my Verizon number.

    Any ideas? I suspect I would need to remove or at least disable my Fi account on Hangouts on my Verizon phone, but I do not want to do that.
    06-12-2015 10:28 PM
  2. dusoccer10's Avatar
    OK, here is my setup: I have a Nexus 6 on Verizon. I used Google Voice for my voicemail (I disabled my Verizon voicemail), and I also use Hangouts for SMS. Along with that, I would get messages and calls that came in on Google Voice. Let's say the Google account is 12345@gmail.com, and the GV number is 123-456-7890.

    I used that Google account to request Project Fi, and I received the invition not long after they started rolling out. I bought another Nexus 6 (used) to use on Project Fi, and I ordered the SIM only kit. After I received it, I turned my Google Voice account into Project Fi, transferring the number. So now, my 12345@gmail.com account is Project Fi, and my Fi number is 123-4560-7890. That part works fine.

    I'm running into issues on my Verizon phone. First of all, transferring my GV account to Fi killed the voicemail for my Verizon line. What I ended up doing was to forward my Verizon number to my Fi number if it's busy or no answer. That works perfectly. It forwards after a few rings, and it goes right to voicemail. To the caller it is completely normal.

    A bigger issue is that I cannot call my Fi number from my Verizon phone. It goes directly to voicemail. I place a call to 123-456-7890 from my Verizon phone, and the first thing I hear is "You have no new messages...". This means that I cannot call my Fi phone from my Verizon phone. I have the Project Fi app installed on my Verizon phone. I tried removing it, but it didn't make any difference. It still calls voicemail. I also tried canceling the call forwarding, but that didn't do anything either.

    At this point, my Verizon line should not be connected to Google voicemail in any way. The calls I don't answer go to Google voicemail, but it is via call forwarding. Is this happening because of Hangouts? I can receive Project Fi calls on my Verizon phone via Hangouts, but for regular calling I use the built in phone dialer, not the Hangouts dialer. When I call the Fi number, I also use the built in phone dialer, not the Hangouts dialer.

    Is the phone somehow automatically calling from my Fi number when I call the Fi number? I called my wife's phone to make sure all calls do not come from Fi, and they don't. Her Caller ID shows my Verizon number.

    Any ideas? I suspect I would need to remove or at least disable my Fi account on Hangouts on my Verizon phone, but I do not want to do that.
    I've got a couple of theories:

    1) try removing the hangouts dialer from your Verizon Nexus 6. Does this help?

    2) if you have the Google Voice app installed on your Verizon Nexus 6, how is it set up? Did you have your outgoing phone calls routed through Google Voice? If so, uncheck this setting. You can also try removing the app altogether.

    Posted via Android Central App
    06-14-2015 04:47 PM
  3. tgp's Avatar
    I've got a couple of theories:

    1) try removing the hangouts dialer from your Verizon Nexus 6. Does this help?

    2) if you have the Google Voice app installed on your Verizon Nexus 6, how is it set up? Did you have your outgoing phone calls routed through Google Voice? If so, uncheck this setting. You can also try removing the app altogether.
    Thanks, great ideas! Unfortunately, neither helped. I removed the Hangouts dialer, and I also uninstalled the Google Voice app. The Project Fi app is not installed either. Calling my Fi number still calls my voicemail. I have no clue how my phone is connected to my GV voicemail anymore.

    My next step is to remove Hangouts completely. I might wait a bit to see if the problem sorts itself out. I'm probably missing a setting somewhere...
    06-14-2015 10:51 PM
  4. dusoccer10's Avatar
    Thanks, great ideas! Unfortunately, neither helped. I removed the Hangouts dialer, and I also uninstalled the Google Voice app. The Project Fi app is not installed either. Calling my Fi number still calls my voicemail. I have no clue how my phone is connected to my GV voicemail anymore.

    My next step is to remove Hangouts completely. I might wait a bit to see if the problem sorts itself out. I'm probably missing a setting somewhere...
    Have you tried the settings on the desktop? You can modify the forwarding there. My guess is that will solve your problems:

    https://support.google.com/voice/answer/165221?hl=en
    06-15-2015 10:04 AM
  5. tgp's Avatar
    Have you tried the settings on the desktop? You can modify the forwarding there. My guess is that will solve your problems:

    https://support.google.com/voice/answer/165221?hl=en
    That fixed it! In my Project Fi (what was Google Voice) forwarding settings it was set to forward to my Verizon number. I have no clue why, but I removed the forward setting and it works!

    After playing around with it a bit, I discovered that it was the Google Voice app that was adding the forwarding. It seems to do it automatically for some reason. I reinstalled the Hangouts Dialer and Project Fi apps, and it still works. Add the Google Voice app, and the issue returns.

    My deepest gratitude to you, dusoccer10!
    dusoccer10 likes this.
    06-15-2015 04:52 PM
  6. AlexMadarasz's Avatar
    Have you tried the settings on the desktop? You can modify the forwarding there. My guess is that will solve your problems:

    https://support.google.com/voice/answer/165221?hl=en
    I'm having [what seems to be] a related issue - when I call my new Fi Nexus 6 from my home landline and my old Moto X 2014 phone (that used to be my primary Google Voice cell phone) my Nexus 6 doesn't ring.

    Unfortunately, now I can't get to GV on my desktop at all to see if some of the [forwarding] settings there might be screwing things up - every time I try to get to GV on the desktop it forwards me to the Fi account site (and there are no numbers in the Fi Forwarding settings).

    When I had GV on my Moto X 2014, I had it set up with a T-Mobile # as the primary #, and a second GV # that I had set to ring to the T-Mobile #. I would give out the GV # to folks that I didn't want to have my direct line (the T-Mobile #).

    When I started Fi, I had Fi give me a new Fi # and delete (return/replace) the old GV #. So, when I re-install GV on my old Moto X 2014 it "knows" that the T-Mobile # is no longer associated with the old GV # ... so I can't get to GV on the old Moto X 2014 either ....

    EDIT: Hmmm, my issues with incoming calls to my Fi Nexus 6 appear to be gone - maybe my [recent/new] inability to access GV on my desktop means that Google was updating / migrating my GV account this weekend?

    --
    Alex
    06-29-2015 08:34 AM

Similar Threads

  1. G4 with Metro PCS...
    By GrooveRite in forum LG G4
    Replies: 13
    Last Post: 11-18-2015, 01:19 PM
  2. Can someone help me with my sd card?
    By Kae-Kae Blacc in forum General Help and How To
    Replies: 8
    Last Post: 06-15-2015, 04:34 PM
  3. Get phone to beep when connected to charger
    By tony bag o donuts in forum Motorola Droid Turbo
    Replies: 3
    Last Post: 06-14-2015, 05:49 AM
  4. Why isn't my front camera working?
    By Clymber in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 06-13-2015, 01:18 AM
  5. Replies: 1
    Last Post: 06-12-2015, 10:55 PM
LINK TO POST COPIED TO CLIPBOARD