1. Alex Dobie's Avatar
    NOTE: THIS IS FOR THE GSM VERSION ONLY. DO NOT ATTEMPT THIS ON THE VERIZON VERSION.

    PROCEED AT YOUR OWN RISK. DRAGONS AHEAD ETC.


    This is pretty easy to do if you're familiar with fastboot, etc., but you'll need an unlocked bootloader before you can do this.

    First, grab the factory images and extract them into whichever directory you have fastboot.

    Get the images here: Factory Images for Nexus Devices - Google Support for Nexus Phones and Flagship Devices - Google Code

    Then you'll want to reboot into fastboot mode (shut down, then hold vol. up + vol. dn + power), open up an (administrator) command prompt in your fastboot directory and run the following:

    (if your fastboot exe is called fastboot-windows, use that in the commands below instead)

    ONCE AGAIN, THIS IS FOR THE UNLOCKED INTERNATIONAL VERSION ONLY, NOT THE VERZION LTE MODEL.

    fastboot flash bootloader bootloader-maguro-primekk15.img
    fastboot reboot-bootloader

    (wait for bootloader to reboot)
    fastboot flash radio radio-maguro-i9250xxkk6.img
    fastboot reboot-bootloader

    (wait for bootloader to reboot)
    fastboot update image-yakju-icl53f.zip

    After this completes, you phone should reboot with 4.0.2.

    The difference here is that we didn't tell fastboot to wipe the user data and cache in the final step, so all your stuff will be there once the phone reboots.
    12-16-2011 02:34 PM
  2. ibejack96's Avatar
    does anybody know how to do this on a mac? i tried using ./fastboot-mac, but its not working
    12-16-2011 09:22 PM
  3. xinn3r's Avatar
    Alex, can you give us a URL link to the patch update instead like 4.0.1?
    And another question, why I can't seem to install the update for the bug fix, it says "assert failed: file_getprop("system/build.prop". bla bla bla
    (status 7)
    Installation aborted

    Any idea why this is?
    12-16-2011 10:43 PM
  4. chevyman29's Avatar
    mine got the update pushed to it a little while ago . what does this update fix ??
    12-16-2011 11:41 PM
  5. joe767's Avatar
    Help Please....I downloaded the image and I have the ITL41F. After extracting the files into my fastboot folder I opened the command line and here is where I'm having the issue. The instruction above show fastboot flash bootloader bootloader-maguro-primekk15.img, but the file I downloaded shows a bootloader-maguro-primekj10.img. Anyway I exe the bootloader-magura-primekj10.img and all I get is waiting for device. Before you ask my bootloader is unlocked, took me all night to do that. Please help, what I'm I doing wrong.
    12-19-2011 12:54 PM
  6. joe767's Avatar
    Followed the steps on "How to manually update GSM Nexuse to 4.0.2).
    I was trying to update to 4.0.2 and followed the steps as laid out. The only thing I change was the file names because after downloading the image for my build (itl41F) shows image-yakju-itl41f and bootload-maguro-primekj10. After everything was completed the phone rebooted to the boot animation and I waited over 15 minutes but it doesn't boot, just showing the nexus boot animation and that's it. I took the battery out and tried to reboot without any success. Could you please help me, the phone's bootloader was unlock prior. Thanks.
    12-19-2011 03:04 PM
  7. joe767's Avatar
    Any Help Please
    12-19-2011 04:20 PM
  8. joe767's Avatar
    I guess I was using the wrong image, but now I flash with the icl53f image and still not getting the phone to boot up. Just the animation and thats it. Any help out there....
    12-19-2011 06:35 PM
  9. sunnybeef's Avatar
    Do a
    ./fastboot -w
    will help
    12-20-2011 02:32 PM
  10. anon(52425)'s Avatar
    I tried the *#*#checkin#*#* and it didnt seem to do anything.
    12-20-2011 03:39 PM
  11. -zero-'s Avatar
    Hi,

    I applied the update and now my phone is in constant boot animation

    a quick google search and I found that the update is only for yakju build and not any other version
    do you think this is what's causing it?

    and more importantly, what can I do to fix it?

    thanks
    01-02-2012 09:19 AM
  12. pli23swim's Avatar
    hey joe... i think im in the same situation as you, in hong kong, bought gsm nexus, unlocked bootloader, rooted, have clockworkmod, and tried to manually update it to 4.0.2. but ended up with the boot animation going on forever! how did you resolve this problem?
    01-04-2012 09:02 AM
  13. flowage's Avatar
    I have the same issue. But I fixed, it boot up and with 4.02 on my phone.

    you can download Samsung Galaxy Nexus Toolkit V2.2 from xdadevelopers

    0) connect your usb cable to the phone.
    1) boot your phone in bootloader (vol up , vol down, and power hold all at the same time)
    2) run runme.bat in the toolkit
    3) select 6. boot to CWM recovery without permanently flashing it.
    4) select wipe user data and rest factory setting.
    5) after it done phone will reboot and pass the boot animation

    or
    Re-flash your phone again with this command. It will wipe all the user data and reset your phone when update to 4.02.
    "
    fastboot -w update image-yakju-icl53f.zip
    "
    I hope this can help anyone have the trouble.
    khaliji likes this.
    01-04-2012 04:04 PM
  14. dsquiller's Avatar
    I bought my GN (GSM) in Taiwan and it is running 4.0.1 yakjuzs. Now that I'm back in the U.S. I want to be able to update to 4.0.2 and subsequent releases. Ideally, I'd like OTA updates, but if I have to manually update, that's OK. Do I need to be running yakju to update and should I convert over to yakju? How do I update and where do I get the image? Better to go with F/W from Samsung or Google? Sorry for all the questions, but I'm new to Android.Thanks
    01-12-2012 06:29 PM
  15. khaliji's Avatar
    thanks man u saved my phone
    01-13-2012 08:22 AM
  16. khaliji's Avatar
    Piece of advice don't try this it doesn't work
    01-13-2012 08:25 AM
  17. alidomino's Avatar
    I've downloaded this from google : yakju-icl53f-factory-89fccaac.tar...do i need to untar it and then rename it to a .zip to use it?
    01-24-2012 06:03 PM
  18. Dante Aguilar's Avatar
    Hey! I am Dante, a Filipino working in Saudi Arabia. I purchased GSM Samsung Galaxy Nexus GT-i9250 with Android Version 4.0.1. Later I found out that it cannot be updated by Google because it is "yakjuxe" version. Can I update my phone to version 4.0.2 using the procedures you mentioned or is this for "yakju only? Is there any procedure to update it? Please help and thanks.
    04-07-2012 08:01 AM
  19. loumar's Avatar
    Hi Alex,
    Will this process work upgrading from 4.0.4 to 4.1.2

    Louis
    12-09-2012 11:33 AM
LINK TO POST COPIED TO CLIPBOARD