1. Mickey Valentine's Avatar
    Hello First post on here.
    I clicked the ask a question and made an account but couldn't find the button again. Not sure if This is the right way to ask questions.

    I have a stock Galaxy Nexus running 4.0.4 ICS. Never been rooted. Probably factory reset 12 times. I'm using it right now.

    My problem as the title states, my wifi won't turn on. Its at a half Way point between on And off. I have photos of my issue but cant seem to upload them at the moment through the browser on my phone.

    I bought the phone near the end of March, the problem revealed itself during end July, occurred 3 times then a factory reset rid me of said issue, I had never dropped my phone. Had never. I dropped it mid August, problem returned and never left. After a factory reset it would go away and return when an app required wifi or a setting on the phone was wifi only. Each time Wifi would attempt to engage and fail with no alert. I've given up factory resets and given up looking for forums asking the same question so might as well ask. I barely found out today that Jelly Bean has been out since Sept 21 but download wifi only so would be nice to get it.

    My conclusion, maybe the wifi radio is jus obliterated and I need a new phone.

    Any help? Thoughts?

    10-11-2012 02:03 AM
  2. Insp_Gadget's Avatar
    Since you said Jellybean has only been out since September, I'm going to assume you have the Verizon version of the Galaxy Nexus, because the GSM version has had it since July.

    Have you tried taking it to a Verizon store to demonstrate the problem to them? Sounds like a defective unit, assuming you've configured it correctly.
    10-11-2012 06:33 AM
  3. Mickey Valentine's Avatar
    Ah yes forgot about that, I'm unfortunately on Verizon. Yes I have gone to them to demonstrate this problem, they say they're unable to Help since they've never heard of the issue before.

    Now since there's some slight paint missing, I'm at a stalemate.

    When I factory reset it the second time I didn't add any apps for a week and the problem returned before then. Most likely is defective I guess. Not sure if there's a WiFi radio in there. But maybe that could be broken? The only two reasons I Can think of is, as you stated, defective; and second, extreme heat conditions. I have no AC and my home can get extremely hot, add that to the fact the phone starts burning my hands.

    Honestly I haven't a clue.

    Pictures are in my Google Drive.
    10-12-2012 01:06 PM
  4. Insp_Gadget's Avatar
    Can't see the pictures in the links you provided because you haven't made them public. No one else has permission to see them.

    So let me get this straight. When you factory reset the phone, WiFi works for a while and then just spontaneously stops working (even on a network you had working prior)?

    The problem is reproducible at a Verizon store, but they can't help you? Why? Did you buy it from a third party? No warranty?

    The phone getting excessively hot is a cause for concern, but I have to assume that since the problem also occurs at a Verizon store (where they presumably have air conditioning) that environment alone is probably not the issue.

    You've tried running stock with no apps installed and it works for a while, but stops on its own, prior to installing any apps?

    Again, unless you've misconfigured your WiFi settings I can't think of any reason for this. The fact that it works at all is the puzzling part. Usually, when a tech component fails it fails 100%. I suppose temperature could be a factor--if heat is causing expansion that is severing a physical component connection in the phone when it gets hot.

    If you got a "too good to be true" deal on this phone from a third party, this might be the reason.
    10-12-2012 02:01 PM
  5. Mickey Valentine's Avatar
    I have made them public now.

    Yes that is correct. It works then stops. The setting idles between on & off with the words "Turning WiFi on..." On any network including my own.

    -Yes the problem is reproducible because it never goes away. The Verizon techs are baffled at the fact its stuck and they've never come across it before. They don't know how to fix it except give me a new one.
    -Now, I do not have insurance for it. My Motorola Droid worked fine and I never had a problem so whats the point of insurance I thought. Only warranty is the Manufacturers, but since some paint is missing it's considered physical damage which isnt covered so I can't get help even if I explain that it has been happening since before the paint was chipped.
    -As for a third party purchase. I bought it from Best Buy.

    My Droid had gotten hot but this was ridiculously hot, I just assumed it was the 4G Radio inside. Or the Wifi Radio/Antenna, since I used that constantly. But I concur on the environment not being the lone issue, as I had the same conclusion.

    Yes I ran stock for a week without any apps, on the 3rd day the problem returned. I still didn't add apps for the remaining 4 days and the problem never went away.

    The only WiFi setting I've changed is: Wifi on&off and finding my Network. I haven't changed any other settings at all. Just one day I turned on my WiFi after getting home and it never fully turned on.
    I was puzzled at that fact aswell. It has a mind of its own really. But temperature wise I think is the more probable reason. I've dealt with Notebook components getting excessively hot and having to solder connections back together. Can't do that with my Phone though.

    Nope, Best Buy just had it for $50 cheaper than Verizon at the time.
    10-14-2012 04:56 PM
  6. Insp_Gadget's Avatar
    Well, if the guys at Best Buy can't/won't help, and no one at a Verizon store (corporate store?) can help, have you contacted Samsung?

    Since the problem is happening with the stock software, perhaps this would be covered under the manufacturer's warranty.
    10-15-2012 03:07 PM
  7. capt.ron's Avatar
    Not sure if this would help but my thought is to re-flash the radio zip file for ICS??? I'm not an expert.
    10-16-2012 01:34 PM
  8. Mickey Valentine's Avatar
    Hm, no I have not. It never crossed my mind to do so. >_< I'll contact Samsung to see what they can do and I guess post my results. If all else fails, I'll just have to buy a new phone. Hopefully they won't give me flak on anything. (I've had bad experiences with manufacturers)

    As for reflashing the Radio zip file, I suppose it could work if the hardware component hasn't failed completely. Though I am inexperienced with any "flashing" concerning Android. Kinda a noob you could say.

    Though, thank you both, for trying to help. Appreciate it. ^_^

    On a side note, I now have Android 4.1.1 but the wifi problem wasn't fixed in case the question crossed your mind.
    10-19-2012 03:07 AM

Similar Threads

  1. Relocked and reflashed my Vivid, now wifi doesnt work?
    By frablacal10 in forum HTC Vivid
    Replies: 2
    Last Post: 07-05-2012, 10:39 PM
  2. Wifi Doesnt Work after Root
    By peopleschamp81 in forum T-Mobile Galaxy S 4G
    Replies: 3
    Last Post: 01-13-2012, 02:34 AM
  3. Does wifi tether work for the bionic yet?
    By crspy in forum Droid Bionic
    Replies: 6
    Last Post: 10-17-2011, 12:37 PM
  4. HBO GO App Doesnt Work for Time Warner Providers.
    By Crackiswack_Bold_is_cool in forum Android Apps
    Replies: 4
    Last Post: 05-03-2011, 10:34 AM
  5. Wifi doesnt work!! Help!
    By austin.n in forum HTC EVO 4G
    Replies: 1
    Last Post: 06-06-2010, 11:15 PM