1. prim8's Avatar
    Anyone else having this issue?
    Since I upgraded to 4.2, both of my Galaxy Nexus phones can't turn bluetooth on.
    11-15-2012 05:38 PM
  2. rootdisk's Avatar
    I had this problem once prior to 4.2. No matter what I did, I couldn't turn bluetooth on. After I powered off the phone and turned it back on. Then I could turn bluetooth off and on with no problem. Hasn't happened since. So you may try powering off the phone and/or pulling the battery and see if that fixes it.
    11-15-2012 10:32 PM
  3. KlineAJ's Avatar
    Try a factory reset if that does not work.
    Hopefully someone else may post your solution either here or there.
    11-16-2012 12:19 AM
  4. TrackerF16's Avatar
    also, try location services under GPS settings, turn it off and then back on (the one asking you about using wifi to localize you faster) the bluetooth and wifi are both 802.11 standards, therefore they are controlled by the same chip (this has worked for me 2x now)
    11-16-2012 01:22 AM
  5. usamaahmad's Avatar
    Anyone else having this issue?
    Since I upgraded to 4.2, both of my Galaxy Nexus phones can't turn bluetooth on.
    I was having this issue, as were a few users on xda. There is one confirmed solution, and one that may work (only one person has had luck with it in the forums). I used the first solution.

    The first solution has you using fastboot, so your bootloader would need to be unlocked. Essentially you flash a new radio, bootloader, image .. basically everything except "userdata.img" so that you can keep all your apps/settings/personalizations. And it worked for me. --- I was rooted (but with stock recovery), and I lost root. You do NOT need root to use this solution, I simply want to highlight that you would lose root if you did have it. What you do need is an unlocked bootloader, and if your bootloader is locked currently, then unlocking will cause the phone to lose all data (thus backup!, actually backup regardless!).

    The second solution is if you're running CWM in recovery, you use the CWM-based update, and just reflash it (only one person in the forum tried this and it worked for him).

    Link to forum: Galaxy Nexus 4.2 Bluetooth - xda-developers
    11-16-2012 07:45 AM
  6. prim8's Avatar
    Thanks for all the replies. I had actually tried rebooting and pulling the battery and airplane mode. I also did a factory reset.
    I tried flashing the radio but I hadn't tried the other solutions yet.
    I actually have two phones, it happened on both. I just completely reflashed my phone with the nexus toolkit and the image from google which fixed it.
    My wife likely wouldn't take kindly to losing all her stuff so I'm trying to find a less invasive solution.
    11-16-2012 09:38 AM
  7. runswithjews's Avatar
    I updated my nexus 7 and it won't turn on either and I couldnt find anybody with the exact same problem until now
    11-16-2012 02:16 PM
  8. Quest Granter's Avatar
    I have same problem. I have 4 GNEX and I had to install stock image in two to get bluetooth to turn on. I am not upgrading other two until I see a fix.
    11-17-2012 05:25 PM
  9. Lyonia's Avatar
    Just to confirm that with CWM reflash now BT is working

    After OTA update CWM was re installed, using Galaxy Nexus Toolkit, then OTA image burned again with CWM

    11-27-2012 01:59 AM
  10. mattg68's Avatar
    Same problem, even after the 4.2.1 update which came today ...

    Galaxy Nexus GSM, 4.2.1
    11-29-2012 04:21 PM
  11. Tacty's Avatar
    after "updating" to 4.2.1 bt acting strangely. it works sometimes, but today refuse to even turn on! nothing helps, it wont turn on no matter what. is it so hard for company like google to provide at least working bluetooth on its phones? this one is major pain, but bt wasnt working properly since i have the phone...i dont want to turn myself into anonymous hacker in order to have working such trivial thing like bt on my phone...i'm more and more into thinking how android is really god forbiden operating system...
    12-02-2012 07:31 AM
  12. PowerZhang's Avatar
    I also meet this problem, are you solved?
    04-18-2013 03:55 AM
  13. kf6kmx's Avatar
    Mine did this after the 4.2 update..

    Solved mine by installing CM 10.2...

    Someone sent me this ink tho saying its a permission issue, and you can try this if you have root

    Solved Bluetooth issue of 4.2.1 OTA | Galaxy Nexus > XDA
    04-18-2013 07:06 AM
  14. Jonathan Hilairet's Avatar
    I called google technical support and they found an easy solution for me.

    In your Nexus 4, go to : parameters/applications/all/Bluetooth
    Empty cache, earase data and remove upgrades.
    Restart your phone
    Tada !
    10-10-2013 11:11 AM
  15. m w4's Avatar
    I had this problem on 4.01 on an Ascend y300 and it was also solved by turning on location servaces.
    12-14-2013 01:30 PM
  16. Brian Sponaugle's Avatar
    This worked for me (Turning off and Location info) . Factory reset also worked for a while but that has its own problems.
    Thanks for the tip.
    01-10-2014 12:23 PM

Similar Threads

  1. Can't turn on 4G after accidentally turning it off
    By hal1 in forum Verizon Galaxy Nexus
    Replies: 4
    Last Post: 12-16-2011, 12:35 AM
  2. can't turn on nfc, stays gray
    By funkmeisterbrau#AC in forum Sprint Nexus S 4G
    Replies: 10
    Last Post: 10-07-2011, 09:18 AM
  3. Can you turn on phone with out power button?
    By nmangiafesto86 in forum Motorola Droid 3
    Replies: 4
    Last Post: 08-13-2011, 06:39 PM
  4. EVO OTA Update: Can I turn on my phone?
    By Saturn2K in forum HTC EVO 4G
    Replies: 3
    Last Post: 06-04-2010, 11:22 PM
  5. EVO OTA Update: Can I turn on my phone?
    By Saturn2K in forum Software Development and Hacking
    Replies: 2
    Last Post: 06-04-2010, 11:11 PM