1. BartmanJax's Avatar
    I've been trying to get the 4.3 OTA since it appeared in the ASOP. I was finally able to "force" the OTA by following these simple instructions:

    1. Go to Settings > Apps > All Apps

    2. Find the Google Services Framework

    3. Force Stop the app and then clear the data.

    4. Go to Settings > About Tablet > System Update

    5. The date should now show 12/31/1969 or something like that from 1969.

    6. Check for the update.

    I had to do this step 6 times, but it finally worked.

    Good Luck!
    Caballera likes this.
    07-26-2013 07:13 PM
  2. tim8900's Avatar
    Worked for me on the fifth try. Thanks.
    BartmanJax likes this.
    07-26-2013 08:11 PM
  3. BartmanJax's Avatar
    Just a quick FYI....after the update, I could not update or install any apps from the Google Play Store. After an hour or so of frustration and searching the web for a solution, I contacted Google and spoke to "Audrey" and got this solution.

    Delete your Google account: Settings > Under Accounts, select Google > Select your account > three vertical dots at the top right > Remove account (if you have multiple accounts, delete them all).

    Go to Settings > Apps > All Apps > Google Play Store
    Clear the data and cache

    Re-add your Google account and downloads from the Play Store should now work.
    07-26-2013 08:21 PM
  4. 7seven's Avatar
    Or you can simply uninstall Google Play updates. After that, updates will automatically reinstall and when you open Google Play next time you have to agree with Terms and Conditions again. Then allow it 1-2 hours and your device will be available online again.

    Posted via Android Central App
    07-27-2013 10:34 AM
  5. monwentworth's Avatar
    Didn't work for me. Tried it 10 times. The date showed 1970 though...
    07-27-2013 01:04 PM
  6. 7seven's Avatar
    I think it really depends on your location. They are releasing the update progressively and geographic location sure is a criteria.

    Posted via Android Central App
    07-27-2013 05:39 PM
  7. 7seven's Avatar
    Anyone received the update yet?

    Posted via Android Central App
    07-28-2013 02:55 AM
  8. monwentworth's Avatar
    I'm in Spain and no update for the moment.
    07-28-2013 08:07 AM
  9. Ricanxd's Avatar
    Forced it also, came in on third attempt.

    Sent from my Galaxy Nexus using AC Forums mobile app
    07-29-2013 12:34 AM
  10. EdiS91's Avatar
    I am from albania. I have not get the update version yet. I try the first way but the update was in 1970 not in 1969. Can anybody help me?

    Posted via Android Central App
    07-29-2013 09:58 AM
  11. monwentworth's Avatar
    Tried again the trick, and this time it worked the first time. Downloading 4.3 right now.
    07-29-2013 06:40 PM
  12. agp101's Avatar
    For errors after updating: http://appslova.com/android-fix-rpcs...le-play-store/

    Posted via Android Central App
    07-29-2013 11:20 PM
  13. Caballera's Avatar
    Tried this on my Galaxy Nexus and it worked, took 3 tries and now it's downloading. Thanks!

    Note I'm in NYC. Bought my GN about 3 weeks after it was released on the GPS.
    07-30-2013 11:59 AM
  14. mightymikek83's Avatar
    Wow, I didn't think this was going to work at all. It worked for me first try!

    Also I just did it on my Nexus 7 (2012)!

    Thanks man!
    07-30-2013 04:21 PM
  15. DaveGoose's Avatar
    Didn't work for me, I am in Canada. I would have thought it would be here by now.
    07-31-2013 10:34 AM
  16. tgp's Avatar
    My wife uses a GSM Galaxy Nexus, and her update came through yesterday. She didn't do anything, not even check for updates. We live near Philadelphia, PA. I, however, am still waiting for the update on my Nexus 4.
    07-31-2013 11:20 AM
  17. pontiac005's Avatar
    My wife's Gnex update came through a couple days ago here in Northern California.

    Sent from my Nexus 4 running Android 4.3 using Tapatalk 4
    07-31-2013 11:34 AM
  18. loofmodnar's Avatar
    Tried it a couple times on Monday without any luck but when I gave it a shot today it worked the first time.
    07-31-2013 02:37 PM
  19. run1fast's Avatar
    I have a Gnex (Google IO 2012) in Colorado. Just got the push a few minutes ago. Didnt have to do anything special. I got tired of hitting update last week.
    07-31-2013 02:42 PM

Similar Threads

  1. Flashing 4.2.2 ROM on Virgin mobile Galaxy S2 Epic 4G Touch GB28
    By TanRRiV in forum Epic 4G Touch Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 01-23-2014, 01:42 AM
  2. My call volume drops when the phone is in the Samsung dock
    By Steve Marshall1 in forum Verizon Samsung Galaxy S4
    Replies: 2
    Last Post: 09-27-2013, 11:03 AM
  3. Very Disappointed in the Durability of my S4 Screen
    By 804hokie in forum Verizon Samsung Galaxy S4
    Replies: 19
    Last Post: 08-09-2013, 03:17 PM
  4. Replies: 13
    Last Post: 07-28-2013, 11:43 PM
  5. Please help! Google play store error on nexus 10!
    By neonworm in forum Google Nexus 10 Tablet
    Replies: 5
    Last Post: 07-26-2013, 08:47 PM