1. esquishems's Avatar

    I had a Galaxy Nexus running Android 4.2.1 and it broke. My insurance replaced it, so I have a new Galaxy Nexus running Android 4.0.2. The new phone doesn't show that any system updates are available. (Well, I think it updated from 4.0.0 to 4.0.2 as soon as I turned it on, but nothing since then.) How do I update it to 4.2?

    Sorry if I'm not giving enough information; I'm new and I'm not sure what's relevant.

    Thanks in advance!
    01-12-2014 02:57 PM
  2. louisstone's Avatar
    When I reloaded my GNex, I left wifi on overnight and it downloaded updates at its leisure. Then it prompted me the next time I fired it up.

    Maybe my unhelpful response will prompt someone with chops to see it and help you out.

    Somebody, somewhere, right now is stuffing Twinkies in their shorts.
    01-12-2014 05:38 PM
  3. esquishems's Avatar
    -I am in Canada and my provider is Mobilicity.
    -I have tried going to About Phone -> System Updates and nothing shows up. When I first got the phone, it updated from like 4.0.0 or 4.0.1 to 4.0.2, but that's all that has showed up. I also tried clearing the cache and force stopping Google Services Framework, as suggested in another thread.
    -I don't really know what it means to install the update manually; I guess I'm willing to, but I feel that something must be wrong because this is the exact same phone (as far as I can tell) I've had for the last year with the exact same provider. When I got this phone one year ago, it ran Jelly Bean automatically, so I don't get why this one wouldn't do the same automatically.

    -Sometimes when I click System Updates, after it says there no updates available and shows "Last checked for updates" as the current time, it starts downloading a 41.2 MB "Android System Update". After it downloads, it restarts and gets that picture of the robot having surgery, but it's still running 4.0.2.
    01-14-2014 08:03 AM
  4. esquishems's Avatar
    I noticed another thing: when it downloads the "Android System Update" and restarts, the picture of the robot starts off as a green guy standing up with a blue thing spinning in his chest, but then it changes to the green guy laying down with a red caution triangle over his chest. Does that tell me anything?
    01-14-2014 09:13 AM

Similar Threads

  1. Samsung Galaxy S3 , Android 4.3 , Gallery issue
    By S3Android43 in forum General Help and How To
    Replies: 11
    Last Post: 07-04-2016, 04:00 PM
  2. Samsung Galaxy S4 rebooting error HELP!!
    By android321nerd in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 10-14-2015, 10:14 PM
  3. Replies: 2
    Last Post: 03-09-2014, 06:18 PM
  4. Data needed from water damaged HTC Desire
    By clc34 in forum General Help and How To
    Replies: 2
    Last Post: 01-13-2014, 07:55 AM
  5. Replies: 0
    Last Post: 01-12-2014, 01:48 PM