1. Nezzaros's Avatar
    Hi guys,

    I'm trying to sync folders between two of my devices (NV Shield K1 and Moto X Play, both running Marshmallow, both rooted). Mostly my goal was to sync savegames between both devices, so I figured the easiest way to go would probably just be syncing the respective app folder in /data/data between devices. I tried doing this by hand via ES Explorer and Google Drive and it worked just fine.
    Now, doing this is a hassle, esp. with several games, so I download and tried several syncing apps, eventually ending up with Folder Sync and Ultimate Sync emerging as the best options. Unfortunately, I then ran into a problem I failed to solve over the course of the last three days - frankly, I even failed to fully figure out what the problem is.

    What I can say is that only one side of the syncing operations seems to be succeeding, that is the uploading part. Ultimate Sync tells me it's downloading and copying files, but it it is not, as the folders in my local data/data don't get modified. Folder sync was kind enough to give me a log spelling out something bout failing to get path on a null reference(). Long story short, what seems to be working is reading from the root folder to Google Drive, but not writing from Google Drive to the root folder. This is true for both devices and both apps. This is not the fully story though, because the most curious thing is that my primarmy test game, Kingdrom Rush, gets corrupted after an (unsuccessful) syncing event - which makes no sense to me.

    Since I was really at a loss, I got SuperSu Pro for access the logging files which seem to confirm (I'm not really fluent in any of those unix cmds though, I just wanted to be able to sync some root folders ^^) that there is a problem with the root access, detecting/writing folders and possibly busy box (which is installed, though I did reinstall just to make sure, and even downloaded one of those verifying tool as well). I'll include some of the log files, as they all contain the same kind of red warning/error messages. Some I keep seeing are these:

    stat: can't stat '/data/data/com.ironhidegames.android.kingdomrushorigins/.*': No such file or directory

    It sure does exist ...
    03-21-2016 06:29 AM

Similar Threads

  1. Replies: 7
    Last Post: 10-29-2018, 12:28 PM
  2. Issues with calculator
    By Mr_B_B in forum Samsung Galaxy S7
    Replies: 17
    Last Post: 11-06-2016, 09:39 PM
  3. Replies: 2
    Last Post: 10-19-2016, 08:38 PM
  4. How to root Samsung J2?
    By Nezzaros in forum Market Help
    Replies: 0
    Last Post: 03-21-2016, 06:24 AM
  5. Replies: 0
    Last Post: 03-21-2016, 04:14 AM