1. askari1992's Avatar
    I have an Huawei honor 6X, 3gb ram, 32 gb internal memory, EMUI 5.0, android 7.0.

    I use google keep for reminders and i really like the way it reminds about stuff, like a text message.

    The problem is that my reminders don't pop when my screen is locked. Only when i unlock the screen all of the pending reminders popup all at once. I have allowed the app to keep running when the screen is turned off but still the problem persists. I think somehow my phone kills the app or some process of it when screen is locked. However, when my wifi in on and screen is locked, it does ring the notification bell which gets suppressed halfway (the notifications do appear on the lock screen this time).


    how do i fix it?
    07-06-2017 12:17 PM
  2. B. Diddy's Avatar
    Any power-saving modes turned on?

    Moved from the Android Apps forum to the Honor 6X forum, since the former is intended for developers to promote their apps.
    07-06-2017 04:38 PM
  3. askari1992's Avatar
    Any power-saving modes turned on?

    Moved from the Android Apps forum to the Honor 6X forum, since the former is intended for developers to promote their apps.
    No. Power saving mode is not turned on.
    07-07-2017 01:36 AM
  4. dpham00's Avatar
    I don't have an honor 6x but I would see if there is a place to specifically white list the app. This may be necessary even with power savings turned off.
    07-07-2017 04:15 PM
  5. wcavaliere88's Avatar
    not sure if this is the reason, but try going into the notification settings and allow calendar to show notification on lock screen and when locked. I would assume that reminders go through the calendar app. hope this helps
    07-07-2017 06:38 PM
  6. dpham00's Avatar
    not sure if this is the reason, but try going into the notification settings and allow calendar to show notification on lock screen and when locked. I would assume that reminders go through the calendar app. hope this helps
    I think that the google keep notifications don't go through the calendar app. With that said,it doesn't hurt to try. Also you can try to allow Google keep to show notifications on the lock screen
    07-08-2017 01:08 AM
  7. B. Diddy's Avatar
    Also, just to be sure, go to Settings>Apps, select Keep, then Notifications, and make sure it's set to show all notification content on the lock screen.
    dpham00 likes this.
    07-08-2017 01:12 PM

Similar Threads

  1. Replies: 7
    Last Post: 07-22-2017, 11:20 AM
  2. Triangle icon in status bar with red dot is not going away
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-06-2017, 12:39 PM
  3. my home , back and recent app button is not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-06-2017, 11:49 AM
  4. Replies: 1
    Last Post: 07-06-2017, 11:38 AM
  5. Replies: 1
    Last Post: 07-06-2017, 11:18 AM
LINK TO POST COPIED TO CLIPBOARD