1. AC Question's Avatar
    My son has an Honor 7 and wants to wear it in a plastic/elastic armband when he goes for a jog. But when he puts the phone in the plastic case, he gets the message "do not cover the top of the screen - Make sure the screen is clean - You can also press the power and volume buttons to disable this mode". But this does not help. Any suggestions?
    12-30-2015 03:37 PM
  2. swebeer's Avatar
    My son has an Honor 7 and wants to wear it in a plastic/elastic armband when he goes for a jog. But when he puts the phone in the plastic case, he gets the message "do not cover the top of the screen - Make sure the screen is clean - You can also press the power and volume buttons to disable this mode". But this does not help. Any suggestions?
    I'm very interested knowing that too.
    01-03-2016 03:49 AM
  3. Kamajabu's Avatar
    Yeah, have same problem. I just turn off blocking but still when I want to change something on phone then I need to fold back top of armband. I think it's impossible to change that without root. Or he can use transparent armband.
    01-22-2016 11:02 AM
  4. AKKW's Avatar
    So would I.
    It's a really really really annoying feature that some muppet of a developer decided to design in.
    I have a transparent armband, and a transparent bike case, and it still does it.
    It's also a pain with the buttons on my P8 to disable it EVERY ********** time GRRRR! :-
    06-15-2016 10:49 AM
  5. anon(9861851)'s Avatar
    Go into Settings, click Smart assistance and inactivate Touch-disable mode

    Posted via the Android Central App
    ninjagammon likes this.
    06-19-2016 04:10 AM
  6. Jessica Tim Hamman's Avatar
    The feature is supposed to be for when you have it in your pocket or in a bag so that you don't butt dial somebody or so it doesn't change your settings or call somebody or charge your account that's what it's for and you can disable that is called touch in your settings so that "Muppet" of a developer actually cure the but the problem other than having a phone lock on or a password cuz a lot of people don't do that we ain't got nothing to hide we put the locks on our PayPal XD you would have been thanking that "muppet" like 10 years ago
    01-26-2017 11:24 AM
  7. SaskiaH1234's Avatar
    I tried the "settings" and click smart assist- but I do not have a smart assist option in my settings..

    Is their any other way I can do this?
    02-07-2017 02:43 AM
  8. Pitfall_Jake's Avatar
    "Smart assist" is just the title of that group of settings selections (on my phone at least). For me the switch to turn it off is the "More..." selection under the smart assist heading.
    02-27-2017 02:34 PM
  9. thisishow's Avatar
    Simultaneously hold the power, and the volume up buttons a few times to disable! :-)
    03-06-2017 07:00 AM
  10. clintbx's Avatar
    Yeah, I'm having this issue too. It wasn't a big deal before but now, it started doing it when its in my bike's phone mount.

    My phone mount doesn't even cover much of the top. Just the corners of the phone. I kinda need out to map check for my courier work.
    03-27-2017 01:19 PM
  11. clintbx's Avatar
    I think I just found it. I'm using a huawei y3ii and under accessibility, I found anti-inadvertently function. Turned it off and now I'm free again.
    03-27-2017 01:25 PM
  12. samir sherwani's Avatar
    Yeah, I'm having this issue too. It wasn't a big deal before but now, it started doing it when its in my bike's phone mount.

    My phone mount doesn't even cover much of the top. Just the corners of the phone. I kinda need out to map check for my courier work.
    Can you disable the "do not cover the top of your phone" msg?-screenshot_2015-01-01-02-16-21.png
    Can you disable the "do not cover the top of your phone" msg?-screenshot_2015-01-01-02-16-29.png
    do as me
    pray for me ^_^
    05-18-2017 02:40 PM
  13. samir sherwani's Avatar
    Smart assistance>> More >> Touch-disable mode
    05-18-2017 04:55 PM
  14. SuperEgor's Avatar
    My son has an Honor 7 and wants to wear it in a plastic/elastic armband when he goes for a jog. But when he puts the phone in the plastic case, he gets the message "do not cover the top of the screen - Make sure the screen is clean - You can also press the power and volume buttons to disable this mode". But this does not help. Any suggestions?
    just disable Settings -> Accessibility - Palm rejection - turn off
    11-01-2017 06:59 PM
  15. emz74's Avatar
    If you have a Huawei Y6 Elite and want to turn off the touch-disable mode.... Go to Settings < Smart Assistance < More < turn off touch-disabled mode. Once you have done this restart your phone or it won't disable. :-)
    11-04-2017 02:16 PM
  16. kikijourney's Avatar
    If you have a Huawei Y6 Elite and want to turn off the touch-disable mode.... Go to Settings < Smart Assistance < More < turn off touch-disabled mode. Once you have done this restart your phone or it won't disable. :-)
    I have the same issue. I don't know why the phone entered the Touch Mode and now even if I restart it or pus simultaneous the volume and power button still remains in that mood.

    Thanks!
    11-05-2017 06:07 AM
  17. brm512's Avatar
    Does anyone know how to disable the touch disable on the Huawei p smart...EMUI 8 I think. I've looked everywhere in the settings and the hold power and volume up just disnakes it for that single time
    04-17-2018 12:43 PM
  18. Wim Boeren's Avatar
    I have a P Smart as well and would like to know the same. There's no touch assistance under the smart assistance menu.
    06-11-2018 11:44 AM
  19. Super Spatman's Avatar
    I also have a P Smart and found this solution on another thread.

    Download the Settings Database Editor app from Google play:

    https://play.google.com/store/apps/d...by4a.setedit22


    In the the System Table screen, scroll down to the bottom towards the 'T' section and find "Touch Disable Mode 1". Tap on it and change it to 0 to turn it off and hit save.

    Worked for me.
    06-26-2018 03:18 AM
  20. HelgenX's Avatar
    @Super Spatman
    Bruh, I signed in to say I love you.
    07-17-2018 08:49 PM
  21. RicaBenhossi's Avatar
    Just to add more info about it, I found the touch-disabled mode option at DISPLAY settings on my Android 7.
    07-27-2018 02:11 PM
  22. tarryn_a's Avatar
    What about android 8? I can't see where to disable it & the volume up & power button combo doesn't work
    07-30-2018 10:26 AM
  23. AbbyMarson's Avatar
    I have a Huawei Y6, not elite, and I've tried everything to fet rid of this because it's so annoying. Under the smart assist section of my settings there is no "more..." option or anything to do with the message that pops up.
    Mine pops up every time I go to unlock my phone even when it has been left face up on a surface so the top of the screen hasn't been covered and it's so annoying
    08-30-2018 04:44 PM
  24. Averan's Avatar
    Just to add that with new updation "Touch-Disable Mode" is now available in P Smart Phone under accessibility (Setting). It was not there before and I suffer too much with no cover issue. Now it is fine.

    Thank you Huawei.
    10-11-2018 09:40 AM

Similar Threads

  1. Replies: 9
    Last Post: 11-09-2018, 06:29 PM
  2. Replies: 1
    Last Post: 12-30-2015, 03:42 PM
  3. S6 Compass not working, how can I get it working?
    By AC Question in forum Samsung Galaxy S6
    Replies: 0
    Last Post: 12-30-2015, 03:33 PM
  4. How do I hard reset my E4?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 12-30-2015, 03:24 PM
  5. Replies: 0
    Last Post: 12-30-2015, 02:58 PM
LINK TO POST COPIED TO CLIPBOARD