1. bardlipped's Avatar
    Hi all, I thought this could be useful for those who like me have looked for a solution to this problem.

    Three days ago I had to carry out a factory reset on my Honor 7 (PLK-1) Android 6.0 smarphone. The result of it was that I couldn't sign into my Google account anymore. The message I was getting after typing in my credentials and agreeing to Google's policies was "Cannot connect to Google servers. Please try later." My smarphone was unable to comunicate with google. A true nightmare, as you may imagine. Unfortunately, nothing of what I found on the net was applicable to my phone.

    However, I won't be annoying you with what troubleshooting steps did not work. I'd like to share WHAT WORKED in my case.

    From Settings-Apps I opened one by one the
    *Google app (Launcher)
    *Gmail app
    *Google Play services app
    *Google Play store app
    and
    1. Cleared the cache
    2.Under "Manage space" hit "Clear Google Search data" and "Clear all data"
    Turned the phone off and on (not "restart")

    and marvelously everything started running as it should!
    I was finaly able to sign into my Google account, Sync my Gmail, Calendar, Maps, Apps ect.

    I hope this article will help you out. If it does, please let me know. Or if you have had any other solution, please add it here.

    Cheers and good luck!
    B. Diddy likes this.
    01-11-2017 10:34 AM
  2. B. Diddy's Avatar
    Welcome to Android Central, and thanks for the tip!
    01-11-2017 03:24 PM
  3. MajestyZ's Avatar
    Great post!
    But, what if this message comes before you install the phone?
    In other words: I gave my phone a factory reset, when it boots the first time, I have to choose a language, then connect to WiFi and after that it'll check my internet connection. It then says 'Cannot connect or communicate with Google servers' and offers me to try again later. It doesn't let me proceed to boot the phone, which is quite annoying as I can't use my phone now.
    Any ideas?
    01-28-2017 10:20 AM
  4. MajestyZ's Avatar
    Found a solution: take out the simcard, reboot and try again.
    01-28-2017 11:28 AM
  5. c3poo's Avatar
    I also have the Voga V bought from gearbest and cannot connect to google service.
    I tried to do it like barlipped said, but it did not solve the problem. I also tried it without simcard, but it doesnt change anything. Another idea how how I can connect with google services?
    04-29-2018 04:35 AM
  6. Drmncazually's Avatar
    I've been trying to fix this problem all day. I'm getting nowhere. Please help with this issue.
    07-13-2018 02:24 AM

Similar Threads

  1. Replies: 1
    Last Post: 03-28-2017, 01:25 PM
  2. Replies: 7
    Last Post: 01-16-2017, 11:06 PM
  3. Replies: 2
    Last Post: 01-11-2017, 04:46 PM
  4. Replies: 0
    Last Post: 01-11-2017, 09:17 AM
  5. Replies: 0
    Last Post: 01-11-2017, 07:48 AM
LINK TO POST COPIED TO CLIPBOARD