1. AC Question's Avatar
    Hi

    I bought my honor 8 two months ago, and it was working fine until this morning. The internet through the wi-fi connection suddenly became slow. It works for my girlfriend's phone, and both of our laptops, and my phone works fine in other wi-fi networks. This problem is only with our home wi-fi. I checked the speed with speedtest app, and after about two minutes of waiting, it showed the right speed, but surfing is painfully slow.
    I did a hard reset on the router, and a cache wipe on my phone, but did not hard reset my phone, because it works on other wi-fi networks.
    So my question is: what do you think is the problem?

    Thank you for your answers!
    01-12-2017 04:44 PM
  2. Guytronic's Avatar
    I'd try rebooting the phone (not resetting) or resetting your home wifi router (unplug wait 10 seconds then plug back in)
    01-12-2017 04:52 PM
  3. p1574's Avatar
    I'm OP

    Thank you, but I already rebooted my phone several times, and even did a cache wipe, and I already rebooted, and resetted the router several times, and still no luck.
    01-12-2017 05:21 PM
  4. Guytronic's Avatar
    Do you have Wi-Fi+ enabled or disabled on the phone?
    01-12-2017 05:34 PM
  5. p1574's Avatar
    Disabled. I always disable my mobile data and enable wi-fi manually when I get home, because my mobile data isn't unlimited.
    01-12-2017 05:41 PM
  6. Guytronic's Avatar
    Are you connected at 2.4 or 5G?

    Sometimes a 5G connection will slow the internet over Wi-Fi.
    p1574 likes this.
    01-12-2017 05:53 PM
  7. p1574's Avatar
    2.4G, and it was good until this morning, and I haven't changed any settings since yesterday.
    01-12-2017 05:58 PM
  8. Guytronic's Avatar
    I'll ask around and see if another 8 user has the answer.

    Maybe someone in Honor 8 forum can figure out what's happening.
    p1574 likes this.
    01-12-2017 06:07 PM
  9. Javier P's Avatar
    Mod note. Thread moved to the Honor 8 fórum.
    Guytronic likes this.
    01-12-2017 07:15 PM
  10. orangecroc's Avatar
    Try getting your phone to "forget" your network and add it again. Or if you can access your router interface, remove your device from the routers device list and then reconnect.
    Guytronic and libra89 like this.
    01-12-2017 07:20 PM
  11. digitalbreak's Avatar
    Do you have a router that has dual band and smart connection feature which switches band automatically for a device based on its usage?

    It could also be a router problem.
    Guytronic, p1574 and libra89 like this.
    01-13-2017 02:24 AM
  12. p1574's Avatar
    My router only has one band, and I didn't find anything about smart connection in the settings, so I guess it doesn't have that feature. Also I did a hard reset on my phone out of frustration, and it didn't help.
    01-13-2017 08:05 AM
  13. dpham00's Avatar
    This is a general guide but perhaps it can help

    https://www.google.com/amp/forums.an...ems.html%3Famp
    p1574 likes this.
    01-13-2017 08:55 AM
  14. p1574's Avatar
    Thank you, but my problem is that the connection is slow on my phone, not that I can't connect. And It was good until yesterday, and no settings have been changed. That's why I don't have a clue about what's the problem.
    01-13-2017 09:33 AM
  15. p1574's Avatar
    Thank you for all your advices, but I honestly tried everything. I hard resetted my router and phone, I went through all the settings, and still the same. At this point I'm just waiting for a miracle.
    01-13-2017 03:46 PM
  16. Tim Chiang's Avatar
    Hi, how did you fix the issue? my phone have the same issue started a couple weeks ago. The wifi is very slow or totally can not open a webpage after a while, while the connection is good, and other devices work very well meanwhile.
    02-17-2017 09:49 AM
  17. madamocta's Avatar
    I don't know if this will help, but the same thing happened on my Sony tablet, can't find a solution (tried factory reset etc). Also happens occasionally on my Honor. Only solution is to turn the WiFi on the device off and then back on. That helps for a few hours. My guess is that the issue is with Android in general, not related to the device, because the issues on my tablet started when I updated to Marshmallow and Honor came with it.
    02-24-2017 04:01 PM

Similar Threads

  1. Inaccurate GPS tracking in cloudy weather on TWO S7's
    By 1812dave in forum Samsung Galaxy S7
    Replies: 7
    Last Post: 01-19-2017, 02:03 PM
  2. Replies: 1
    Last Post: 01-19-2017, 03:57 AM
  3. why is my gs3 acting weird
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-12-2017, 10:42 PM
  4. Replies: 0
    Last Post: 01-12-2017, 04:05 PM
  5. Replies: 1
    Last Post: 01-12-2017, 03:46 PM
LINK TO POST COPIED TO CLIPBOARD