1. SianS95's Avatar
    Hello,
    So recently I've noticed that my phone (dual sim Huawei Honor 8) has been stuck on no service. I'm using the giffgaff network and would usually get 3g/4g signal in my area and nobody that I know on the same network are experiencing any problems.
    I've tried factory resetting the phone and making sure that the correct apn settings are put in but still no luck.
    The only time I have managed to somewhat fix the issue is when I change the slot that the sim card is in and I can manage to have it working in the 2g slot. But as soon as I change the preferences for the slot to 3g/4g the signal disappears.
    So I'm currently just using my phone on 2g which isnt convenient at all!
    It's been like this for almost a month now and is beyond frustrating! It worked perfectly fine before this happened and I can't think of anything would have caused the issue.

    *I've just tested out a SIM from a different network and the same thing is happening, it seems to me that my phone doesn't want to receive 3g/4g signal? As both Sims work okay on 2g but as soon as I select 3g or 4g the signal goes*

    I would be great full for any help!
    Thank you!
    02-18-2017 10:31 AM
  2. Morty2264's Avatar
    I was going to suggest popping your SIM card into another device to see how it fares; but it looks like you've done similar with inputting a SIM from a different network into your device. Have you had the phone for a month? I would contact Honor via their customer service if this continues to happen. Please keep us updated on the situation!
    02-18-2017 10:56 AM
  3. Jared DiPane's Avatar
    May depend on which model of the phone you bought. Not all of them have the same bands. Do you happen to know which variant you have? (check in the settings under about phone)
    02-21-2017 01:35 PM
  4. Morty2264's Avatar
    Any updates on your situation, OP?
    02-21-2017 06:09 PM
  5. manthasm's Avatar
    Hey, I've been having the same issue and wonder if anybody found a fix for this?
    04-24-2017 04:12 AM
  6. orangecroc's Avatar
    This issue almost always fixes itself for me when I restart the phone.
    Morty2264 likes this.
    04-24-2017 03:22 PM
  7. Jai Ct's Avatar
    i think i know why no signal..

    1.only 1 sim can use 4g or 3g data and another one only 2g signal available..
    2.in your country maybe no morw signal 2g.only 3g and above only can use..that why u do not get any signal for 2g sim standby.
    dpham00 and Morty2264 like this.
    12-30-2017 09:18 AM
  8. dpham00's Avatar
    i think i know why no signal..

    1.only 1 sim can use 4g or 3g data and another one only 2g signal available..
    2.in your country maybe no morw signal 2g.only 3g and above only can use..that why u do not get any signal for 2g sim standby.
    That is a good point. If your carrier isn't broadcasting in a supported band then it would look like you have no signal
    Morty2264 likes this.
    12-30-2017 11:21 AM

Similar Threads

  1. Why is security tighter with the latest software upgrade
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 02-19-2017, 03:16 AM
  2. Am I having problems getting online with Android 7
    By RoslynL in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 02-19-2017, 03:08 AM
  3. Instagram logo does not update to new one (Huawei P8)
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-18-2017, 10:07 AM
  4. Why am i not able to download previously downloaded apps?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-18-2017, 09:46 AM
  5. Replies: 0
    Last Post: 02-18-2017, 06:52 AM
LINK TO POST COPIED TO CLIPBOARD