1. Robert Lau's Avatar
    Guys, Google play services is killing my battery. I have done
    1. Factory Reset
    2. Tried Installing Google Play Beta Services
    3. Uninstalling almost every app I own
    4. Turn off GPS/Location Services
    5. I Just sent my phone to Huweii (It is an Honor 8) and they sent me it back.

    SInce getting my phone back I have installed a very select few apps. The first and Second day my batter was amazing, just what i remembered (at the end of a day I had 40 or 50%). Then this morning at 6:30 AM I took it off the charger, and it is now 8 AM and my batter has drained more than 10%.

    I will include a picture below, PLEASE anyone with any ideas let me know.

    I am running
    EMUI 5.0.1
    Android 7.0
    Attached Thumbnails Google Play Services Killing My Battery.... STILLL-screen-shot-2018-01-31-8.00.53-am.png  
    01-31-2018 09:07 AM
  2. Ayush Rao's Avatar
    Guys, Google play services is killing my battery. I have done
    1. Factory Reset
    2. Tried Installing Google Play Beta Services
    3. Uninstalling almost every app I own
    4. Turn off GPS/Location Services
    5. I Just sent my phone to Huweii (It is an Honor 8) and they sent me it back.

    SInce getting my phone back I have installed a very select few apps. The first and Second day my batter was amazing, just what i remembered (at the end of a day I had 40 or 50%). Then this morning at 6:30 AM I took it off the charger, and it is now 8 AM and my batter has drained more than 10%.

    I will include a picture below, PLEASE anyone with any ideas let me know.

    I am running
    EMUI 5.0.1
    Android 7.0
    Can you please upload this page.....
    01-31-2018 09:29 AM
  3. wcavaliere88's Avatar
    Just a thought, prob not the cause but can't hurt. are there any pending updates, go to the play store then my apps in the overflow menu. thinking maybe a pending app update is causing this. maybe you can turn off the option to have check for updates automatically.
    Morty2264 likes this.
    01-31-2018 06:15 PM
  4. dpham00's Avatar
    After doing a factory data reset, did you still have the problem even before installing any third party apps?
    Morty2264 likes this.
    01-31-2018 09:12 PM
  5. Morty2264's Avatar
    How long have you had the phone? Have you tried using it in Safe Mode to see if the issue persists? If so, it might not be Google Play that is the culprit. Keep us posted!
    02-01-2018 10:02 AM

Similar Threads

  1. App not on my Android smart phone
    By 5-Card-Major in forum Ask a Question
    Replies: 2
    Last Post: 01-31-2018, 02:38 PM
  2. How do I move data stored on my SD card back to phone
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-31-2018, 11:16 AM
  3. When I open Google photo editor the filters area is blank
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-31-2018, 10:57 AM
  4. Replies: 1
    Last Post: 01-31-2018, 07:56 AM
  5. Why can't I log into the Wish App from my Galaxy Note 8?
    By Android Central Question in forum Ask a Question
    Replies: 8
    Last Post: 01-31-2018, 12:29 AM
LINK TO POST COPIED TO CLIPBOARD