07-08-2014 09:17 AM
50 12
  1. ncinerate's Avatar
    I'm reposting this here for any lingering people who haven't moved back over to the webosnation forum for android on the touchpad. This may not be the most updated version of this post, with new updates coming to the post you can find here:


    So you're ready to start dabbling with CM9 but don't know where to start? Allow me to be your guide! Please note that these instructions are subject to rapid change as CM9 receives upgrades from it's alpha status in the coming days/weeks/months. This guide is accurate as of 1/20/2012 and will be updated reasonably frequently to keep it relevant.

    I hope this helps! I appreciate the kind words, find your generosity to be amazing and hope this guide continues to help all of our dual-booting members! A lot of time and effort have went into this post and your appreciation keeps me motivated to continue my work here. I will be updating the post soon with more fun tricks, tips, improvements, and app reviews!

    Before you install this, please do some reading to understand the current limitations of the android ALPHA (it is -not- a totally stable or bug-free release). If you decide you still want to give it a shot, read on.


    STEP 0: Is your touchpad ready to install Android?

    Make sure your touchpad is in developer mode and that you have novacom installed on your computer. One of the best ways to ensure this is simply to follow my Getting Started guide for webOS, as it will improve your webOS experience and in the process will ensure your computer can properly communicate with the touchpad before you attempt android install. You can find that guide here:


    Also, take time to read about the current CM9 android offerings and make sure it's something you actually want to pursue. Android is in an extreme alpha state, and while it is running remarkably well on the touchpad even now, it is still not recommended for all users (AKA - it may be better to wait on a more stable release).

    Relevant reading:

    [Release][Alpha0] CyanogenMod 9 Touchpad - RootzWiki


    STEP 1: Assemble the various files you will need to install CM9. This list is current through 1/20/2012 - do not follow these instructions if a new ALPHA or BETA has been released.

    First, you need several files from here:
    [Release][Alpha0] CyanogenMod 9 Touchpad - RootzWiki


    CM9 Alpha 0
    Techerrata Downloads - Downloading update-cm-9.0.0-RC0-Touchpad-alpha0-fullofbugs.zip


    New ACMEInstaller
    goo-inside.me - acmeinstaller downloads

    Downloads - moboot - Mobile Open Bootloader for the HP Touchpad - Google Project Hosting

    Charger and SystemUI force close fix for alpha0

    And lastly, you'll want a version of google apps that will work on your Touchpad, you can find that here:

    Multiupload.com - upload your files to multiple file hosting sites!

    And a google apps fix file that will enable calendar syncing:

    Multiupload.com - upload your files to multiple file hosting sites!


    Step 2: Prepare the Touchpad for installation.

    To prepare the Touchpad for installation, you must first plug the touchpad into your computer as a USB drive and there are several files we must transfer to the device.

    When you plug your touchpad into the computer and put it in USB mode, then explore the touchpad as a USB drive, it is automatically in the /media/internal folder.

    Into this folder, you are going to drag and drop the following files:

    Charger and SystemUI force close fix for alpha0
    -BOTH- google apps files we downloaded in step 1

    Now that that's been handled, you need to right click anywhere on the screen and create a new directory. Simply right click anywhere on the file explorer screen, and create a new directory named:


    If you've followed directions, you will now have a folder named CMinstall in the same directory that you've dropped the three files we just discussed.

    Now, double click into this directory. You should now be inside the empty CMinstall directory. You are going to drag and drop several of the .zip files you downloaded in step 1. Place into this CMinstall directory the following ZIP files:

    CM9 alpha 0

    Now you can eject your touchpad. At this point, you need to put your touchpad into bootie recovery USB mode. To do this, turn your touchpad off. Now that it is off, turn it on, and as soon as it begins to turn on, hold down the volume-up rocker button until a USB symbol appears on the screen. Finally, plug your touchpad into your computer via the USB cable. Your touchpad is now prepared to install Android.


    Step 3: Prepare windows to install Android.

    First, you need to move your ACMEInstall2 file to a directory that you can easily find it. I suggest making a directory on the root of your hard drive for this purpose. For example:

    To do this, simply go into explorer, click on your hard drive, right click on the pane with the folders, and create a directory called android. Now drag and drop (or cut/paste) your ACMEInstall2 file into this directory.

    Now, it's time to actually install CM9. Click on the start menu at the bottom left of your screen, then in the search bar (or in the start/run bar for those still using XP), type:


    Now hit enter. This will bring up a black-screen terminal window. First, you're going to need to navigate to the place that you placed the ACMEInstall2 file. If you're following this guide, you do this by typing:

    cd /android

    Finally, we are ready to install. To do so, cut/paste the following line into your CMD terminal window:

    novacom boot mem:// < ACMEInstaller2

    If you've done everything right, your touchpad will go dark, then begin filling up with text as it installs the various bits and pieces to get everything working. Pat yourself on the back, the hard part is over. You still need to fix some things however, so before the touchpad boots back up, quickly begin preparing for step 4



    Ok, your touchpad is getting everything installed, but you're going to need to fix a few things before it will be as useful as you might like. When the touchpad finishes installing it's going to reboot into MOBOOT, a place that allows you to select which operating system you would like to use (webOS or cyanomod). You select between these by using the volume rocker, then hitting the home button to select. On your first boot-up you don't want EITHER of these options - you want to boot into CLOCKWORKMOD. Be ready when the touchpad begins to boot up, and immediately put it into clockworkmod.

    Now that you're in clockworkmod, you need to select "install zip from sdcard". You navigate this menu with your volume rocker and your home/power buttons. Simply use the volume rocker to go down to select install zip, and hit the home key to select.

    Select "choose zip from sdcard".

    Now scroll down until you see the three files we put on the touchpad earlier (the charging-fix, the google apps file, and the google apps fix).

    Install them in that order. Charging fix, google apps, google apps fix.

    Now hit the power button a few times to get back to the main screen and choose to "reboot system now".

    Finally, allow the system to boot into CM9.


    Step 5: Do you want webOS to boot by default?

    One annoying thing about installing android is it sets up MOBOOT to automatically boot into android if you turn your touchpad on and leave it sit for a few seconds. I much prefer my touchpad to boot into webOS.

    To do this, boot back into webOS and go into preware, then search for the application named:


    Install it, then launch this program. now you can easily change the settings of moboot. Set the boot default to webOS and you're golden. You can also change the bootloader timeout to anywhere between 1 and 9 seconds. Set it to a slightly higher amount of seconds (I find 7 seconds is the sweet spot) and now you'll be auto-booting into webOS and have a slightly greater amount of time for any selections when MOBOOT loads.


    Step 6: Learn some useful tricks...

    I'll just dump a few useful tricks here.

    For starters - if you want to transfer files back and forth from the CM9 touchpad you might have difficulty figuring out how exactly to do it. Here's how you pull it off:

    First, tap on your app drawer in the top right of the screen (the little checkerboard). Now, select the "settings" icon.

    Now tap on storage on the left-hand pane.

    Finally, the tricky part - tap on the 3 squares at the VERY top right of your screen. It will bring down a little drop-down menu for USB computer connection. Tap it and put a checkmark in the "Media Device MTP" box.

    Now you can plug your touchpad into the computer at will and transfer files back and forth from it. Easy as pie, I'm not sure why this isn't activated by default, but it's a simple fix if you know what to do.


    Step 7: There is no step 7, yet...

    You are now dual-booting CM9 and ready to enjoy testing it out. There will be more tweaks/steps/suggestions to come as the build becomes more stable and complete, but for now it works reasonably well and should provide you with a nice experience. Feel free to go into the android marketplace and find some cool android-only programs to experience. One I recommend you give a shot is Google Currents - it's free and a brilliant news reader. Almost every game/app I've tested seems to work well on my touchpad, so feel free to fiddle around with it.

    Future updates to CM9 can be installed very easily from clockworkmod, simply download them on the touchpad and install them from clockworkmod as we described above. This will keep you current and enjoying the latest updates.
    01-20-2012 03:59 PM
  2. atulmodi's Avatar
    Really excellent steps described. I gone through multiple posts. And they had info but not in the way explained here.
    01-20-2012 05:58 PM
  3. hopper75's Avatar
    I'm reposting this here for any lingering people who haven't moved back over to the webosnation forum for android on the touchpad.
    I guess I've been away too long, are we now able to post freely over on the other site without mods jumping all over it? What happened to PreCentral anyway? Thanks for yet another great guide by the way!
    01-20-2012 08:27 PM
  4. Mutoidi's Avatar
    Good install.. nice OS system!
    This feels really smooth.. listings are less tortuous than CM7.. a great Tablet OS in the making in fact!!!
    ...Watch out 'webOS'!!!

    Only 'glitch' I had was with CM9 setting Android to boot-default in Preware's 'CyBoot' (which I didn't notice), then when I set 'next boot' in CyBoot also to Android, I got stuck in an Android booting-loop and unable to reboot webOS, until I used Acme Installer to reinstall Clockwork.. that then gave me access to again set webOS as default and 'next boot' to 'choose' (from MoBoot Menu Options).

    I think a CM9 option to reboot to webOS (as in CM7) would be 'polite' - on the TouchPad version anyway!

    01-21-2012 03:35 AM
  5. hanly2's Avatar
    Is there instructions onupgrading from cm7 to cm9? Will I lose all of my apps if I upgrade?
    01-22-2012 05:27 PM
  6. Gman2222's Avatar
    Is there instructions onupgrading from cm7 to cm9? Will I lose all of my apps if I upgrade?
    Didn't lose any of my apps and I didn't do any backups.
    01-22-2012 05:44 PM
  7. mahler9's Avatar
    thanks for that Cyboot tip... works for me
    01-22-2012 05:50 PM
  8. hanly2's Avatar
    Didn't lose any of my apps and I didn't do any backups.
    Ok so how did you upgrade?
    01-22-2012 06:53 PM
  9. Gman2222's Avatar
    Ok so how did you upgrade?
    novacom boot mem:// < ACMEInstaller2

    then I flashed the charge fix, gapps, and gapps fix.
    01-22-2012 10:40 PM
  10. hanly2's Avatar
    ok so I need to download all of the files in that list and then just put them in the same places as the old ones?
    01-23-2012 03:01 PM
  11. keeganleach's Avatar
    Ok how do i download the files that are from Multiuploads?
    01-23-2012 09:08 PM
  12. Gman2222's Avatar
    ok so I need to download all of the files in that list and then just put them in the same places as the old ones?
    Yup. Only new files I needed for installation were AcmeInstaller2 and gapps/fixes.
    01-23-2012 11:49 PM
  13. Mutoidi's Avatar
    Ok how do i download the files that are from Multiuploads?
    I guess you have to head down to the FBI, nuke their offices, fly to New Zealand, liberate the chief dude, get the codes back to him and then try again?

    OR head to a different download site?

    DemonHighwayman likes this.
    01-24-2012 12:30 AM
  14. DemonHighwayman's Avatar
    CM9 Alpha 0.5 is out now guys.
    crutzulee likes this.
    01-24-2012 05:33 AM
  15. hanly2's Avatar
    Ok I just installed cm9 right over my cm7 install and it seems to be working, the only problems are I don't know how to use it. How do I get to the settings? so I can set up wifi and stuff?

    Ok figured that part out. Now I can't get email to work, it just keeps stopping and closing as soon as I open it. Anyone else?
    01-24-2012 06:26 PM
  16. DemonHighwayman's Avatar
    Ok I just installed cm9 right over my cm7 install and it seems to be working, the only problems are I don't know how to use it. How do I get to the settings? so I can set up wifi and stuff?

    Ok figured that part out. Now I can't get email to work, it just keeps stopping and closing as soon as I open it. Anyone else?
    If I remember correctly, email is in the list of stuff that isn't working yet.
    01-25-2012 05:18 AM
  17. crutzulee's Avatar
    Wiped cache and davlik and installed right over cm 9 alpha 0 yesterday. No crashes in almost 24 hours of moderate use.
    Wifi has been stable. Battery seems mildly improved. Adfree now works! Browsing with Opera mobile is great (some people are reporting increased touch sensitivity leading to unintentional zoom - not for me) .
    As I type this on thumb keyboard, I'm finding it to be more accurate. I was always sure that it was me and my bad typing skills but maybe there has been some improvement?
    Thumb keyboard was causing some intermittent crashing of Opera mobile on alpha 0 forcing a reboot. This has not happened yet under alpha 0.5.
    01-25-2012 11:21 AM
  18. atulmodi's Avatar
    I have issue with my TP.

    I am with CM on TP since the day of very first.

    Now problem starts today.

    I have CM9 (Not 0.5) and otherwise working excellent, but won't give me option of WebOS, Clockworkmod, shutdown etc.

    To me looks like moboot is screwed up. I had moboot 3.0.5 (latest necessary for CM9).

    How to fix this problem now. I am not big fan of WebOS but I need moboot to make any upgradation etc.

    If no moboot means no access to Clockworkmod and no way to go for any upgradation
    and can not acces WebOs any otherway. Because it reboot in Android only.
    01-27-2012 08:04 PM
  19. P_Yiddy's Avatar
    Reboot and then hold down the power button and home button. Should bring the boot menu back
    01-27-2012 09:17 PM
  20. atulmodi's Avatar
    Thanks, It works great and after I get into moboot menu and tried couple of tomes in and out of WebOs and Android and it worked Power+Home button trick way.

    At an end I run Installer2 by hooking up with computer and put moboot in cminstall and after Installer 2 installed moboot. It is rock again.

    So I think, other people may have this problem. Moboot screwed up itself.
    01-28-2012 11:40 AM
  21. aviatordoc's Avatar
    Had CM7 before, but I think I have screwed something up now.
    After entering the bootie menu (big USB) and am running the ACMEInstaller2 properly but nothing happens. For a long time. so I eject ,remove the USB and reboot using center button and power, but now have only WebOS boot up. Cannot access moboot.
    What can I do? Or what am i doing wrong?
    01-28-2012 01:55 PM
  22. aviatordoc's Avatar
    well got it done. Problem wa with the novacom.
    Went the other route \program files\Palm, Inc\ novacom boot mem.... all went smooth as silk.
    randy5290 likes this.
    01-28-2012 05:28 PM
  23. atulmodi's Avatar
    With CM9 I am keep getting message when I power off and power on.

    "Unfortunately, Search has stopped"

    I couldn't figure out which app or what basic program has issue going on.

    I did uninstall and reinstall CM9 with complete clean data and cache. No different result.

    Do other users has same issue going on?

    How to fix this error?

    Its not big deal, but if can fix it, good.
    01-31-2012 09:01 AM
  24. Mutoidi's Avatar
    'dalingrin' estimates no more 'Alpha' updates nec. for CM9 now..
    'Nightly' updates instead anyone? Presumably until 'Beta' status is reached.
    Create backup of existing install first of course!

    Here is the most recent at time of posting:
    May fix (or create!) a few 'issues'

    Techerrata Downloads - Downloading update-cm-9.0.0-tenderloin-KANG-20120216-040001-signed.zip

    @ https://twitter.com/#!/cm_tenderloin


    Full File Download-List:



    Gerrit Code Review


    With Big thanks to all the Crews!

    02-16-2012 09:24 AM
  25. Mutoidi's Avatar
    02-21-2012 03:09 PM
50 12