1. Paul Ahlbrandt's Avatar
    Today I wiped my Touchpad with TPtoolbox, installed CM11 4.4.2 with standard gapps and philz recovery. Everything was working great and going smooth until I tried to use a USB Logitech G11 keyboard and a wireless G700 mouse with the dongle attached to the keyboard. The touchpad will recognize the first device installed to the OTG cable but nothing else I plug into it unless the first device is removed. Let me give some examples of things I have tried

    ****OTG Y cable (1 male Micro USB, 1 Female Micro USB power input, 1 Female USB) powered by PC or AC Power supply***

    -TP>OTG>Keyboard>Mouse dongle = Keyboard input only

    -TP>OTG>Non powered USB hub>Keyboard + Mouse = input based on first device plugged in, if both are plugged in when I plug in the hub, they keyboard always loads first but the mouse does work when keyboard is removed.

    -TP>OTG>Non powered USB hub> Keyboard + wireless mini keyboard/mouse combo (Rii i8) + USB flash drive = Everything works, I can type with both the USB keyboard and the mini keyboard with functional mini mouse pad as well as access USB storage. However, when I add any type of dedicated mouse, be it my G700 or wired usb G500, neither work unless I remove the other two input devices.

    Notes: The OTG cable itself works fine using several devices, whether it be flash drives, external hdd, keyboards including a Rii i8 wireless keyboard/mouse combo (touch pad feature works as a mouse with the keyboard, probably because its considered one device.) but I cannot get it to work with a dedicated mouse in conjunction with a keyboard. If I remove the keyboard, again the mouse works fine on its own. If I have the mouse plugged in first, the mouse will work find but the keyboard will not.

    Additionally, I tried to get my USB Xbox 360 controller to be recognized as well on its own but that is not working. I have ensured the correct files are present but it blinks once and then goes off so that's another issue I am trying to solve.

    Some of you might be asking, why use a dedicated mouse if I can get the mouse pad on my mini keyboard to work? Gaming


    Does anyone have any ideas or a solution? Its driving me insane and I really want it to work with what I have. I even tried making a DIY OTG cable, same results haha.

    Thanks again, cheers!

    Paul
    01-04-2015 10:30 PM

Similar Threads

  1. Replies: 10
    Last Post: 03-02-2015, 12:43 PM
  2. Replies: 2
    Last Post: 02-13-2015, 06:29 PM
  3. Nexus 7 stuck in a softbrick/bootloop cannot fix, any help?
    By thesk8guy in forum Google Nexus 7 Tablet (2013)
    Replies: 8
    Last Post: 01-16-2015, 08:29 PM
  4. Replies: 5
    Last Post: 01-07-2015, 08:17 AM
  5. Sending pictures uses mobile data
    By enzie5454 in forum Samsung Galaxy Note 3
    Replies: 4
    Last Post: 01-06-2015, 03:43 AM
LINK TO POST COPIED TO CLIPBOARD