1. bradfish06's Avatar
    I've noticed every time I try to use Google maps (usually on my commute, trying to see traffic), as soon as I put in the destination, the phone can't find GPS. I get this "searching for GPS" message and a grey arror instead of the blue one. Sometimes it finds it after a minute or so and sometimes it never finds it.

    Did not have this problem with the Samsung S4 I just upgraded from, so its not a location or vehicle issue. Anyone else experiencing this? Hoping it just requires a phone or maps update (related, is there any way to report this, either to HTC or to google, to make sure it gets addressed?)

    Possible that it is the case I am using, interfering somehow? I will maybe try without the case.

    BTW I have location on the highest accuracy setting, using GPS, WiFi, bluetooth and LTE.

    Thanks!
    Jordan
    05-13-2016 12:35 PM
  2. Rukbat's Avatar
    Try this:

    Open the Phone, as if you were going to make a phone call and dial -
    *#9090# -- Diagnostic Configuration (*#197328640# if that doesn't work)
    Menu, select Key Input, enter Q
    Menu, select Key Input, enter 0000
    wait for the next menu. (It takes a while.)
    UMTS->COMMON->NV REBUILD->NV REBUILD->SYSTEM->PROTOCOL->GPS->IMS
    or, if you don't have UMTS:
    UE SETTINGS & INFO->SETTING->SYSTEM->NV REBUILD->ALL

    Restart the phone.
    05-13-2016 12:44 PM
  3. Cosnietak's Avatar
    I have HTC 10 from two weeks, and have same problem, i try "only GPS mode" in location settings, move phone from case, upgrade google maps, and nothing helped. Problem is only with Google Maps, i hope that HTC as soon as possible fix this problem - it's finally a flagship model.
    05-19-2016 04:22 PM
  4. Cosnietak's Avatar
    Information update: Problem witch GPS also appears in other applications that use GPS as Endomondo, TomTom navigation, etc. It seems like gps module get suspended after few minutes. In GPS TEST app I've got information that no satellite is "in use".
    05-24-2016 04:51 AM
  5. ibleedbloo's Avatar
    There is an app called GPS status which will monitor how many satellites you have connection to. Perhaps it can help you diagnose further.

    Posted via the Android Central App
    05-24-2016 04:53 AM
  6. VladMorosanu's Avatar
    Same problem with my HTC 10 bought from Orange, Romania.

    In 15 minutes time I get disconnected about 3-4 times. When that happens, I've noticed that I lose mobile signal as well. Blackout is between 30 seconds to several minutes. When it finally works again, it takes several minutes to get back to 4G+, usually stays under H (Data).

    I'm thinking of sending it back. I've used several other phones successfully in exactly the same place in exactly the same car, never had problems until now.

    I've owned a Galaxy S4, Xperia Z3, LG G4, same car, only the HTC has issues.
    06-19-2016 12:10 PM
  7. Mike Dee's Avatar
    Same problem with my HTC 10 bought from Orange, Romania.

    In 15 minutes time I get disconnected about 3-4 times. When that happens, I've noticed that I lose mobile signal as well. Blackout is between 30 seconds to several minutes. When it finally works again, it takes several minutes to get back to 4G+, usually stays under H (Data).

    I'm thinking of sending it back. I've used several other phones successfully in exactly the same place in exactly the same car, never had problems until now.

    I've owned a Galaxy S4, Xperia Z3, LG G4, same car, only the HTC has issues.
    This is also happening with a lot of LG G5s

    Posted via the Android Central App
    06-21-2016 05:49 PM
  8. Jerouk's Avatar
    Thanks for this suggestion - for the curious amongst us could you please confirm what this is doing?

    Cheers

    J
    10-19-2016 05:39 AM
  9. iooiuk's Avatar
    Try turning off power saver. Works with Android auto. So no reason it won't work with maps.
    Garretbandroid likes this.
    11-30-2016 03:51 AM
  10. Garretbandroid's Avatar
    This worked for me!
    06-07-2017 03:26 PM
  11. Destined627's Avatar
    Yeah my navigation sucks. Everytime I try to use it, the GPS signal is lost and it doesn't navigate....super annoying. I have no idea why. Location is on and power saver is not on, so that isn't it.
    08-20-2017 04:24 AM

Similar Threads

  1. S6 edge battery problem
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 05-13-2016, 02:26 PM
  2. Golf GPS
    By slacker74 in forum Samsung Gear S2
    Replies: 1
    Last Post: 05-12-2016, 11:54 PM
  3. GPS Setting on HTC 10
    By Timomsu in forum HTC 10
    Replies: 1
    Last Post: 05-12-2016, 10:34 PM
  4. Anyone having multiple problems with your Note 5?
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 05-12-2016, 08:14 PM
  5. Moto e 2nd gen as and sys app problems
    By Jeannie Holmes in forum Moto E (2015)
    Replies: 0
    Last Post: 05-12-2016, 05:14 PM
LINK TO POST COPIED TO CLIPBOARD