1. Filip777's Avatar
    I have a question. I have "keep WIFI on during sleep" option set to "Never".

    When I wake up my phone from sleep after 30 minutes or more of not using it, the wifi does not reactivate itself (it's off, no wifi icon in statusbar), but when I go to settings, it says that Wifi is enabled. Just like in the picture below...

    I want to know if this is normal or what? Happens to me on both stock and custom rom.
    Attached Thumbnails WiFi not reactivating after sleep-screenshot_20160913-161304.jpg  
    09-16-2016 11:17 AM
  2. cbreze's Avatar
    Not normal although I'm not rooted. I have my wifi set to 2.4GHz which gives me better range. Not sure if this would help you or not. My wifi stays on all nite and does not shut itself off whether sleeping or not.
    09-16-2016 01:08 PM
  3. Filip777's Avatar
    My wifi is set to 2.4 as well.
    If your wifi stays enabled the whole night, then you have "keep WIFI on during sleep" option set to Always. If not, then you have a problem with wifi not disabling itself.

    Anyone else with this issue, wifi not reactivating after sleep with "keep WIFI on during sleep" option set to "Never or plugged" ??
    09-16-2016 01:27 PM
  4. cbreze's Avatar
    Is there some reason you don't want it on when in sleep mode?
    09-16-2016 01:39 PM
  5. Filip777's Avatar
    Is there some reason you don't want it on when in sleep mode?
    Yes, I have no need for it to be enabled when in sleep mode + it definitely saves battery this way.

    But I don`t understand why it doesn`t reactivate itself after I "wake up" my phone. It says that wifi is enabled, but when I go for example to Play store, it says no connection, so I have to manually switch wifi off and then on.
    09-16-2016 01:44 PM
  6. cbreze's Avatar
    Understand your problem, but leaving mine on all the time seems to use negligible amount of power. Usually average about 4% over an 8 hour nite. I've always left it on with all other phones as well. Was never an issue. Hope you sort it out.
    09-16-2016 01:49 PM
  7. chin chen's Avatar
    I have the same issue. I put it on sleep mode today and after activating it again, the wifi didnt work, although i was connected and had signal. I needed to put wifi off and then on, it worked again. I do think the Htc 10 has some wifi issues and if you google it, it shows that some people have similar problems. Kind of annoying. My phone also disconnects randomly during the day, and i have to do the same again, sometimes it works and sometimes it doesnt. After a while it works again magically, but i dont know how to solve the issue.
    09-16-2016 08:16 PM
  8. Filip777's Avatar
    I have the same issue. I put it on sleep mode today and after activating it again, the wifi didnt work, although i was connected and had signal. I needed to put wifi off and then on, it worked again. I do think the Htc 10 has some wifi issues and if you google it, it shows that some people have similar problems. Kind of annoying. My phone also disconnects randomly during the day, and i have to do the same again, sometimes it works and sometimes it doesnt. After a while it works again magically, but i dont know how to solve the issue.
    So it`s not just me huh. This is a software bug.
    Are you fully stock (1.90.401.5. firmware) ?
    09-17-2016 06:50 AM
  9. chin chen's Avatar
    So it`s not just me huh. This is a software bug.
    Are you fully stock (1.90.401.5. firmware) ?
    Yes. Tried out the 2.4 Ghz connection, no difference to me. Happened again this morning. Just a few minutes ago the connection slowed down for some reason, now it is good again.
    09-17-2016 08:26 AM
  10. Filip777's Avatar
    Yes. Tried out the 2.4 Ghz connection, no difference to me. Happened again this morning. Just a few minutes ago the connection slowed down for some reason, now it is good again.
    If you set 2.4 GHz on your phone while using the same frequency, it should boost the wifi signal a bit. Though I have no problems with Wifi dropouts, and my router is 2 thick walls (2 rooms) away from me (15m).

    I think that a factory reset could maybe fix this problem with WiFi not reactivating...
    09-17-2016 08:46 AM
  11. Filip777's Avatar
    @chin chen , I fixed this by putting my Wi-Fi frequency band from 2.4 GHz to "Automatic" in advanced wifi settings. Htc and google really need to fix their ****!

    btw. I also disabled ipv6 in my router settings, so Im not sure if this helped too.
    09-18-2016 06:42 AM
  12. chin chen's Avatar
    @chin chen , I fixed this by putting my Wi-Fi frequency band from 2.4 GHz to "Automatic" in advanced wifi settings. Htc and google really need to fix their ****!

    btw. I also disabled ipv6 in my router settings, so Im not sure if this helped too.
    So you did the exact opposite, from 2.4Ghz to automatic 😀

    The 2 things i read about helpibg were going to 2.4 Ghz and disabling ipv6. I will try that out too in the evening.
    Filip777 likes this.
    09-18-2016 11:10 AM

Similar Threads

  1. Greenify not auto-hibernating Apps
    By fordhamtroll in forum Samsung Galaxy S7 edge
    Replies: 8
    Last Post: 09-19-2016, 05:34 PM
  2. anyone having problems with their S-pen not working correctly with note 7?
    By Amirofthedesert in forum Samsung Galaxy Note 7
    Replies: 10
    Last Post: 09-19-2016, 02:53 PM
  3. Why I my app post is not getting published?
    By Jainutechnologies in forum Android Apps
    Replies: 3
    Last Post: 09-19-2016, 12:04 AM
  4. Productivity apps do not run in background
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-16-2016, 10:42 AM
LINK TO POST COPIED TO CLIPBOARD