1. Mugenized's Avatar
    The preinstalled Amazon app on my HTC 10 is on version 8.2.100 and doesn't update. Whenever I use it, I get the prompt to update and when I click on the button to do so, it just opens another page in the app but doesn't give me an update option. From what I can tell, this app is actually the Amazon Underground app from a while back. Installing the Amazon shopping app from the Play Store (version 12.xx) doesn't remove or change the preinstalled app either. Does anyone have the same issue or a solution for this? Thanks.
    07-06-2017 07:38 AM
  2. SpookDroid's Avatar
    The Amazon app (not the shopping one), since it allows you to access apps, is not available through the Play Store and cannot be updated 'natively'. You need to manually download from the Amazon site (which is probably the page it's taking you when you hit 'update') and manually install from there (you need to allow installation from 'unknown sources' as well; it should prompt you to enable if it's not).
    07-06-2017 08:35 AM
  3. Mugenized's Avatar
    Yeah, I'm aware that this is the one that isn't in the Play Store. When I click to update it from the app's prompt, it brings me to the app's page within the app itself but the only option that pops up is Open, not update. I already have the install from unknown sources checked as well.
    07-06-2017 09:54 AM
  4. SpookDroid's Avatar
    07-06-2017 11:06 AM
  5. Mugenized's Avatar
    It's weird, I tried that route before. First, I opened that link with the app and it brings me to the same page in the app itself where it only gives me the option to open. If I open it in my browser and I click to download, it'll just launch the Amazon app which puts me in the same situation. Thanks for the suggestion, though.

    Not sure what the deal is. I've cleared all cache and data and that didn't help. Has anyone else have this happen with the stock Amazon app on their 10?
    07-06-2017 11:16 AM
  6. SpookDroid's Avatar
    Clear defaults from the Amazon app (so that the download doesn't open the app). You need to download the APK. If you want, try it on your computer and transfer the APK to your phone. Then install there.
    07-06-2017 11:19 AM
  7. Mugenized's Avatar
    Thanks, not sure why it didn't occur to me to open the d/l link on another tab but I did just that and I was able to install the APK. I think it's the latest version (12.2.0.200) but it still says an upgrade is available and puts me back in the same loop as before. Whatever, at least it's not 4 full versions older!
    SpookDroid likes this.
    07-06-2017 11:30 AM
  8. SpookDroid's Avatar
    Maybe it's an update to an app you have installed? or to the Amazon video app?
    07-06-2017 11:54 AM
  9. Mugenized's Avatar
    Nope, the only other Amazon app I have is Amazon Music and that was recently updated through the Play Store. I thought it might've been due to the preinstalled Kindle app that I disabled but I enabled it and it was updated by the Play Store.
    07-06-2017 12:55 PM
  10. SpookDroid's Avatar
    Weird. Have you tried clearing the app's cache? Or maybe uninstalling (if possible) and re-installing now that you have the APK?
    07-06-2017 02:22 PM
  11. Mugenized's Avatar
    Yeah, I tried clearing all data and I can't completely uninstall it since it was baked into my VZW 10's ROM.
    07-06-2017 02:51 PM
  12. Geezerb's Avatar
    This is happening with all devices. It's a problem with Amazon. I have paid apps that are not working anymore due to this glitch. Can't get my work email.
    07-07-2017 10:44 AM

Similar Threads

  1. Enhanced features update looks suspicious
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-10-2017, 10:03 AM
  2. Replies: 1
    Last Post: 07-06-2017, 10:43 AM
  3. Cannot access my Motorola as Android is constantly updating.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-06-2017, 07:39 AM
  4. Replies: 1
    Last Post: 07-06-2017, 06:58 AM
  5. Replies: 0
    Last Post: 07-06-2017, 06:34 AM
LINK TO POST COPIED TO CLIPBOARD