02-04-2018 12:22 PM
58 123
tools
  1. BoxingKanga's Avatar
    Hi I have a Honor v10 running Oreo. Today no matter what app I attempt to download after i accept the terms and conditions I get a 404 error.
    I have cleared the data and cache in play services and play store plus the data multiple times and restarted the phone several times with the same error.

    Can anyone assist?
    menpar and Brandon Wang like this.
    02-03-2018 12:38 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! You're getting a 404 error while using the Google Play Store app? You're not on the Play Store website on your browser, are you?
    02-03-2018 01:26 AM
  3. BoxingKanga's Avatar
    using the play store app, which I have uninstalled and re-installed since posting the question and still getting the same error
    02-03-2018 01:46 AM
  4. B. Diddy's Avatar
    That's strange. Does it happen on both wi-fi and mobile data?
    02-03-2018 01:50 AM
  5. BoxingKanga's Avatar
    Yes, i first noticed it on Mobile but it also happens on wifi either home and a public network
    02-03-2018 02:02 AM
  6. BoxingKanga's Avatar
    Just discovered that I can't update apps either, same error
    02-03-2018 02:32 AM
  7. EddyQuest's Avatar
    Me and my wife are having the exactly same problem.

    It started yesterday.

    I have a Huawei Mate 10 Pro and she has a Huawei P10.
    02-03-2018 06:07 AM
  8. jiong zou's Avatar
    My mate 10(Chinese version) has the exact same problem start from yesterday. Yesterday evening I can update via a VPN, but now VPN also doesn't work.
    02-03-2018 08:08 AM
  9. Kasunt's Avatar
    Hey i have the same problem.I recently updated my STF-AL10(honor 9) to oreo and now i cannot update or install apps from playstore.It gives me error 404
    Tryed full factory reset,reinstalling playstore and play services,changing network settings.But nothing works
    Subi Nukta likes this.
    02-03-2018 10:17 AM
  10. Blulue's Avatar
    I'm on exactly the same boat from yesterday. Huawei p10 plus, Chinese version, with or without VPN, Wi-Fi or mobile network, many times of cleaning data/cache and restarting, still the same error. Seems like the problem is on Google's side. Thanks guys, at least I could go to sleep without further struggling

    My mate 10(Chinese version) has the exact same problem start from yesterday. Yesterday evening I can update via a VPN, but now VPN also doesn't work.
    02-03-2018 10:25 AM
  11. Ahmed Hafed's Avatar
    Hi, I have exactly the same error 404 with my Nokia 7 (Andorid 8.0.0)
    Tried factory reset, un-install and re0install playstore and play services both WifI and mobile data.
    NOTHING!!!

    Any help ?
    02-03-2018 10:25 AM
  12. singhnsk's Avatar
    Hi, I have exactly the same error 404 with my Nokia 7 (Andorid 8.0.0)
    Tried factory reset, un-install and re0install playstore and play services both WifI and mobile data.
    NOTHING!!!

    Any help ?
    Facing the same issue on my Nokia 7 as well. Anything you got yet?
    02-03-2018 10:44 AM
  13. Koncors's Avatar
    Hi all. Same issue. Huawei mate 9. Tried to reinstall Play Market and even backed to previous versions, all the same.
    Few days ago new updates were installed on my phone.. I think the problem is there
    02-03-2018 11:05 AM
  14. singhnsk's Avatar
    Hi all. Same issue. Huawei mate 9. Tried to reinstall Play Market and even backed to previous versions, all the same.
    Few days ago new updates were installed on my phone.. I think the problem is there
    Mine was working fine till this morning. The play store version was still the same. No phone software updates were installed.
    So, it looks to me like a backend change Google made which affects uncertified devices.
    02-03-2018 11:19 AM
  15. Koncors's Avatar
    Oh.. my Play Market shows my device is CERTIFIED!
    02-03-2018 11:26 AM
  16. singhnsk's Avatar
    Oh.. my Play Market shows my device is CERTIFIED!
    Then my wrong guess :| Is your device imported from another country? Just checking if this is to do something.
    02-03-2018 11:42 AM
  17. M Panezai's Avatar
    I have the same problem
    Google won't let me login my account
    Nothing is working
    Google says they won't login my account until Google play services are updated while I try to update it it says errors
    someone help us
    02-03-2018 11:45 AM
  18. Koncors's Avatar
    Then my wrong guess :| Is your device imported from another country? Just checking if this is to do something.
    Yes, from another, but not sure that may cause this issue..
    02-03-2018 12:56 PM
  19. Rukbat's Avatar
    404 on the internet (wifi or mobile data) says "page not found". If it happens on a system like Google's Play servers, I'd suspect the local Play server (Google maintains many servers around the world for the same service). I've used play a few times already today (updated a few apps). About the only thing possible might be to try resetting your DNS servers. Use wifi, but set the address manually. (Long-press the connection, then check Advanced.) Use the same IP address it shows, but change the DNS addresses to 8.8.8.8 for the first one and 8.8.4.4 for the second one. Their DNS server should have the correct address for their Play server. (I use those addresses on all my devices, so maybe that's why I'[m not having any problems.)
    02-03-2018 01:00 PM
  20. singhnsk's Avatar
    I don't think that the Play Store's 404 means the same as what we use for the internet pages.
    Anyhow, my ISP by default uses the Google DNS servers. Also, all other devices in the house work fine. The only difference between theirs and mine is that mine was imported from another country. So, I suspect something like a mismatched location causing this error.
    02-03-2018 01:08 PM
  21. Koncors's Avatar
    Yes, confirm, all other divices feel fine. Though I'm not sure about their buying location..
    02-03-2018 01:27 PM
  22. dtfyg's Avatar
    404 on the internet (wifi or mobile data) says "page not found". If it happens on a system like Google's Play servers, I'd suspect the local Play server (Google maintains many servers around the world for the same service). I've used play a few times already today (updated a few apps). About the only thing possible might be to try resetting your DNS servers. Use wifi, but set the address manually. (Long-press the connection, then check Advanced.) Use the same IP address it shows, but change the DNS addresses to 8.8.8.8 for the first one and 8.8.4.4 for the second one. Their DNS server should have the correct address for their Play server. (I use those addresses on all my devices, so maybe that's why I'[m not having any problems.)
    I've tried changing the primary and secondary DNS for my wifi but it still gave me an error 404. I've also tried using an app (DNset) to change my DNs, but although I don't have the error, it still doesn't download.
    02-03-2018 02:27 PM
  23. Koncors's Avatar
    I tried vpn, logout from all devices in google, changing pass.. and no result
    02-03-2018 02:35 PM
  24. nexus38's Avatar
    My mate 10(Chinese version) has the exact same problem start from yesterday. Yesterday evening I can update via a VPN, but now VPN also doesn't work.
    Exactly the same issue except the my device is mate9. I have re-installed the Google Play Store and Google Play Services and I also tried factory reset but that fixing attempts are not worked.
    02-03-2018 03:52 PM
  25. fred_yu_job's Avatar
    it looks like Google just changed it's Google play service, and some phone didn't catch this up?
    and the phone from HuaWei hit the most
    02-03-2018 04:05 PM
58 123

Similar Threads

  1. Replies: 2
    Last Post: 05-04-2018, 05:44 AM
  2. I cant change the storage to SD card in my Samsung Galaxy tab 4
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-03-2018, 01:29 AM
  3. Contacts showing pictures from wrong version
    By Bob Smiley in forum General Help and How To
    Replies: 1
    Last Post: 02-03-2018, 01:28 AM
  4. Replies: 0
    Last Post: 02-02-2018, 11:43 PM
  5. samsung S8 has the best UI
    By snowboarders in forum Samsung Galaxy S8 & S8+
    Replies: 0
    Last Post: 02-02-2018, 11:18 PM
LINK TO POST COPIED TO CLIPBOARD