1. Android Central Question's Avatar
    I was sitting here browsing snapchat on my htc10 when I got a message at the bottom of my screen for about a second before my phone rebooted itself. This thing has been a nightmare for about a year now, so I didn't think much of it. I immediately reopened snapchat and found it had logged me out. Facebook, twitter, etc were still signed in. Once I got back in the message came back but there was no crash or logging out this time, so I grabbed a screenshot. It reads:

    Instantiate action error - java.lang.ClassNotFoundExeption: Invalid name: com.woodslink.android.wiredheadphoneroutingfix.action.internal, Unknown, version 0.0.HDMI_PLUGGED

    The end of that seems strange to me, being that my phone was not connected to anything via HDMI, USB, aux or even bluetooth. It sounds to me like a missing tag from an update, except none of my apps have had one in several days (except the play store, which annoyingly decided to do one while I was trying to troubleshoot this). Also, this error has not come back since I got the screenshot.

    I then noticed it did not automatically reconnect to the wifi as it normally does (home network). Furthermore, I can't get it to connect. I enter the password and get two messages: "Failed to save network" and "Failed to connect". I did this several times before checking on my pc to see if the password was changed. Nope, same.

    I can't say for sure if the error has anything to do with this, but I find it suspicious that it happened at the same time. I also can't find any information on it. Lots of threads for a similar error with things other than "HDMI_PLUGGED" at the end. I've tried the cookie cutter fixes for those - wiping cache, uninstalling soundabout (which I did have), resetting network settings, booting in safe mode, etc. No dice. I also tried uninstalling snapchat and every new app I've gotten in the past few months.

    Still can't get on the wifi. As much as I loved the m7, I fully regret getting the 10. It's been a headache since new. Might just dig the old one out.

    And keep it as far away from Oreo as possible.
    06-27-2018 07:42 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! You could try reinstalling the firmware. If you got the phone from Verizon, that should be pretty easy if you use the Software Repair Assistant. Otherwise, try the steps described here for downloading the ROM and manually installing it: https://forums.androidcentral.com/e?...token=N-THkDs3
    06-28-2018 01:11 PM
  3. Montgomerywenis's Avatar
    I was sitting here browsing snapchat on my htc10 when I got a message at the bottom of my screen for about a second before my phone rebooted itself. This thing has been a nightmare for about a year now, so I didn't think much of it. I immediately reopened snapchat and found it had logged me out. Facebook, twitter, etc were still signed in. Once I got back in the message came back but there was no crash or logging out this time, so I grabbed a screenshot. It reads:

    Instantiate action error - java.lang.ClassNotFoundExeption: Invalid name: com.woodslink.android.wiredheadphoneroutingfix.action.internal, Unknown, version 0.0.HDMI_PLUGGED

    The end of that seems strange to me, being that my phone was not connected to anything via HDMI, USB, aux or even bluetooth. It sounds to me like a missing tag from an update, except none of my apps have had one in several days (except the play store, which annoyingly decided to do one while I was trying to troubleshoot this). Also, this error has not come back since I got the screenshot.

    I then noticed it did not automatically reconnect to the wifi as it normally does (home network). Furthermore, I can't get it to connect. I enter the password and get two messages: "Failed to save network" and "Failed to connect". I did this several times before checking on my pc to see if the password was changed. Nope, same.

    I can't say for sure if the error has anything to do with this, but I find it suspicious that it happened at the same time. I also can't find any information on it. Lots of threads for a similar error with things other than "HDMI_PLUGGED" at the end. I've tried the cookie cutter fixes for those - wiping cache, uninstalling soundabout (which I did have), resetting network settings, booting in safe mode, etc. No dice. I also tried uninstalling snapchat and every new app I've gotten in the past few months.

    Still can't get on the wifi. As much as I loved the m7, I fully regret getting the 10. It's been a headache since new. Might just dig the old one out.

    And keep it as far away from Oreo as possible.
    Apart from your being logged out, this exact thing just happened to me about two hours ago. I also have the HTC 10 and have been having frequent problems with it since it came out of the box. It's been shutting down and (sometimes) restarting at ~20% battery for awhile, but today it just shut off at ~40%. I tried turning it back on but it wouldn't start up. Plugged it in and started it up to see it was already at 49%. But I didn't notice it wasn't connecting to my wifi for awhile. It gives me the same errors:

    Failed to save network
    Failed to connect to network

    My wifi works fine. My PS4 and Xbox work fine using it. The router and modem are fine.

    I've tried everything I could think of and everything the internet had to offer, including that in other similar situations, a full factory reboot was needed to amend the error. I don't want to do that. I need a better solution. Help us please.
    11-01-2018 06:53 PM
  4. kistjo's Avatar
    Had same problem, and changed 'Keep Wi-Fi on during sleep' to 'Always'
    11-02-2018 12:34 PM

Similar Threads

  1. Transfer photos from camera to phone
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2018, 08:30 PM
  2. Send text message thread to email in one 1 forward.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 06-27-2018, 08:20 PM
  3. Did HTC predictive text get a lot worse at some point, or is it just me?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-27-2018, 06:50 PM
  4. I can't get my doogee x10 to reboot it just goes to no command what do i do ?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2018, 05:42 PM
  5. My call log won't display. Samsung Galaxy s3.
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-27-2018, 04:40 PM
LINK TO POST COPIED TO CLIPBOARD