1. timbrown527's Avatar
    Ok. First of all, I'm new here so please understand if this question doesn't appear in the right place.

    I have an HTC 10, with android 7. Recently, my phone decided to go into airplane mode. I can try to deactivate that, but it doesn't get past "shutting down airplane mode".

    Twice I have done a factory restart on the phone. the first time I was putting files back on and noticed that it reactivated airplane mode and was stuck that way.

    I tried another factory restart but that didn't work until after I left the phone off all night. The next morning, I did another factory reset. It was ok. I let the phone stay on all day but turned it off last night. It was fine at that point.

    Tonight I turned it back on...and it went back into airplane mode and is stuck again. I had done *NOTHING* to the phone after the factory reset. Just turned it off and then back on today. Period.

    I have had this phone going on a year and this didn't appear until this past week.

    Could it be an update that is now being added to my phone that is doing this? If so, how can you find out what it is without wasting lots of time on this? Is there a way to roll back the whole phone at once to see if that reveals the problem???

    Thanks in advance. As it is, I'm back on my Samsung convoy 3 flip phone...so I'm not totally cut off.
    12-02-2018 08:25 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I moved this from the Nougat forum to the HTC 10 forum, since it sounds like more of a device-specific issue, rather than a general Nougat one.

    Does this also happen in Safe Mode? https://support.t-mobile.com/docs/DOC-25901
    12-03-2018 01:55 AM
  3. timbrown527's Avatar
    Welcome to Android Central! I moved this from the Nougat forum to the HTC 10 forum, since it sounds like more of a device-specific issue, rather than a general Nougat one.

    Does this also happen in Safe Mode? https://support.t-mobile.com/docs/DOC-25901
    Yes. I've done it again just to confirm since I have done a factory reset since.

    Signal icon has a line through it...and when you open up "Settings" and look at "Airplane Mode", it says "turning off". Stuck that way.

    Thanks.
    12-03-2018 10:18 AM
  4. B. Diddy's Avatar
    It's either a firmware or hardware issue. If it's firmware, you'd have to reinstall the stock ROM. Are you on Verizon or a different network? If it's Verizon, you can try their Software Repair Assistant.
    12-03-2018 11:23 AM
  5. timbrown527's Avatar
    It's a Verizon phone, on StraightTalk.
    12-03-2018 08:58 PM
  6. B. Diddy's Avatar
    Ok, then try the Software Repair Assistant. It might act like a factory reset, so make sure you backup your important data first.
    12-04-2018 12:50 AM
  7. timbrown527's Avatar
    Ok, then try the Software Repair Assistant. It might act like a factory reset, so make sure you backup your important data first.
    Ok, I never heard of the SRA, but I did a search. Looks like it's necessary to connect my phone to a Windows machine (I use Linux). I'll have to get things set up and give it a shot.

    SIDE NOTE: Turned on my phone this morning and the signal was back for some time. When I noticed it, I rebooted it to see what would happen...and it's whacked out again.

    I'll give the SRA a try and get back with you. Thanks!
    B. Diddy likes this.
    12-04-2018 10:22 AM
  8. timbrown527's Avatar
    Ok, then try the Software Repair Assistant. It might act like a factory reset, so make sure you backup your important data first.
    Update: The phone appears (so far) to have straightened itself out somehow (update perhaps?). I am not going to reactivate it yet...because i don't yet trust it.

    What I will do is try running the SRA on it. The only question I have at this point is, if the symptoms are gone, will it detect an issue at all....

    So that's where we stand. I'll update when I get a chance to run the SRA.

    I hate non-reproducable problems.

    Thanks again.
    12-05-2018 10:29 PM
  9. B. Diddy's Avatar
    I'd just sit tight until/unless the problem happens again, then go ahead with the software repair.
    12-05-2018 10:30 PM
  10. BruceCk's Avatar
    Could it be bad contact on the SIM card? Worth shutting down and removing, cleaning the contacts and trying again.
    12-11-2018 03:01 PM
  11. timbrown527's Avatar
    Could it be bad contact on the SIM card? Worth shutting down and removing, cleaning the contacts and trying again.
    I finally have a Windows computer here I can load the SRA into (I normally use Linux)...Been using my flip phone but the HTC seems to be ok for the most part...except for a few cases.

    Going to run the SRA on it just to see what it reports. And, since I'm not sure if I have reseated the SIM card, I'll do that too.
    12-28-2018 03:47 PM

Similar Threads

  1. My samsung galaxy s7 is sharing my personal info with contacts
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-03-2018, 02:15 AM
  2. How do I put 33 names and emails in group called breakfast club
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-03-2018, 01:58 AM
  3. Cast Moto G6 -> Microsoft 10 PC
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 12-02-2018, 05:02 PM
  4. I no longer receive & sounds for my emails and text messages
    By Chilimama in forum General Help and How To
    Replies: 1
    Last Post: 12-02-2018, 04:16 PM
  5. text issues
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-02-2018, 04:14 PM
LINK TO POST COPIED TO CLIPBOARD