1. o4liberty's Avatar
    I have had the Eris for almost two weeks and it seems to be very lagy anymore any suggestions?
    12-18-2009 08:31 PM
  2. redman213's Avatar
    do you use Task Killer? Also try deleting some apps you dont use if you have a lot and restart your device.
    12-18-2009 10:00 PM
  3. IzelTokatl's Avatar
    I've been using mine for 2 weeks roughly. I haven't noticed that the number of apps installed causes the lag. What I do notice is the apps that are running in the background tend to be the issue(just like on a PC). Most apps you turn on don't turn themselves off. You'll need any one of the various App closing programs out there.

    my personal favorite so far
    Automatic Task Killer - automatically kills specific task you define at the screen turn off time.
    Advanced Task Killer - you manually kill apps as you deem necessary

    When my phone starts to get lag I just kill off some apps I am not using. You may notice that some apps turn on, on their own. You'll have to manually go into those apps and go into their settings to see if they are always on or enabling in specific scenarios. programs like LastFM and Locale will turn themselves on randomly. LastFM does it when use the scrobbling features. Locale was cool but I didn't like the processor drain so I uninstalled it.

    Just like what happens on your PC the more things you've got running the harder you'll push the processor to share its resources slowing things down.
    12-21-2009 01:17 PM